summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2009-03-08 18:14:25 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2009-03-08 18:14:25 +0000
commit25217f87622650cb2cedf05244c4d090701e6b26 (patch)
tree6b8b4714f46d2139367a85ee10728f35f25e209d /dev-ruby/rmagick
parentamd64/x86 stable, bug #260516 (diff)
downloadgentoo-2-25217f87622650cb2cedf05244c4d090701e6b26.tar.gz
gentoo-2-25217f87622650cb2cedf05244c4d090701e6b26.tar.bz2
gentoo-2-25217f87622650cb2cedf05244c4d090701e6b26.zip
Migrate to EAPI 2.
(Portage version: 2.2_rc20/cvs/Linux 2.6.29-rc6 i686)
Diffstat (limited to 'dev-ruby/rmagick')
-rw-r--r--dev-ruby/rmagick/ChangeLog7
-rw-r--r--dev-ruby/rmagick/rmagick-1.15.15.ebuild26
-rw-r--r--dev-ruby/rmagick/rmagick-1.15.17.ebuild26
-rw-r--r--dev-ruby/rmagick/rmagick-2.6.0.ebuild22
-rw-r--r--dev-ruby/rmagick/rmagick-2.9.0.ebuild20
-rw-r--r--dev-ruby/rmagick/rmagick-2.9.1.ebuild21
6 files changed, 51 insertions, 71 deletions
diff --git a/dev-ruby/rmagick/ChangeLog b/dev-ruby/rmagick/ChangeLog
index 70dca18cbbdf..9a0c843ff5a3 100644
--- a/dev-ruby/rmagick/ChangeLog
+++ b/dev-ruby/rmagick/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rmagick
# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rmagick/ChangeLog,v 1.137 2009/03/07 08:00:23 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rmagick/ChangeLog,v 1.138 2009/03/08 18:14:25 betelgeuse Exp $
+
+ 08 Mar 2009; Petteri Räty <betelgeuse@gentoo.org> rmagick-1.15.15.ebuild,
+ rmagick-1.15.17.ebuild, rmagick-2.6.0.ebuild, rmagick-2.9.0.ebuild,
+ rmagick-2.9.1.ebuild:
+ Migrate to EAPI 2.
07 Mar 2009; Hans de Graaff <graaff@gentoo.org> rmagick-2.9.0.ebuild,
rmagick-2.9.1.ebuild:
diff --git a/dev-ruby/rmagick/rmagick-1.15.15.ebuild b/dev-ruby/rmagick/rmagick-1.15.15.ebuild
index 72a87f1b556a..7b872f2aec7d 100644
--- a/dev-ruby/rmagick/rmagick-1.15.15.ebuild
+++ b/dev-ruby/rmagick/rmagick-1.15.15.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rmagick/rmagick-1.15.15.ebuild,v 1.6 2008/12/13 16:28:41 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rmagick/rmagick-1.15.15.ebuild,v 1.7 2009/03/08 18:14:25 betelgeuse Exp $
+
+EAPI="2"
inherit ruby
@@ -17,25 +19,17 @@ LICENSE="Artistic"
SLOT="0"
KEYWORDS="alpha amd64 hppa ia64 ~mips ppc ppc64 sparc x86"
IUSE="examples doc"
+# hdri causes extensive changes in the imagemagick internals, and
+# rmagick is not ready to deal with those, see bug 184356.
DEPEND="virtual/ruby
- >=media-gfx/imagemagick-6.0"
+ >=media-gfx/imagemagick-6.0[-hdri]"
S=${WORKDIR}/RMagick-${PV}
-# hdri causes extensive changes in the imagemagick internals, and
-# rmagick is not ready to deal with those, see bug 184356.
-pkg_setup() {
- if built_with_use --missing false media-gfx/imagemagick hdri ; then
- eerror "imagemagick is built with the hdri USE flag, this is not supported by rmagick"
- eerror "please rebuild imagemagick without hdri support if you want to use rmagick"
- die "imagemagick is built with the hdri USE flag, this is not supported by rmagick"
- fi
-}
-
# Using a custom src_compile instead of the ruby one because the ruby
# one gets confused by an additional setup.rb that should not be used
# here.
-src_compile() {
+src_configure() {
myconf="${RUBY_ECONF} ${EXTRA_ECONF}"
# When documentation is built many examples are also run. Not all
@@ -56,7 +50,9 @@ src_compile() {
--with-ruby=${RUBY} \
${myconf} \
"$@" || die "econf failed"
+}
+src_compile() {
ruby_emake "$@" || die
}
@@ -72,5 +68,5 @@ src_install() {
${RUBY_ECONF} || die "setup.rb install failed"
cd "${S}"
- dodoc ChangeLog README.html README-Mac-OSX.txt README.txt
+ dodoc ChangeLog README.html README-Mac-OSX.txt README.txt || die
}
diff --git a/dev-ruby/rmagick/rmagick-1.15.17.ebuild b/dev-ruby/rmagick/rmagick-1.15.17.ebuild
index 4d77b5e1cd09..e388043c5cae 100644
--- a/dev-ruby/rmagick/rmagick-1.15.17.ebuild
+++ b/dev-ruby/rmagick/rmagick-1.15.17.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rmagick/rmagick-1.15.17.ebuild,v 1.1 2008/12/06 10:09:11 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rmagick/rmagick-1.15.17.ebuild,v 1.2 2009/03/08 18:14:25 betelgeuse Exp $
+
+EAPI="2"
inherit ruby
@@ -17,25 +19,17 @@ LICENSE="Artistic"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
IUSE="examples doc"
+# hdri causes extensive changes in the imagemagick internals, and
+# rmagick is not ready to deal with those, see bug 184356.
DEPEND="virtual/ruby
- >=media-gfx/imagemagick-6.0"
+ >=media-gfx/imagemagick-6.0[-hdri]"
S=${WORKDIR}/RMagick-${PV}
-# hdri causes extensive changes in the imagemagick internals, and
-# rmagick is not ready to deal with those, see bug 184356.
-pkg_setup() {
- if built_with_use --missing false media-gfx/imagemagick hdri ; then
- eerror "imagemagick is built with the hdri USE flag, this is not supported by rmagick"
- eerror "please rebuild imagemagick without hdri support if you want to use rmagick"
- die "imagemagick is built with the hdri USE flag, this is not supported by rmagick"
- fi
-}
-
# Using a custom src_compile instead of the ruby one because the ruby
# one gets confused by an additional setup.rb that should not be used
# here.
-src_compile() {
+src_configure() {
myconf="${RUBY_ECONF} ${EXTRA_ECONF}"
# When documentation is built many examples are also run. Not all
@@ -56,7 +50,9 @@ src_compile() {
--with-ruby=${RUBY} \
${myconf} \
"$@" || die "econf failed"
+}
+src_compile() {
ruby_emake "$@" || die
}
@@ -72,5 +68,5 @@ src_install() {
${RUBY_ECONF} || die "setup.rb install failed"
cd "${S}"
- dodoc ChangeLog README.html README-Mac-OSX.txt README.txt
+ dodoc ChangeLog README.html README-Mac-OSX.txt README.txt || die
}
diff --git a/dev-ruby/rmagick/rmagick-2.6.0.ebuild b/dev-ruby/rmagick/rmagick-2.6.0.ebuild
index ef440ba56936..8f27853631a4 100644
--- a/dev-ruby/rmagick/rmagick-2.6.0.ebuild
+++ b/dev-ruby/rmagick/rmagick-2.6.0.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rmagick/rmagick-2.6.0.ebuild,v 1.6 2008/12/13 16:28:41 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rmagick/rmagick-2.6.0.ebuild,v 1.7 2009/03/08 18:14:25 betelgeuse Exp $
+
+EAPI="2"
inherit ruby
@@ -18,21 +20,13 @@ LICENSE="Artistic"
SLOT="0"
KEYWORDS="alpha amd64 hppa ia64 ~mips ppc ppc64 sparc x86"
IUSE="examples doc"
+# hdri causes extensive changes in the imagemagick internals, and
+# rmagick is not ready to deal with those, see bug 184356.
DEPEND="virtual/ruby
- >=media-gfx/imagemagick-6.3.5.6"
+ >=media-gfx/imagemagick-6.3.5.6[-hdri]"
S="${WORKDIR}/RMagick-${PV}"
-# hdri causes extensive changes in the imagemagick internals, and
-# rmagick is not ready to deal with those, see bug 184356.
-pkg_setup() {
- if built_with_use --missing false media-gfx/imagemagick hdri ; then
- eerror "imagemagick is built with the hdri USE flag, this is not supported by rmagick"
- eerror "please rebuild imagemagick without hdri support if you want to use rmagick"
- die "imagemagick is built with the hdri USE flag, this is not supported by rmagick"
- fi
-}
-
# Use a custom src_compile because the setup.rb included with RMagick
# doesn't like extra parameters during the setup phase.
src_compile() {
@@ -62,7 +56,7 @@ src_install() {
${RUBY} setup.rb install --prefix="${D}" || die "setup.rb install failed"
cd "${S}"
- dodoc ChangeLog README.html README-Mac-OSX.txt
+ dodoc ChangeLog README.html README-Mac-OSX.txt || die
use examples && dodoc examples/*
}
diff --git a/dev-ruby/rmagick/rmagick-2.9.0.ebuild b/dev-ruby/rmagick/rmagick-2.9.0.ebuild
index 6566dd3b6134..7927e16dcd63 100644
--- a/dev-ruby/rmagick/rmagick-2.9.0.ebuild
+++ b/dev-ruby/rmagick/rmagick-2.9.0.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rmagick/rmagick-2.9.0.ebuild,v 1.5 2009/03/07 08:00:23 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rmagick/rmagick-2.9.0.ebuild,v 1.6 2009/03/08 18:14:25 betelgeuse Exp $
+
+EAPI="2"
inherit ruby
@@ -18,23 +20,15 @@ LICENSE="Artistic"
SLOT="0"
KEYWORDS="~alpha ~amd64 hppa ~ia64 ~mips ~ppc ppc64 sparc ~x86"
IUSE="examples doc"
+# hdri causes extensive changes in the imagemagick internals, and
+# rmagick is not ready to deal with those, see bug 184356.
RDEPEND="virtual/ruby
- >=media-gfx/imagemagick-6.3.5.6"
+ >=media-gfx/imagemagick-6.3.5.6[-hdri]"
DEPEND="${RDEPEND}
doc? ( virtual/ghostscript media-libs/libwmf )"
S="${WORKDIR}/RMagick-${PV}"
-# hdri causes extensive changes in the imagemagick internals, and
-# rmagick is not ready to deal with those, see bug 184356.
-pkg_setup() {
- if built_with_use --missing false media-gfx/imagemagick hdri ; then
- eerror "imagemagick is built with the hdri USE flag, this is not supported by rmagick"
- eerror "please rebuild imagemagick without hdri support if you want to use rmagick"
- die "imagemagick is built with the hdri USE flag, this is not supported by rmagick"
- fi
-}
-
# Use a custom src_compile because the setup.rb included with RMagick
# doesn't like extra parameters during the setup phase.
src_compile() {
@@ -65,7 +59,7 @@ src_install() {
${RUBY} setup.rb install --prefix="${D}" || die "setup.rb install failed"
cd "${S}"
- dodoc ChangeLog README.html README-Mac-OSX.txt
+ dodoc ChangeLog README.html README-Mac-OSX.txt || die
use examples && dodoc examples/*
}
diff --git a/dev-ruby/rmagick/rmagick-2.9.1.ebuild b/dev-ruby/rmagick/rmagick-2.9.1.ebuild
index 73ac5b226711..6b283e663693 100644
--- a/dev-ruby/rmagick/rmagick-2.9.1.ebuild
+++ b/dev-ruby/rmagick/rmagick-2.9.1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rmagick/rmagick-2.9.1.ebuild,v 1.2 2009/03/07 08:00:23 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rmagick/rmagick-2.9.1.ebuild,v 1.3 2009/03/08 18:14:25 betelgeuse Exp $
+
+EAPI="2"
inherit ruby
@@ -18,23 +20,16 @@ LICENSE="Artistic"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
IUSE="examples doc"
+
+# hdri causes extensive changes in the imagemagick internals, and
+# rmagick is not ready to deal with those, see bug 184356.
RDEPEND="virtual/ruby
- >=media-gfx/imagemagick-6.3.5.6"
+ >=media-gfx/imagemagick-6.3.5.6[-hdri]"
DEPEND="${RDEPEND}
doc? ( virtual/ghostscript media-libs/libwmf )"
S="${WORKDIR}/RMagick-${PV}"
-# hdri causes extensive changes in the imagemagick internals, and
-# rmagick is not ready to deal with those, see bug 184356.
-pkg_setup() {
- if built_with_use --missing false media-gfx/imagemagick hdri ; then
- eerror "imagemagick is built with the hdri USE flag, this is not supported by rmagick"
- eerror "please rebuild imagemagick without hdri support if you want to use rmagick"
- die "imagemagick is built with the hdri USE flag, this is not supported by rmagick"
- fi
-}
-
# Use a custom src_compile because the setup.rb included with RMagick
# doesn't like extra parameters during the setup phase.
src_compile() {
@@ -65,7 +60,7 @@ src_install() {
${RUBY} setup.rb install --prefix="${D}" || die "setup.rb install failed"
cd "${S}"
- dodoc ChangeLog README.html README-Mac-OSX.txt
+ dodoc ChangeLog README.html README-Mac-OSX.txt || die
use examples && dodoc examples/*
}