summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-02-24 08:44:12 +0000
committerHans de Graaff <graaff@gentoo.org>2013-02-24 08:44:12 +0000
commit99cae18216e61cfe14efedf8fa8c07df44a26179 (patch)
treecff31e00d0aeeefb70fe82b7b183c54da22cd2ca /dev-ruby/rspec-expectations
parentVersion bump. (diff)
downloadgentoo-2-99cae18216e61cfe14efedf8fa8c07df44a26179.tar.gz
gentoo-2-99cae18216e61cfe14efedf8fa8c07df44a26179.tar.bz2
gentoo-2-99cae18216e61cfe14efedf8fa8c07df44a26179.zip
Version bump.
(Portage version: 2.1.11.50/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/rspec-expectations')
-rw-r--r--dev-ruby/rspec-expectations/ChangeLog8
-rw-r--r--dev-ruby/rspec-expectations/rspec-expectations-2.13.0.ebuild45
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-ruby/rspec-expectations/ChangeLog b/dev-ruby/rspec-expectations/ChangeLog
index d721a28b1e6e..b6f8d5d36a4b 100644
--- a/dev-ruby/rspec-expectations/ChangeLog
+++ b/dev-ruby/rspec-expectations/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/rspec-expectations
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-expectations/ChangeLog,v 1.51 2013/02/24 08:10:36 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-expectations/ChangeLog,v 1.52 2013/02/24 08:44:12 graaff Exp $
+
+*rspec-expectations-2.13.0 (24 Feb 2013)
+
+ 24 Feb 2013; Hans de Graaff <graaff@gentoo.org>
+ +rspec-expectations-2.13.0.ebuild:
+ Version bump.
24 Feb 2013; Hans de Graaff <graaff@gentoo.org>
-rspec-expectations-2.10.0.ebuild, -rspec-expectations-2.11.3.ebuild:
diff --git a/dev-ruby/rspec-expectations/rspec-expectations-2.13.0.ebuild b/dev-ruby/rspec-expectations/rspec-expectations-2.13.0.ebuild
new file mode 100644
index 000000000000..5a5524b3b097
--- /dev/null
+++ b/dev-ruby/rspec-expectations/rspec-expectations-2.13.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-expectations/rspec-expectations-2.13.0.ebuild,v 1.1 2013/02/24 08:44:12 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="http://rspec.rubyforge.org/"
+SRC_URI="https://github.com/rspec/${PN}/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/diff-lcs-1.1.3"
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/rspec-core-2.11.0:2
+ dev-ruby/rspec-mocks:2
+ )"
+
+all_ruby_prepare() {
+ # Don't set up bundler: it doesn't understand our setup.
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+
+ # Remove the Gemfile to avoid running through 'bundle exec'
+ rm Gemfile || die
+
+ # fix up the gemspecs
+ sed -i \
+ -e '/git ls/d' \
+ -e '/add_development_dependency/d' \
+ "${RUBY_FAKEGEM_GEMSPEC}" || die
+}