summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-28 12:21:48 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-28 12:21:48 +0000
commit2b4931dd8529efa4be5ab2edc7c078925e271c06 (patch)
treea0a6d489235c12e90ef97abcef12b3bce2cf1f7d /dev-ruby/ruby-bz2/ruby-bz2-0.2.2-r1.ebuild
parentRevision bump to enable all tests, and add proper dependencies. Tests are dis... (diff)
downloadgentoo-2-2b4931dd8529efa4be5ab2edc7c078925e271c06.tar.gz
gentoo-2-2b4931dd8529efa4be5ab2edc7c078925e271c06.tar.bz2
gentoo-2-2b4931dd8529efa4be5ab2edc7c078925e271c06.zip
Replace ebuild with a ruby-ng one, only support Ruby 1.8 as that's the only version supported. Closes bug #292275.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/ruby-bz2/ruby-bz2-0.2.2-r1.ebuild')
-rw-r--r--dev-ruby/ruby-bz2/ruby-bz2-0.2.2-r1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/dev-ruby/ruby-bz2/ruby-bz2-0.2.2-r1.ebuild b/dev-ruby/ruby-bz2/ruby-bz2-0.2.2-r1.ebuild
new file mode 100644
index 000000000000..cbdc84ed8078
--- /dev/null
+++ b/dev-ruby/ruby-bz2/ruby-bz2-0.2.2-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-bz2/ruby-bz2-0.2.2-r1.ebuild,v 1.1 2010/01/28 12:21:48 flameeyes Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18"
+
+inherit ruby-ng
+
+MY_P="${P/ruby-}"
+
+DESCRIPTION="Ruby interface to libbz2"
+HOMEPAGE="http://moulon.inra.fr/ruby/bz2.html"
+SRC_URI="ftp://moulon.inra.fr/pub/ruby/${MY_P}.tar.gz"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="doc"
+
+S="${WORKDIR}/${MY_P}"
+
+RDEPEND="app-arch/bzip2"
+DEPEND="${RDEPEND}"
+
+each_ruby_configure() {
+ ${RUBY} extconf.rb || die "extconf failed"
+}
+
+each_ruby_compile() {
+ emake || die "emake failed"
+
+ if use doc; then
+ emake rdoc || die "rdoc failed"
+ fi
+}
+
+each_ruby_test() {
+ emake test || die "tests failed"
+}
+
+each_ruby_install() {
+ doruby bz2.so
+
+ dodoc README.en || die
+ dohtml bz2.html || die
+
+ if use doc; then
+ pushd docs &>/dev/null
+ docinto api
+ dohtml -r doc || die
+ popd &>/dev/null
+ fi
+}