summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-06-26 06:38:02 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-06-26 06:38:02 +0000
commit9add9c1e0d5242bda8a250f923fc8b80a94c2100 (patch)
tree1c78228c4acf8180c7e872889a8013714eab34be /dev-ruby/ruby-postgres
parentcall epatch once (diff)
downloadgentoo-2-9add9c1e0d5242bda8a250f923fc8b80a94c2100.tar.gz
gentoo-2-9add9c1e0d5242bda8a250f923fc8b80a94c2100.tar.bz2
gentoo-2-9add9c1e0d5242bda8a250f923fc8b80a94c2100.zip
Bump per bug #215510. The gem name has changed, but the postgres.so is still the same name, and it is supposed to just work. ruby-pg to come later.
(Portage version: 2.2_rc1/cvs/Linux 2.6.26-rc4-00103-g1beee8d x86_64)
Diffstat (limited to 'dev-ruby/ruby-postgres')
-rw-r--r--dev-ruby/ruby-postgres/ChangeLog10
-rw-r--r--dev-ruby/ruby-postgres/ruby-postgres-0.7.9.20080128.ebuild26
2 files changed, 35 insertions, 1 deletions
diff --git a/dev-ruby/ruby-postgres/ChangeLog b/dev-ruby/ruby-postgres/ChangeLog
index 9579245b00c8..8c0f5be71e3e 100644
--- a/dev-ruby/ruby-postgres/ChangeLog
+++ b/dev-ruby/ruby-postgres/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-ruby/ruby-postgres
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-postgres/ChangeLog,v 1.20 2008/05/19 19:54:29 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-postgres/ChangeLog,v 1.21 2008/06/26 06:38:02 robbat2 Exp $
+
+*ruby-postgres-0.7.9.20080128 (26 Jun 2008)
+
+ 26 Jun 2008; Robin H. Johnson <robbat2@gentoo.org>
+ +ruby-postgres-0.7.9.20080128.ebuild:
+ Bump per bug #215510. The gem name has changed, but the postgres.so is
+ still the same name, and it is supposed to just work. ruby-pg to come
+ later.
19 May 2008; Tiziano Müller <dev-zero@gentoo.org>
ruby-postgres-0.7.1.ebuild, ruby-postgres-0.7.1.20051221-r1.ebuild,
diff --git a/dev-ruby/ruby-postgres/ruby-postgres-0.7.9.20080128.ebuild b/dev-ruby/ruby-postgres/ruby-postgres-0.7.9.20080128.ebuild
new file mode 100644
index 000000000000..01d53a6b5df5
--- /dev/null
+++ b/dev-ruby/ruby-postgres/ruby-postgres-0.7.9.20080128.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-postgres/ruby-postgres-0.7.9.20080128.ebuild,v 1.1 2008/06/26 06:38:02 robbat2 Exp $
+
+inherit ruby gems versionator
+
+# changes 0.7.1.20060406 to 0.7.1.2006.04.06
+
+# ideally, PV would have been this to start with, but can't change it now as
+# 0.7.1.20051221 > 0.7.1.2006.04.06.
+MY_PV="0.7.9.2008.01.28"
+MY_PN="postgres"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="An extension library to access a PostgreSQL database from Ruby"
+HOMEPAGE="http://ruby.scripting.ca/postgres"
+SRC_URI="http://gems.rubyforge.org/gems/${MY_P}.gem"
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+USE_RUBY="ruby18"
+
+RDEPEND="virtual/postgresql-base"
+DEPEND="${RDEPEND}
+ >=dev-ruby/rubygems-0.9.0-r1"