summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-11-13 13:10:04 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-11-13 13:10:04 +0000
commit05dd123012677452e48476d1eefa4f6285a6b3cf (patch)
tree392b440e21a31b366fcfe8157c1b38216f9a8cab /dev-ruby/ruby-prof
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-05dd123012677452e48476d1eefa4f6285a6b3cf.tar.gz
gentoo-2-05dd123012677452e48476d1eefa4f6285a6b3cf.tar.bz2
gentoo-2-05dd123012677452e48476d1eefa4f6285a6b3cf.zip
Only disable the thread test instead of restricting tests, upstream is aware of the failure and it's not a regression.
(Portage version: 2.2_rc14/cvs/Linux 2.6.27-gentoo-r2 x86_64)
Diffstat (limited to 'dev-ruby/ruby-prof')
-rw-r--r--dev-ruby/ruby-prof/ChangeLog6
-rw-r--r--dev-ruby/ruby-prof/ruby-prof-0.7.0.ebuild14
2 files changed, 15 insertions, 5 deletions
diff --git a/dev-ruby/ruby-prof/ChangeLog b/dev-ruby/ruby-prof/ChangeLog
index ef34f768f750..37bae872d2d2 100644
--- a/dev-ruby/ruby-prof/ChangeLog
+++ b/dev-ruby/ruby-prof/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/ruby-prof
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-prof/ChangeLog,v 1.8 2008/11/13 04:18:49 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-prof/ChangeLog,v 1.9 2008/11/13 13:10:04 flameeyes Exp $
+
+ 13 Nov 2008; Diego Pettenò <flameeyes@gentoo.org> ruby-prof-0.7.0.ebuild:
+ Only disable the thread test instead of restricting tests, upstream is
+ aware of the failure and it's not a regression.
13 Nov 2008; Diego Pettenò <flameeyes@gentoo.org> ruby-prof-0.7.0.ebuild:
Quote variables to make repoman happy.
diff --git a/dev-ruby/ruby-prof/ruby-prof-0.7.0.ebuild b/dev-ruby/ruby-prof/ruby-prof-0.7.0.ebuild
index 2fbeb9be5570..5c8d1ff699b0 100644
--- a/dev-ruby/ruby-prof/ruby-prof-0.7.0.ebuild
+++ b/dev-ruby/ruby-prof/ruby-prof-0.7.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-prof/ruby-prof-0.7.0.ebuild,v 1.2 2008/11/13 04:18:49 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-prof/ruby-prof-0.7.0.ebuild,v 1.3 2008/11/13 13:10:04 flameeyes Exp $
inherit ruby
@@ -20,9 +20,15 @@ DEPEND="${RDEPEND}
USE_RUBY="ruby18"
-# Tests don't work on 0.7.0 version, but I contacted upstream to get
-# them fixed.
-RESTRICT="test"
+src_unpack() {
+ ruby_src_unpack
+
+ # The thread testing in 0.7.0 and earlier versions is broken, it
+ # has to be tested for the next versions, since upstream is
+ # looking for a solution.
+ rm "${S}"/test/thread_test.rb \
+ || die "unable to remove the broken test"
+}
src_compile() {
cd "${S}/ext"