summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-10-08 06:06:31 +0000
committerHans de Graaff <graaff@gentoo.org>2012-10-08 06:06:31 +0000
commit6ea8f8dab9c364a515e3bc5ace332f1d3ba4cf36 (patch)
treebddcdac62619bcbfe7fd7d6ca4f1c0d30292e0d7 /dev-ruby/ruby-progressbar
parentRemove old. (diff)
downloadgentoo-2-6ea8f8dab9c364a515e3bc5ace332f1d3ba4cf36.tar.gz
gentoo-2-6ea8f8dab9c364a515e3bc5ace332f1d3ba4cf36.tar.bz2
gentoo-2-6ea8f8dab9c364a515e3bc5ace332f1d3ba4cf36.zip
Version bump. Drop hppa ppc ppc64 x86 x86-fbsd due to new timecop dependency, bug 437582.
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/ruby-progressbar')
-rw-r--r--dev-ruby/ruby-progressbar/ChangeLog9
-rw-r--r--dev-ruby/ruby-progressbar/ruby-progressbar-1.0.2.ebuild29
2 files changed, 37 insertions, 1 deletions
diff --git a/dev-ruby/ruby-progressbar/ChangeLog b/dev-ruby/ruby-progressbar/ChangeLog
index b17971ebdd31..45e4b8ac95e1 100644
--- a/dev-ruby/ruby-progressbar/ChangeLog
+++ b/dev-ruby/ruby-progressbar/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/ruby-progressbar
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-progressbar/ChangeLog,v 1.44 2012/10/07 16:49:41 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-progressbar/ChangeLog,v 1.45 2012/10/08 06:06:31 graaff Exp $
+
+*ruby-progressbar-1.0.2 (08 Oct 2012)
+
+ 08 Oct 2012; Hans de Graaff <graaff@gentoo.org>
+ +ruby-progressbar-1.0.2.ebuild:
+ Version bump. Drop hppa ppc ppc64 x86 x86-fbsd due to new timecop dependency,
+ bug 437582.
07 Oct 2012; Raúl Porcel <armin76@gentoo.org> ruby-progressbar-0.0.9.ebuild,
ruby-progressbar-0.0.10.ebuild:
diff --git a/dev-ruby/ruby-progressbar/ruby-progressbar-1.0.2.ebuild b/dev-ruby/ruby-progressbar/ruby-progressbar-1.0.2.ebuild
new file mode 100644
index 000000000000..36f00b0485ab
--- /dev/null
+++ b/dev-ruby/ruby-progressbar/ruby-progressbar-1.0.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-progressbar/ruby-progressbar-1.0.2.ebuild,v 1.1 2012/10/08 06:06:31 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ruby19 ree18 jruby"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Text Progress Bar Library for Ruby"
+HOMEPAGE="https://github.com/jfelchner/ruby-progressbar"
+
+LICENSE="|| ( Ruby GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/timecop )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Ss]imple[Cc]ov/ s:^:#:' spec/spec_helper.rb || die
+}