summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNguyen Thai Ngoc Duy <pclouds@gentoo.org>2006-12-16 14:40:47 +0000
committerNguyen Thai Ngoc Duy <pclouds@gentoo.org>2006-12-16 14:40:47 +0000
commit2123f29b7dd1641fab73927d5248f9545201711f (patch)
tree8faa4063c59e2b2d46a28e6a030cb73d8d902f73 /dev-ruby/rubygems
parentComment out the else in the pkg_setup dedicated USE checks, since it is possi... (diff)
downloadgentoo-2-2123f29b7dd1641fab73927d5248f9545201711f.tar.gz
gentoo-2-2123f29b7dd1641fab73927d5248f9545201711f.tar.bz2
gentoo-2-2123f29b7dd1641fab73927d5248f9545201711f.zip
added patch to fix "gem build gemspec.yaml" failure
(Portage version: 2.1.1)
Diffstat (limited to 'dev-ruby/rubygems')
-rw-r--r--dev-ruby/rubygems/ChangeLog8
-rw-r--r--dev-ruby/rubygems/files/digest-rubygems-0.9.0-r23
-rw-r--r--dev-ruby/rubygems/files/rubygems-0.9.0-build-from-yaml.patch12
-rw-r--r--dev-ruby/rubygems/rubygems-0.9.0-r2.ebuild49
4 files changed, 71 insertions, 1 deletions
diff --git a/dev-ruby/rubygems/ChangeLog b/dev-ruby/rubygems/ChangeLog
index 3762aeed819a..47a5a59c4100 100644
--- a/dev-ruby/rubygems/ChangeLog
+++ b/dev-ruby/rubygems/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/rubygems
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rubygems/ChangeLog,v 1.37 2006/11/01 17:56:32 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rubygems/ChangeLog,v 1.38 2006/12/16 14:40:47 pclouds Exp $
+
+*rubygems-0.9.0-r2 (16 Dec 2006)
+
+ 16 Dec 2006; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
+ +files/rubygems-0.9.0-build-from-yaml.patch, +rubygems-0.9.0-r2.ebuild:
+ Added patch to fix "gem build gemspec.yaml" failure
*rubygems-0.9.0-r1 (01 Nov 2006)
diff --git a/dev-ruby/rubygems/files/digest-rubygems-0.9.0-r2 b/dev-ruby/rubygems/files/digest-rubygems-0.9.0-r2
new file mode 100644
index 000000000000..5b13f741f2b3
--- /dev/null
+++ b/dev-ruby/rubygems/files/digest-rubygems-0.9.0-r2
@@ -0,0 +1,3 @@
+MD5 5d496e1f415b8b4033ab867f01d1161f rubygems-0.9.0.tgz 174321
+RMD160 7d2a4ec1a615f608e75c68ee346d957efbb34ed1 rubygems-0.9.0.tgz 174321
+SHA256 6e90baff5ec951939ffcec569b9e1829e46da56cd320b1de1c8e2f5be828fef0 rubygems-0.9.0.tgz 174321
diff --git a/dev-ruby/rubygems/files/rubygems-0.9.0-build-from-yaml.patch b/dev-ruby/rubygems/files/rubygems-0.9.0-build-from-yaml.patch
new file mode 100644
index 000000000000..62f09b38687a
--- /dev/null
+++ b/dev-ruby/rubygems/files/rubygems-0.9.0-build-from-yaml.patch
@@ -0,0 +1,12 @@
+diff -ur rubygems-0.9.0/lib/rubygems/specification.rb rubygems-0.9.0.new/lib/rubygems/specification.rb
+--- rubygems-0.9.0/lib/rubygems/specification.rb 2006-06-27 01:46:30.000000000 +0700
++++ rubygems-0.9.0.new/lib/rubygems/specification.rb 2006-12-16 21:27:10.000000000 +0700
+@@ -412,7 +412,7 @@
+ def Specification.from_yaml(input)
+ input = normalize_yaml_input(input)
+ spec = YAML.load(input)
+- if(spec.class == FalseClass) then
++ if(spec.nil? || spec.class == FalseClass) then
+ raise Gem::EndOfYAMLException
+ end
+ unless Specification === spec
diff --git a/dev-ruby/rubygems/rubygems-0.9.0-r2.ebuild b/dev-ruby/rubygems/rubygems-0.9.0-r2.ebuild
new file mode 100644
index 000000000000..4ee10acf02bf
--- /dev/null
+++ b/dev-ruby/rubygems/rubygems-0.9.0-r2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rubygems/rubygems-0.9.0-r2.ebuild,v 1.1 2006/12/16 14:40:47 pclouds Exp $
+
+inherit ruby
+
+DESCRIPTION="Centralized Ruby extension management system"
+HOMEPAGE="http://rubyforge.org/projects/rubygems/"
+LICENSE="Ruby"
+
+# The URL depends implicitly on the version, unfortunately. Even if you
+# change the filename on the end, it still downloads the same file.
+SRC_URI="http://rubyforge.org/frs/download.php/11289/${P}.tgz"
+
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc-macos ~ppc64 ~sparc ~x86 ~x86-fbsd"
+SLOT="0"
+IUSE=""
+DEPEND=">=dev-lang/ruby-1.8"
+
+PATCHES="${FILESDIR}/no_post_install.patch
+ ${FILESDIR}/${P}-build-c-extensions.patch
+ ${FILESDIR}/${P}-build-from-yaml.patch"
+USE_RUBY="ruby18"
+
+src_compile() {
+ return
+}
+
+src_install() {
+ ver=$(${RUBY} -r rbconfig -e 'print Config::CONFIG["MAJOR"] + "." + Config::CONFIG["MINOR"]')
+ GEM_HOME=${D}/usr/lib/ruby/gems/$ver ruby_src_install
+ cp "${FILESDIR}/auto_gem.rb" "${D}"/$(${RUBY} -r rbconfig -e 'print Config::CONFIG["sitedir"]')
+ keepdir /usr/lib/ruby/gems/$ver/doc
+ doenvd "${FILESDIR}/10rubygems"
+}
+
+pkg_postinst()
+{
+ ewarn "If you have previously switched to using ruby18_with_gems using ruby-config, this"
+ ewarn "package has removed that file and makes it unnecessary anymore. Please use ruby-config"
+ ewarn "to revert back to ruby18."
+}
+
+pkg_postrm()
+{
+ # If we potentially downgraded, then getting rid of RUBYOPT from env.d is probably a smart idea.
+ env-update
+ source /etc/profile
+}