summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Brown <rbrown@gentoo.org>2007-03-06 00:37:21 +0000
committerRichard Brown <rbrown@gentoo.org>2007-03-06 00:37:21 +0000
commit09eadc7c7cb6c75d9d2cee6fcc69630d203fffda (patch)
treea240cfa178dc61ae793b24d0b0251f0f0af20ee1 /dev-ruby
parentold (diff)
downloadgentoo-2-09eadc7c7cb6c75d9d2cee6fcc69630d203fffda.tar.gz
gentoo-2-09eadc7c7cb6c75d9d2cee6fcc69630d203fffda.tar.bz2
gentoo-2-09eadc7c7cb6c75d9d2cee6fcc69630d203fffda.zip
Add "example" to IUSE from Santiago M. Mola Velasco <cooldwind@gmail.com> in Bug #169169. Fix installation of readme files.
(Portage version: 2.1.2-r9)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/ruby-svg/ChangeLog10
-rw-r--r--dev-ruby/ruby-svg/files/digest-ruby-svg-1.0.3-r13
-rw-r--r--dev-ruby/ruby-svg/ruby-svg-1.0.3-r1.ebuild33
3 files changed, 44 insertions, 2 deletions
diff --git a/dev-ruby/ruby-svg/ChangeLog b/dev-ruby/ruby-svg/ChangeLog
index 54bb4d5175c9..10ad190c5687 100644
--- a/dev-ruby/ruby-svg/ChangeLog
+++ b/dev-ruby/ruby-svg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/ruby-svg
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-svg/ChangeLog,v 1.7 2006/10/20 21:29:04 agriffis Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-svg/ChangeLog,v 1.8 2007/03/06 00:37:21 rbrown Exp $
+
+*ruby-svg-1.0.3-r1 (06 Mar 2007)
+
+ 06 Mar 2007; Richard Brown <rbrown@gentoo.org> +ruby-svg-1.0.3-r1.ebuild:
+ Add "example" to IUSE from Santiago M. Mola Velasco <cooldwind@gmail.com> in
+ Bug #169169. Fix installation of readme files.
20 Oct 2006; Aron Griffis <agriffis@gentoo.org> ruby-svg-1.0.3.ebuild:
Mark 1.0.3 stable on ia64
diff --git a/dev-ruby/ruby-svg/files/digest-ruby-svg-1.0.3-r1 b/dev-ruby/ruby-svg/files/digest-ruby-svg-1.0.3-r1
new file mode 100644
index 000000000000..777d24065553
--- /dev/null
+++ b/dev-ruby/ruby-svg/files/digest-ruby-svg-1.0.3-r1
@@ -0,0 +1,3 @@
+MD5 6544a236ffe11fd52f39b19b254b0ee2 ruby-svg-1.0.3.tar.gz 22839
+RMD160 8a7cee9d559b31ed0c671492d8ab872b72377d99 ruby-svg-1.0.3.tar.gz 22839
+SHA256 cf8a8358a9a468318f733367649fdb75c02fec23077946ccc2f0dda9e503e919 ruby-svg-1.0.3.tar.gz 22839
diff --git a/dev-ruby/ruby-svg/ruby-svg-1.0.3-r1.ebuild b/dev-ruby/ruby-svg/ruby-svg-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..6e54e473d6e2
--- /dev/null
+++ b/dev-ruby/ruby-svg/ruby-svg-1.0.3-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-svg/ruby-svg-1.0.3-r1.ebuild,v 1.1 2007/03/06 00:37:21 rbrown Exp $
+
+inherit ruby
+
+DESCRIPTION="Ruby SVG Generator"
+HOMEPAGE="http://ruby-svg.sourceforge.jp/"
+SRC_URI="http://downloads.sourceforge.jp/ruby-svg/2288/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~ia64 ~ppc ~x86"
+USE_RUBY="any"
+IUSE="examples"
+DEPEND="virtual/ruby
+ dev-ruby/rdtool"
+RDEPEND="virtual/ruby"
+
+src_install() {
+ ruby install.rb config --prefix=${D}/usr || die
+ ruby install.rb setup || die
+ ruby install.rb install || die
+
+ rd2 README.en.rd > README.en.html
+ rd2 README.ja.rd > README.ja.html
+
+ dohtml *.html || die
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples
+ doins sample/*
+ fi
+}