summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-05-04 15:59:52 +0000
committerHans de Graaff <graaff@gentoo.org>2013-05-04 15:59:52 +0000
commit0df84e7f2b01e9ba61bf5887f1e04a6b7cb74ab4 (patch)
tree7b38c485f1eb0f57da18fd000f5fb856e68d529b /dev-ruby
parentStable for HPPA (bug #468334). (diff)
downloadgentoo-2-0df84e7f2b01e9ba61bf5887f1e04a6b7cb74ab4.tar.gz
gentoo-2-0df84e7f2b01e9ba61bf5887f1e04a6b7cb74ab4.tar.bz2
gentoo-2-0df84e7f2b01e9ba61bf5887f1e04a6b7cb74ab4.zip
Version bump.
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/httpclient/ChangeLog7
-rw-r--r--dev-ruby/httpclient/httpclient-2.3.3.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/dev-ruby/httpclient/ChangeLog b/dev-ruby/httpclient/ChangeLog
index 931e387491e2..0b66a4e4d4ba 100644
--- a/dev-ruby/httpclient/ChangeLog
+++ b/dev-ruby/httpclient/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/httpclient
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httpclient/ChangeLog,v 1.45 2013/01/15 07:07:45 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httpclient/ChangeLog,v 1.46 2013/05/04 15:59:52 graaff Exp $
+
+*httpclient-2.3.3 (04 May 2013)
+
+ 04 May 2013; Hans de Graaff <graaff@gentoo.org> +httpclient-2.3.3.ebuild:
+ Version bump.
15 Jan 2013; Rick Farina <zerochaos@gentoo.org> httpclient-2.2.5.ebuild:
adding ~arm keywords to net-analyzer/metasploit rdeps
diff --git a/dev-ruby/httpclient/httpclient-2.3.3.ebuild b/dev-ruby/httpclient/httpclient-2.3.3.ebuild
new file mode 100644
index 000000000000..93d02e85fb2b
--- /dev/null
+++ b/dev-ruby/httpclient/httpclient-2.3.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httpclient/httpclient-2.3.3.ebuild,v 1.1 2013/05/04 15:59:52 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_TEST="-Ilib test"
+RUBY_FAKEGEM_TASK_DOC="doc"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRADOC="README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="'httpclient' gives something like the functionality of libwww-perl (LWP) in Ruby"
+HOMEPAGE="https://github.com/nahi/httpclient"
+SRC_URI="https://github.com/nahi/httpclient/tarball/v${PV} -> ${P}.tgz"
+RUBY_S="nahi-httpclient-*"
+
+LICENSE="Ruby"
+SLOT="0"
+
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="${RDEPEND}
+ !dev-ruby/http-access2"
+
+ruby_add_rdepend "virtual/ruby-ssl"
+
+ruby_add_bdepend "doc? ( dev-ruby/rdoc )"
+
+all_ruby_prepare () {
+ rm Gemfile || die
+ sed -i -e '/[bB]undler/s:^:#:' Rakefile || die
+
+ # Remove mandatory CI reports since we don't need this for testing.
+ sed -i -e '/reporter/s:^:#:' Rakefile || die
+
+ # Remove mandatory simplecov dependency
+ sed -i -e '/[Ss]imple[Cc]ov/ s:^:#:' test/helper.rb || die
+
+ # Comment out test requiring network access that makes assumptions
+ # about the environment, bug 395155
+ sed -i -e '/test_async_error/,/^ end/ s:^:#:' test/test_httpclient.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib -S testrb test/test_*.rb || die
+}