summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-02-09 08:58:32 +0000
committerHans de Graaff <graaff@gentoo.org>2012-02-09 08:58:32 +0000
commit26e77824b804b4f2cd6bea2061ebe277e457c3bd (patch)
treecb6659a70f5684d5a78b42e8b7b93e46db90b843 /dev-ruby
parentMask sys-libs/db-5.3 for testing. (diff)
downloadgentoo-2-26e77824b804b4f2cd6bea2061ebe277e457c3bd.tar.gz
gentoo-2-26e77824b804b4f2cd6bea2061ebe277e457c3bd.tar.bz2
gentoo-2-26e77824b804b4f2cd6bea2061ebe277e457c3bd.zip
Version bump.
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/bundler/ChangeLog7
-rw-r--r--dev-ruby/bundler/bundler-1.0.22.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/dev-ruby/bundler/ChangeLog b/dev-ruby/bundler/ChangeLog
index 036edd0ea698..43e6da41e2c5 100644
--- a/dev-ruby/bundler/ChangeLog
+++ b/dev-ruby/bundler/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/bundler
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bundler/ChangeLog,v 1.34 2012/01/17 13:56:28 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bundler/ChangeLog,v 1.35 2012/02/09 08:58:32 graaff Exp $
+
+*bundler-1.0.22 (09 Feb 2012)
+
+ 09 Feb 2012; Hans de Graaff <graaff@gentoo.org> +bundler-1.0.22.ebuild:
+ Version bump.
17 Jan 2012; Agostino Sarubbo <ago@gentoo.org> bundler-1.0.18.ebuild:
Stable for amd64, wrt bug #398847
diff --git a/dev-ruby/bundler/bundler-1.0.22.ebuild b/dev-ruby/bundler/bundler-1.0.22.ebuild
new file mode 100644
index 000000000000..8c4efeaaad82
--- /dev/null
+++ b/dev-ruby/bundler/bundler-1.0.22.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bundler/bundler-1.0.22.ebuild,v 1.1 2012/02/09 08:58:32 graaff Exp $
+
+EAPI=2
+
+# jruby → needs to be tested because jruby-1.5.1 fails in multiple
+# ways unrelated to this package.
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+
+# No documentation task
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md ISSUES.md UPGRADING.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An easy way to vendor gem dependencies"
+HOMEPAGE="http://github.com/carlhuda/bundler"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend virtual/rubygems
+
+ruby_add_bdepend "test? ( app-text/ronn dev-ruby/rspec:2 )"
+
+RDEPEND="${RDEPEND}
+ dev-vcs/git"
+DEPEND="${DEPEND}
+ test? ( dev-vcs/git )"
+
+all_ruby_prepare() {
+ # Reported upstream: http://github.com/carlhuda/bundler/issues/issue/738
+ sed -i -e '726s/should/should_not/' spec/runtime/setup_spec.rb || die
+
+ # Fails randomly and no clear cause can be found. Might be related
+ # to bug 346357. This was broken in previous releases without a
+ # failing spec, so patch out this spec for now since it is not a
+ # regression.
+ sed -i -e '49,54d' spec/install/deploy_spec.rb || die
+}
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *ruby19)
+ # Account for different wording in ruby 1.9.3.
+ sed -i -e 's/no such file to load/cannot load such file/' spec/runtime/require_spec.rb spec/install/gems/groups_spec.rb || die
+ ;;
+ *)
+ ;;
+ esac
+}