summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-11-13 04:00:46 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-11-13 04:00:46 +0000
commit26f413c4220335e237deaa7dc3a5af14bc677603 (patch)
tree88616a122bec30e363fe1517cf191fc0c9142d11 /dev-ruby
parentRemove old version and add proper dependencies for texlive (for doc generatio... (diff)
downloadgentoo-2-26f413c4220335e237deaa7dc3a5af14bc677603.tar.gz
gentoo-2-26f413c4220335e237deaa7dc3a5af14bc677603.tar.bz2
gentoo-2-26f413c4220335e237deaa7dc3a5af14bc677603.zip
Version bump, use package rather than gem so that the ebuild can run the tests (which are for now restricted).
(Portage version: 2.2_rc14/cvs/Linux 2.6.27-gentoo-r2 x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/ruby-prof/ChangeLog9
-rw-r--r--dev-ruby/ruby-prof/ruby-prof-0.7.0.ebuild63
2 files changed, 71 insertions, 1 deletions
diff --git a/dev-ruby/ruby-prof/ChangeLog b/dev-ruby/ruby-prof/ChangeLog
index 8bc3760beec9..de0947597ad5 100644
--- a/dev-ruby/ruby-prof/ChangeLog
+++ b/dev-ruby/ruby-prof/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/ruby-prof
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-prof/ChangeLog,v 1.5 2008/02/26 05:43:36 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-prof/ChangeLog,v 1.6 2008/11/13 04:00:46 flameeyes Exp $
+
+*ruby-prof-0.7.0 (13 Nov 2008)
+
+ 13 Nov 2008; Diego Pettenò <flameeyes@gentoo.org>
+ +ruby-prof-0.7.0.ebuild:
+ Version bump, use package rather than gem so that the ebuild can run the
+ tests (which are for now restricted).
*ruby-prof-0.6.0 (26 Feb 2008)
diff --git a/dev-ruby/ruby-prof/ruby-prof-0.7.0.ebuild b/dev-ruby/ruby-prof/ruby-prof-0.7.0.ebuild
new file mode 100644
index 000000000000..89704db16b03
--- /dev/null
+++ b/dev-ruby/ruby-prof/ruby-prof-0.7.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-prof/ruby-prof-0.7.0.ebuild,v 1.1 2008/11/13 04:00:46 flameeyes Exp $
+
+inherit ruby
+
+DESCRIPTION="A module for profiling Ruby code"
+HOMEPAGE="http://rubyforge.org/projects/ruby-prof/"
+SRC_URI="mirror://rubyforge/${PN}/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+
+RDEPEND="virtual/ruby"
+DEPEND="${RDEPEND}
+ test? ( dev-ruby/rake )
+ doc? ( dev-ruby/rake )"
+
+USE_RUBY="ruby18"
+
+# Tests don't work on 0.7.0 version, but I contacted upstream to get
+# them fixed.
+RESTRICT="test"
+
+src_compile() {
+ cd "${S}/ext"
+ ruby_econf || die "ruby_econf failed"
+ ruby_emake || die "ruby_emake failed"
+
+ if use doc; then
+ rake rdoc || die "rake rdoc failed"
+ fi
+}
+
+src_test() {
+ rake test || die "rake test failed"
+}
+
+src_install() {
+ dobin bin/ruby-prof || die "dobin failed"
+
+ cd "${S}"/lib
+ doruby -r * || die "doruby failed"
+
+ cd "${S}"/ext
+ ruby_einstall || die "ruby_einstall failed"
+
+ cd "${S}"
+
+ dodoc README CHANGES || die "dodoc failed"
+
+ if use doc; then
+ dohtml -r doc/* || die "dohtml failed"
+ fi
+
+
+ for dir in examples rails rails/example rails/environment; do
+ docinto $dir
+ dodoc $dir/* || die "dodoc $dir failed"
+ done
+}