summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-10-22 13:02:47 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-10-22 13:02:47 +0000
commit3583174c8bf83038dfdeb50f5ab0f4e4a570b5e9 (patch)
tree56542b8ef0665d7b1bd707edfd80446beaaf5b6e /dev-ruby
parentVersion bump. (diff)
downloadgentoo-2-3583174c8bf83038dfdeb50f5ab0f4e4a570b5e9.tar.gz
gentoo-2-3583174c8bf83038dfdeb50f5ab0f4e4a570b5e9.tar.bz2
gentoo-2-3583174c8bf83038dfdeb50f5ab0f4e4a570b5e9.zip
Version bump.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/rb-gsl/ChangeLog7
-rw-r--r--dev-ruby/rb-gsl/rb-gsl-1.16.0.3.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-ruby/rb-gsl/ChangeLog b/dev-ruby/rb-gsl/ChangeLog
index 4796ccd6bcd1..c4b5dc5cf77d 100644
--- a/dev-ruby/rb-gsl/ChangeLog
+++ b/dev-ruby/rb-gsl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rb-gsl
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rb-gsl/ChangeLog,v 1.6 2014/07/13 07:11:25 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rb-gsl/ChangeLog,v 1.7 2014/10/22 13:02:47 mrueg Exp $
+
+*rb-gsl-1.16.0.3 (22 Oct 2014)
+
+ 22 Oct 2014; Manuel Rüger <mrueg@gentoo.org> +rb-gsl-1.16.0.3.ebuild:
+ Version bump.
*rb-gsl-1.16.0.2 (13 Jul 2014)
diff --git a/dev-ruby/rb-gsl/rb-gsl-1.16.0.3.ebuild b/dev-ruby/rb-gsl/rb-gsl-1.16.0.3.ebuild
new file mode 100644
index 000000000000..3dc32c19a971
--- /dev/null
+++ b/dev-ruby/rb-gsl/rb-gsl-1.16.0.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rb-gsl/rb-gsl-1.16.0.3.ebuild,v 1.1 2014/10/22 13:02:47 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+inherit ruby-fakegem multilib
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="ChangeLog README"
+
+RUBY_FAKEGEM_TASK_TEST="test:libs"
+DESCRIPTION="Ruby interface to GNU Scientific Library"
+HOMEPAGE="https://github.com/david-macmahon/rb-gsl"
+#SRC_URI="https://github.com/david-macmahon/${PN}/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+DEPEND+=" sci-libs/gsl"
+RDEPEND+=" sci-libs/gsl"
+
+RUBY_S="${PN}-${P}"
+
+ruby_add_rdepend "dev-ruby/narray"
+
+each_ruby_prepare() {
+ sed -i -e '/$CPPFLAGS =/a \$LDFLAGS = " -L#{narray_config} -l:narray.so "+$LDFLAGS' -e 's/src/lib/' ext/gsl/extconf.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/gsl extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext/gsl V=1
+ cp ext/gsl/*$(get_modname) lib/gsl || die
+}
+
+each_ruby_test() {
+ ${RUBY} -S testrb -Ilib -Itest test/*.rb test/*/*.rb || die
+}