summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-03-14 13:06:33 +0000
committerHans de Graaff <graaff@gentoo.org>2010-03-14 13:06:33 +0000
commit39a9540438823c489f004af613761b532cf02eb8 (patch)
tree83e790385970e6f278b9cb8509dd355059b0ec71 /dev-ruby
parentSimplify src_install(). (diff)
downloadgentoo-2-39a9540438823c489f004af613761b532cf02eb8.tar.gz
gentoo-2-39a9540438823c489f004af613761b532cf02eb8.tar.bz2
gentoo-2-39a9540438823c489f004af613761b532cf02eb8.zip
Version bump. Stop using capistrano-launcher now that the old slot is gone.
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/capistrano/ChangeLog8
-rw-r--r--dev-ruby/capistrano/capistrano-2.5.17.ebuild34
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-ruby/capistrano/ChangeLog b/dev-ruby/capistrano/ChangeLog
index 81e1324365cc..87ee3861b6b7 100644
--- a/dev-ruby/capistrano/ChangeLog
+++ b/dev-ruby/capistrano/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/capistrano
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/capistrano/ChangeLog,v 1.52 2010/02/28 08:07:43 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/capistrano/ChangeLog,v 1.53 2010/03/14 13:06:33 graaff Exp $
+
+*capistrano-2.5.17 (14 Mar 2010)
+
+ 14 Mar 2010; Hans de Graaff <graaff@gentoo.org> +capistrano-2.5.17.ebuild:
+ Version bump. Stop using capistrano-launcher now that the old slot is
+ gone.
28 Feb 2010; Hans de Graaff <graaff@gentoo.org> -capistrano-1.4.2.ebuild:
Remove masked version.
diff --git a/dev-ruby/capistrano/capistrano-2.5.17.ebuild b/dev-ruby/capistrano/capistrano-2.5.17.ebuild
new file mode 100644
index 000000000000..2a9576188cce
--- /dev/null
+++ b/dev-ruby/capistrano/capistrano-2.5.17.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/capistrano/capistrano-2.5.17.ebuild,v 1.1 2010/03/14 13:06:33 graaff Exp $
+
+EAPI="2"
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A distributed application deployment system"
+HOMEPAGE="http://capify.org/"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/net-ssh-2.0.14
+ >=dev-ruby/net-sftp-2.0.2
+ >=dev-ruby/net-scp-1.0.2
+ >=dev-ruby/net-ssh-gateway-1.0.0
+ >=dev-ruby/highline-1.2.7"
+ruby_add_bdepend test "dev-ruby/mocha"
+
+RDEPEND="!dev-ruby/capistrano-launcher"
+
+each_ruby_prepare() {
+ # Remove Jeweler check_dependencies task
+ sed -i '/check_dependencies/d' Rakefile
+}