summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-10-31 07:06:58 +0000
committerHans de Graaff <graaff@gentoo.org>2014-10-31 07:06:58 +0000
commit4029130d40f9b17613d0d29b5bb2e8bebdd23ef7 (patch)
treed51347d82a918220f96a37389e32381d1e377dac /dev-ruby
parentupdate manifest (diff)
downloadgentoo-2-4029130d40f9b17613d0d29b5bb2e8bebdd23ef7.tar.gz
gentoo-2-4029130d40f9b17613d0d29b5bb2e8bebdd23ef7.tar.bz2
gentoo-2-4029130d40f9b17613d0d29b5bb2e8bebdd23ef7.zip
Add back old version since it is not fully compatible with 0.3.0 and should be slotted.
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/simple_oauth/ChangeLog7
-rw-r--r--dev-ruby/simple_oauth/simple_oauth-0.2.0-r1.ebuild27
2 files changed, 33 insertions, 1 deletions
diff --git a/dev-ruby/simple_oauth/ChangeLog b/dev-ruby/simple_oauth/ChangeLog
index f4716a64d12c..aaebcf87c494 100644
--- a/dev-ruby/simple_oauth/ChangeLog
+++ b/dev-ruby/simple_oauth/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/simple_oauth
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/simple_oauth/ChangeLog,v 1.13 2014/10/30 13:59:41 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/simple_oauth/ChangeLog,v 1.14 2014/10/31 07:06:58 graaff Exp $
+
+ 31 Oct 2014; Hans de Graaff <graaff@gentoo.org>
+ +simple_oauth-0.2.0-r1.ebuild:
+ Add back old version since it is not fully compatible with 0.3.0 and should
+ be slotted.
30 Oct 2014; Manuel Rüger <mrueg@gentoo.org> -simple_oauth-0.2.0-r1.ebuild,
simple_oauth-0.3.0.ebuild:
diff --git a/dev-ruby/simple_oauth/simple_oauth-0.2.0-r1.ebuild b/dev-ruby/simple_oauth/simple_oauth-0.2.0-r1.ebuild
new file mode 100644
index 000000000000..615173afb14a
--- /dev/null
+++ b/dev-ruby/simple_oauth/simple_oauth-0.2.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/simple_oauth/simple_oauth-0.2.0-r1.ebuild,v 1.6 2014/10/31 07:06:58 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 jruby"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Simply builds and verifies OAuth headers"
+HOMEPAGE="https://github.com/laserlemon/simple_oauth"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+each_ruby_test() {
+ export CI=true
+ each_fakegem_test
+}