summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-10-05 10:43:08 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-10-05 10:43:08 +0000
commit504f19742b6ec203c6eff718513b6fa260200b0e (patch)
treef44596252170cb73c08e40a4e183abb467770d9c /dev-ruby
parentStable for amd64, wrt bug #479868 (diff)
downloadgentoo-2-504f19742b6ec203c6eff718513b6fa260200b0e.tar.gz
gentoo-2-504f19742b6ec203c6eff718513b6fa260200b0e.tar.bz2
gentoo-2-504f19742b6ec203c6eff718513b6fa260200b0e.zip
Tests run now, but will fail.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/pkg-config/ChangeLog9
-rw-r--r--dev-ruby/pkg-config/pkg-config-1.1.4-r1.ebuild31
2 files changed, 38 insertions, 2 deletions
diff --git a/dev-ruby/pkg-config/ChangeLog b/dev-ruby/pkg-config/ChangeLog
index 89bde4bd3401..9cc6990a20d4 100644
--- a/dev-ruby/pkg-config/ChangeLog
+++ b/dev-ruby/pkg-config/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/pkg-config
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pkg-config/ChangeLog,v 1.19 2012/09/30 22:06:16 flameeyes Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pkg-config/ChangeLog,v 1.20 2013/10/05 10:43:08 mrueg Exp $
+
+*pkg-config-1.1.4-r1 (05 Oct 2013)
+
+ 05 Oct 2013; Manuel Rüger <mrueg@gentoo.org> +pkg-config-1.1.4-r1.ebuild:
+ Tests run now, but will fail.
30 Sep 2012; Diego E. Pettenò <flameeyes@gentoo.org> pkg-config-1.1.4.ebuild:
Add missing dependency on virtual/pkgconfig.
diff --git a/dev-ruby/pkg-config/pkg-config-1.1.4-r1.ebuild b/dev-ruby/pkg-config/pkg-config-1.1.4-r1.ebuild
new file mode 100644
index 000000000000..ccd505ddb3ce
--- /dev/null
+++ b/dev-ruby/pkg-config/pkg-config-1.1.4-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pkg-config/pkg-config-1.1.4-r1.ebuild,v 1.1 2013/10/05 10:43:08 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc NEWS"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A pkg-config implementation by Ruby"
+HOMEPAGE="https://github.com/rcairo/pkg-config"
+LICENSE="|| ( LGPL-2 LGPL-2.1 LGPL-3 )"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+SLOT="0"
+IUSE="test"
+
+ruby_add_bdepend "test? ( >=dev-ruby/test-unit-2.5.1-r1 )"
+# this is used for testing
+DEPEND+=" test? ( x11-libs/cairo )"
+RDEPEND+=" virtual/pkgconfig"
+
+each_ruby_test() {
+ ruby-ng_testrb-2 -Ilib test/test_${PN/-/_}.rb
+}