summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-10-05 10:44:03 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-10-05 10:44:03 +0000
commit6c5af5952c0a235ba3e31d1fec373e1e54427001 (patch)
tree080ddbf02291be7266332d52326972ae5df6a386 /dev-ruby
parentTests run now, but will fail. (diff)
downloadgentoo-2-6c5af5952c0a235ba3e31d1fec373e1e54427001.tar.gz
gentoo-2-6c5af5952c0a235ba3e31d1fec373e1e54427001.tar.bz2
gentoo-2-6c5af5952c0a235ba3e31d1fec373e1e54427001.zip
Tests run now, but will fail.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/gem_plugin/ChangeLog7
-rw-r--r--dev-ruby/gem_plugin/gem_plugin-0.2.3-r3.ebuild28
2 files changed, 34 insertions, 1 deletions
diff --git a/dev-ruby/gem_plugin/ChangeLog b/dev-ruby/gem_plugin/ChangeLog
index 3aa41db68d2b..4e8967b13dcb 100644
--- a/dev-ruby/gem_plugin/ChangeLog
+++ b/dev-ruby/gem_plugin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/gem_plugin
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gem_plugin/ChangeLog,v 1.37 2013/09/14 12:14:04 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gem_plugin/ChangeLog,v 1.38 2013/10/05 10:44:03 mrueg Exp $
+
+*gem_plugin-0.2.3-r3 (05 Oct 2013)
+
+ 05 Oct 2013; Manuel Rüger <mrueg@gentoo.org> +gem_plugin-0.2.3-r3.ebuild:
+ Tests run now, but will fail.
14 Sep 2013; Manuel Rüger <mrueg@gentoo.org> -gem_plugin-0.2.3-r1.ebuild:
Cleanup old.
diff --git a/dev-ruby/gem_plugin/gem_plugin-0.2.3-r3.ebuild b/dev-ruby/gem_plugin/gem_plugin-0.2.3-r3.ebuild
new file mode 100644
index 000000000000..a20e64607f84
--- /dev/null
+++ b/dev-ruby/gem_plugin/gem_plugin-0.2.3-r3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gem_plugin/gem_plugin-0.2.3-r3.ebuild,v 1.1 2013/10/05 10:44:02 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
+
+RUBY_FAKEGEM_EXTRAINSTALL="resources"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A plugin system based only on rubygems that uses dependencies only."
+# Hosted by mongrel's rubyforge
+HOMEPAGE="http://mongrel.rubyforge.org/"
+
+LICENSE="mongrel"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+each_ruby_test() {
+ ${RUBY} -Ilib test/test_plugins.rb || die "tests failed"
+}