summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-11-20 13:39:13 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-11-20 13:39:13 +0000
commitadcbca7fe34aa32a5c9df3816a604fdd22400828 (patch)
tree8858398e5d75f7cba4625c288df76bc094184e9d /dev-ruby
parentVersion bump (diff)
downloadgentoo-2-adcbca7fe34aa32a5c9df3816a604fdd22400828.tar.gz
gentoo-2-adcbca7fe34aa32a5c9df3816a604fdd22400828.tar.bz2
gentoo-2-adcbca7fe34aa32a5c9df3816a604fdd22400828.zip
Cleanup old.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/eventmachine/ChangeLog6
-rw-r--r--dev-ruby/eventmachine/eventmachine-1.0.0.ebuild70
-rw-r--r--dev-ruby/eventmachine/eventmachine-1.0.3.ebuild70
3 files changed, 5 insertions, 141 deletions
diff --git a/dev-ruby/eventmachine/ChangeLog b/dev-ruby/eventmachine/ChangeLog
index 3eea1fa5f613..4299e003cb80 100644
--- a/dev-ruby/eventmachine/ChangeLog
+++ b/dev-ruby/eventmachine/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/eventmachine
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/eventmachine/ChangeLog,v 1.21 2013/10/25 06:29:06 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/eventmachine/ChangeLog,v 1.22 2013/11/20 13:39:13 mrueg Exp $
+
+ 20 Nov 2013; Manuel Rüger <mrueg@gentoo.org> -eventmachine-1.0.0.ebuild,
+ -eventmachine-1.0.3.ebuild:
+ Cleanup old.
*eventmachine-1.0.3-r1 (25 Oct 2013)
diff --git a/dev-ruby/eventmachine/eventmachine-1.0.0.ebuild b/dev-ruby/eventmachine/eventmachine-1.0.0.ebuild
deleted file mode 100644
index 867c6dded005..000000000000
--- a/dev-ruby/eventmachine/eventmachine-1.0.0.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/eventmachine/eventmachine-1.0.0.ebuild,v 1.1 2012/11/24 11:31:42 graaff Exp $
-
-EAPI=4
-# jruby → has shims for Java handling but tests fail badly, remaining
-# stuck; avoid that for now.
-USE_RUBY="ruby18 ree18 ruby19"
-
-RUBY_FAKEGEM_TASK_DOC="yard"
-RUBY_FAKEGEM_DOCDIR="rdoc"
-RUBY_FAKEGEM_EXTRADOC="docs/*.md README.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="EventMachine is a fast, simple event-processing library for Ruby programs."
-HOMEPAGE="http://rubyeventmachine.com"
-
-LICENSE="|| ( GPL-2 Ruby )"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE=""
-
-DEPEND="${DEPEND}
- dev-libs/openssl"
-RDEPEND="${RDEPEND}
- dev-libs/openssl"
-
-ruby_add_bdepend "doc? ( dev-ruby/yard )"
-
-all_ruby_prepare() {
- # Remove package tasks to avoid dependency on rake-compiler.
- rm rakelib/package.rake || die
-
- # fix test issue - upstream b96b736b39261f7d74f013633cc7cd619afa20c4
- sed -i -e 's/DEBUG/BROADCAST/g' tests/test_set_sock_opt.rb || die
-
- # Remove the resolver tests since they require network access and
- # the localhost test fails with an IPv6 localhost.
- rm tests/test_resolver.rb || die
-}
-
-each_ruby_configure() {
- for extdir in ext ext/fastfilereader; do
- pushd $extdir
- ${RUBY} extconf.rb || die "extconf.rb failed for ${extdir}"
- popd
- done
-}
-
-each_ruby_compile() {
- for extdir in ext ext/fastfilereader; do
- pushd $extdir
- # both extensions use C++, so use the CXXFLAGS not the CFLAGS
- emake CFLAGS="${CXXFLAGS} -fPIC" archflag="${LDFLAGS}" || die "emake failed for ${extdir}"
- popd
- cp $extdir/*.so lib/ || die "Unable to copy extensions for ${extdir}"
- done
-}
-
-each_ruby_test() {
- ${RUBY} -Ilib -S testrb tests/test_*.rb || die
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- insinto /usr/share/doc/${PF}/
- doins -r examples || die "Failed to install examples"
-}
diff --git a/dev-ruby/eventmachine/eventmachine-1.0.3.ebuild b/dev-ruby/eventmachine/eventmachine-1.0.3.ebuild
deleted file mode 100644
index e921c137f593..000000000000
--- a/dev-ruby/eventmachine/eventmachine-1.0.3.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/eventmachine/eventmachine-1.0.3.ebuild,v 1.1 2013/05/02 05:24:56 graaff Exp $
-
-EAPI=5
-# jruby → has shims for Java handling but tests fail badly, remaining
-# stuck; avoid that for now.
-USE_RUBY="ruby18 ruby19"
-
-RUBY_FAKEGEM_TASK_DOC="yard"
-RUBY_FAKEGEM_DOCDIR="rdoc"
-RUBY_FAKEGEM_EXTRADOC="docs/*.md README.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="EventMachine is a fast, simple event-processing library for Ruby programs."
-HOMEPAGE="http://rubyeventmachine.com"
-
-LICENSE="|| ( GPL-2 Ruby )"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE=""
-
-DEPEND="${DEPEND}
- dev-libs/openssl"
-RDEPEND="${RDEPEND}
- dev-libs/openssl"
-
-ruby_add_bdepend "doc? ( dev-ruby/yard )"
-
-all_ruby_prepare() {
- # Remove package tasks to avoid dependency on rake-compiler.
- rm rakelib/package.rake || die
-
- # fix test issue - upstream b96b736b39261f7d74f013633cc7cd619afa20c4
- sed -i -e 's/DEBUG/BROADCAST/g' tests/test_set_sock_opt.rb || die
-
- # Remove the resolver tests since they require network access and
- # the localhost test fails with an IPv6 localhost.
- rm tests/test_resolver.rb || die
-}
-
-each_ruby_configure() {
- for extdir in ext ext/fastfilereader; do
- pushd $extdir
- ${RUBY} extconf.rb || die "extconf.rb failed for ${extdir}"
- popd
- done
-}
-
-each_ruby_compile() {
- for extdir in ext ext/fastfilereader; do
- pushd $extdir
- # both extensions use C++, so use the CXXFLAGS not the CFLAGS
- emake CFLAGS="${CXXFLAGS} -fPIC" archflag="${LDFLAGS}" || die "emake failed for ${extdir}"
- popd
- cp $extdir/*.so lib/ || die "Unable to copy extensions for ${extdir}"
- done
-}
-
-each_ruby_test() {
- ${RUBY} -Ilib -S testrb tests/test_*.rb || die
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- insinto /usr/share/doc/${PF}/
- doins -r examples || die "Failed to install examples"
-}