summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-05-04 09:08:45 +0000
committerHans de Graaff <graaff@gentoo.org>2013-05-04 09:08:45 +0000
commitcb05534cadfbead4cbea14ee0125b029f5715c8f (patch)
tree4dddb39e657405dfbf1ade7d925c55fa9fc9405b /dev-ruby
parentAdd dev-perl/Module-Find to RDEPEND. bug #461324 (diff)
downloadgentoo-2-cb05534cadfbead4cbea14ee0125b029f5715c8f.tar.gz
gentoo-2-cb05534cadfbead4cbea14ee0125b029f5715c8f.tar.bz2
gentoo-2-cb05534cadfbead4cbea14ee0125b029f5715c8f.zip
Version bump.
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/highline/ChangeLog10
-rw-r--r--dev-ruby/highline/highline-1.6.18.ebuild47
-rw-r--r--dev-ruby/highline/highline-1.6.8.ebuild27
3 files changed, 55 insertions, 29 deletions
diff --git a/dev-ruby/highline/ChangeLog b/dev-ruby/highline/ChangeLog
index 844834760748..5e6ff6de1282 100644
--- a/dev-ruby/highline/ChangeLog
+++ b/dev-ruby/highline/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/highline
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/highline/ChangeLog,v 1.74 2012/12/30 20:46:07 ago Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/highline/ChangeLog,v 1.75 2013/05/04 09:08:45 graaff Exp $
+
+*highline-1.6.18 (04 May 2013)
+
+ 04 May 2013; Hans de Graaff <graaff@gentoo.org> -highline-1.6.8.ebuild,
+ +highline-1.6.18.ebuild:
+ Version bump.
30 Dec 2012; Agostino Sarubbo <ago@gentoo.org> highline-1.6.13.ebuild:
Stable for alpha, wrt bug #447594
diff --git a/dev-ruby/highline/highline-1.6.18.ebuild b/dev-ruby/highline/highline-1.6.18.ebuild
new file mode 100644
index 000000000000..c2b97c71a8b2
--- /dev/null
+++ b/dev-ruby/highline/highline-1.6.18.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/highline/highline-1.6.18.ebuild,v 1.1 2013/05/04 09:08:45 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc TODO"
+RUBY_FAKEGEM_DOCDIR="doc/html"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Highline is a high-level command-line IO library for ruby."
+HOMEPAGE="http://highline.rubyforge.org/"
+
+IUSE=""
+LICENSE="|| ( GPL-2 Ruby )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+
+all_ruby_prepare() {
+ # fix up gemspec file not to call git
+ sed -i -e '/git ls-files/d' highline.gemspec || die
+
+ # Avoid tests that require a real console because we can't provide
+ # that when running tests through portage. These should pass when
+ # run in a console. We should probably narrow this down more to the
+ # specific tests.
+ sed -i -e '/tc_highline/ s:^:#:' test/ts_all.rb || die
+
+ sed -i -e '/test_question_options/,/^ end/ s:^:#:' \
+ -e '/test_paged_print_infinite_loop_bug/,/^ end/ s:^:#:' \
+ -e '/test_cancel_paging/,/^ end/ s:^:#:' \
+ test/tc_menu.rb || die
+}
+
+each_ruby_test() {
+ case ${RUBY} in
+ *jruby)
+ ewarn "Skipping tests since they hang indefinitely."
+ ;;
+ *)
+ ${RUBY} -S rake test || die
+ ;;
+ esac
+}
diff --git a/dev-ruby/highline/highline-1.6.8.ebuild b/dev-ruby/highline/highline-1.6.8.ebuild
deleted file mode 100644
index 3272792c0bcb..000000000000
--- a/dev-ruby/highline/highline-1.6.8.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/highline/highline-1.6.8.ebuild,v 1.7 2012/11/07 04:30:40 jer Exp $
-
-EAPI=2
-
-USE_RUBY="ruby18 ruby19 jruby ree18"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG README TODO"
-RUBY_FAKEGEM_DOCDIR="doc/html"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Highline is a high-level command-line IO library for ruby."
-HOMEPAGE="http://rubyforge.org/projects/highline/"
-
-IUSE=""
-LICENSE="|| ( GPL-2 Ruby )"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-
-all_ruby_prepare() {
- # Provide our own metadata since jruby can't handle the metadata.
- rm ../metadata || die
-
- sed -i -e '/AUTHORS/s:^:#:' Rakefile || die "Fixing the Rakefile failed"
-}