summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-02-28 07:56:59 +0000
committerHans de Graaff <graaff@gentoo.org>2010-02-28 07:56:59 +0000
commitcb05781110530ccf67c95dac2bcd3ef748f9868f (patch)
tree432047dabb49d0e2cc4c4e519b613e36952aa07c /dev-ruby
parentAdd app-text/docbook-xsl-stylesheets to DEPEND per bug 307025 (diff)
downloadgentoo-2-cb05781110530ccf67c95dac2bcd3ef748f9868f.tar.gz
gentoo-2-cb05781110530ccf67c95dac2bcd3ef748f9868f.tar.bz2
gentoo-2-cb05781110530ccf67c95dac2bcd3ef748f9868f.zip
Version bump. Convert to ruby-fakegem.
(Portage version: 2.1.7.16/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/piston/ChangeLog9
-rw-r--r--dev-ruby/piston/piston-2.0.8.ebuild31
2 files changed, 38 insertions, 2 deletions
diff --git a/dev-ruby/piston/ChangeLog b/dev-ruby/piston/ChangeLog
index 5fe1b2011296..42185563911e 100644
--- a/dev-ruby/piston/ChangeLog
+++ b/dev-ruby/piston/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/piston
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/piston/ChangeLog,v 1.6 2009/12/02 06:52:20 graaff Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/piston/ChangeLog,v 1.7 2010/02/28 07:56:59 graaff Exp $
+
+*piston-2.0.8 (28 Feb 2010)
+
+ 28 Feb 2010; Hans de Graaff <graaff@gentoo.org> +piston-2.0.8.ebuild:
+ Version bump. Convert to ruby-fakegem.
*piston-2.0.7 (02 Dec 2009)
diff --git a/dev-ruby/piston/piston-2.0.8.ebuild b/dev-ruby/piston/piston-2.0.8.ebuild
new file mode 100644
index 000000000000..19d5d1a277fd
--- /dev/null
+++ b/dev-ruby/piston/piston-2.0.8.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/piston/piston-2.0.8.ebuild,v 1.1 2010/02/28 07:56:59 graaff Exp $
+
+EAPI="2"
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="History.txt README.txt TODO"
+RUBY_FAKEGEM_EXTRAINSTALL="script"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Rails utility that uses Subversion to manage local copies of upstream vendor branches."
+HOMEPAGE="http://piston.rubyforge.org"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# Tests fails. Disabled for now and reported upstream:
+# http://github.com/francois/piston/issues/issue/4
+RESTRICT="test"
+
+ruby_add_bdepend test "dev-ruby/mocha"
+
+ruby_add_rdepend " >=dev-ruby/log4r-1.0.5
+ >=dev-ruby/main-2.8.3
+ >=dev-ruby/activesupport-2.0.0"