summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2008-01-10 19:58:30 +0000
committerHans de Graaff <graaff@gentoo.org>2008-01-10 19:58:30 +0000
commitd40da3d2ead8c5011362f061775a38fb3a33ca43 (patch)
tree3b1711afb81bf7bfce8792b2c16205a2a981934f /dev-ruby
parentRemove unneeded patch. Bug #205222. (diff)
downloadgentoo-2-d40da3d2ead8c5011362f061775a38fb3a33ca43.tar.gz
gentoo-2-d40da3d2ead8c5011362f061775a38fb3a33ca43.tar.bz2
gentoo-2-d40da3d2ead8c5011362f061775a38fb3a33ca43.zip
Version bump
(Portage version: 2.1.3.19)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/rmagick/ChangeLog9
-rw-r--r--dev-ruby/rmagick/files/digest-rmagick-2.1.03
-rw-r--r--dev-ruby/rmagick/rmagick-2.1.0.ebuild66
3 files changed, 76 insertions, 2 deletions
diff --git a/dev-ruby/rmagick/ChangeLog b/dev-ruby/rmagick/ChangeLog
index f1557dff3a80..dfe4b08b8857 100644
--- a/dev-ruby/rmagick/ChangeLog
+++ b/dev-ruby/rmagick/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rmagick
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rmagick/ChangeLog,v 1.87 2007/12/29 14:43:55 graaff Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rmagick/ChangeLog,v 1.88 2008/01/10 19:58:30 graaff Exp $
+
+*rmagick-2.1.0 (10 Jan 2008)
+
+ 10 Jan 2008; Hans de Graaff <graaff@gentoo.org> +rmagick-2.1.0.ebuild:
+ Version bump: minor enhancements and bug fixes.
*rmagick-2.0.0 (29 Dec 2007)
diff --git a/dev-ruby/rmagick/files/digest-rmagick-2.1.0 b/dev-ruby/rmagick/files/digest-rmagick-2.1.0
new file mode 100644
index 000000000000..8c16700808bd
--- /dev/null
+++ b/dev-ruby/rmagick/files/digest-rmagick-2.1.0
@@ -0,0 +1,3 @@
+MD5 5045ab66e67c0420647a212ea1e782d0 RMagick-2.1.0.tar.bz2 928514
+RMD160 d6ead50f9c57a2a9c790c9dbf427e842f2273f87 RMagick-2.1.0.tar.bz2 928514
+SHA256 6e42636afd4ce07a9024d358d14d22d029ace4d9817f19dca7ed60fb9d741b1c RMagick-2.1.0.tar.bz2 928514
diff --git a/dev-ruby/rmagick/rmagick-2.1.0.ebuild b/dev-ruby/rmagick/rmagick-2.1.0.ebuild
new file mode 100644
index 000000000000..b386f145d126
--- /dev/null
+++ b/dev-ruby/rmagick/rmagick-2.1.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rmagick/rmagick-2.1.0.ebuild,v 1.1 2008/01/10 19:58:30 graaff Exp $
+
+inherit ruby
+
+# The gem for this package doesn't seem to play well with portage. It
+# runs a GNUish configure script, with argument passed directly from
+# the gem install command, but gem install doesn't use the same style
+# of arguments. Thus, unless you're smart enough to come up with a
+# fix, please leave this as a source package install.
+
+MY_PV=${PV//_/-}
+DESCRIPTION="An interface between Ruby and the ImageMagick(TM) image processing library"
+HOMEPAGE="http://rmagick.rubyforge.org/"
+SRC_URI="http://rubyforge.org/frs/download.php/30514/RMagick-${MY_PV}.tar.bz2"
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples doc"
+DEPEND="virtual/ruby
+ >=media-gfx/imagemagick-6.3.5.6"
+
+S="${WORKDIR}/RMagick-${PV}"
+
+# hdri causes extensive changes in the imagemagick internals, and
+# rmagick is not ready to deal with those, see bug 184356.
+pkg_setup() {
+ if built_with_use --missing false media-gfx/imagemagick hdri ; then
+ eerror "imagemagick is built with the hdri USE flag, this is not supported by rmagick"
+ eerror "please rebuild imagemagick without hdri support if you want to use rmagick"
+ die "imagemagick is built with the hdri USE flag, this is not supported by rmagick"
+ fi
+}
+
+# Use a custom src_compile because the setup.rb included with RMagick
+# doesn't like extra parameters during the setup phase.
+src_compile() {
+ # When documentation is built many examples are also run. Not all
+ # of them may work (e.g. due to missing additional dependencies)
+ # so we allow the examples to fail.
+ if ! use doc ; then
+ RUBY_ECONF="--disable-htmldoc --allow-example-errors"
+ fi
+
+ ${RUBY} setup.rb config --prefix=/usr "$@" \
+ ${RUBY_ECONF} ${EXTRA_ECONF} || die "setup.rb config failed"
+ ${RUBY} setup.rb setup || die "setup.rb setup failed"
+}
+
+# Use a custom src_install instead of the default one in ruby.eclass
+# because the one in ruby.eclass does not include setting the prefix
+# for the installation step and assumes that arguments can be given
+# also during the install phase.
+src_install() {
+ if ! use doc ; then
+ RUBY_ECONF="--disable-htmldoc --allow-example-errors"
+ fi
+
+ ${RUBY} setup.rb config --prefix="${D}/usr" "$@" \
+ ${RUBY_ECONF} ${EXTRA_ECONF} || die "setup.rb config failed"
+ ${RUBY} setup.rb install --prefix="${D}" || die "setup.rb install failed"
+
+ cd "${S}"
+ dodoc ChangeLog README.html README-Mac-OSX.txt README.txt
+}