summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-08-18 18:43:22 +0000
committerHans de Graaff <graaff@gentoo.org>2013-08-18 18:43:22 +0000
commitdd657e9ef5d7cd1688a3e4834040c743fcc9f79b (patch)
tree7fe303437b0f6439de04a4d61398f1461f4988cb /dev-ruby
parentRemove old, drop m68k to ~arch. (diff)
downloadgentoo-2-dd657e9ef5d7cd1688a3e4834040c743fcc9f79b.tar.gz
gentoo-2-dd657e9ef5d7cd1688a3e4834040c743fcc9f79b.tar.bz2
gentoo-2-dd657e9ef5d7cd1688a3e4834040c743fcc9f79b.zip
Cleanup.
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/minitest/ChangeLog6
-rw-r--r--dev-ruby/minitest/minitest-4.5.0.ebuild58
-rw-r--r--dev-ruby/minitest/minitest-4.7.0.ebuild58
-rw-r--r--dev-ruby/minitest/minitest-5.0.3.ebuild31
4 files changed, 5 insertions, 148 deletions
diff --git a/dev-ruby/minitest/ChangeLog b/dev-ruby/minitest/ChangeLog
index 640dd1b91954..2c0d68524b87 100644
--- a/dev-ruby/minitest/ChangeLog
+++ b/dev-ruby/minitest/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/minitest
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/minitest/ChangeLog,v 1.125 2013/07/17 06:41:49 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/minitest/ChangeLog,v 1.126 2013/08/18 18:43:22 graaff Exp $
+
+ 18 Aug 2013; Hans de Graaff <graaff@gentoo.org> -minitest-4.5.0.ebuild,
+ -minitest-4.7.0.ebuild, -minitest-5.0.3.ebuild:
+ Cleanup.
17 Jul 2013; Hans de Graaff <graaff@gentoo.org> minitest-5.0.6.ebuild:
Drop ruby18 blocker since the problem cannot be reproduced. Add missing hoe
diff --git a/dev-ruby/minitest/minitest-4.5.0.ebuild b/dev-ruby/minitest/minitest-4.5.0.ebuild
deleted file mode 100644
index c8f501cc101c..000000000000
--- a/dev-ruby/minitest/minitest-4.5.0.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/minitest/minitest-4.5.0.ebuild,v 1.12 2013/04/14 11:40:57 ago Exp $
-
-EAPI=5
-# jruby → tests fail, reported upstream
-# http://rubyforge.org/tracker/index.php?func=detail&aid=27657&group_id=1040&atid=4097
-USE_RUBY="ruby18 ruby19 ree18 jruby"
-
-RUBY_FAKEGEM_TASK_DOC="docs"
-
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="History.txt Manifest.txt README.txt"
-
-inherit ruby-fakegem
-
-DESCRIPTION="minitest/unit is a small and fast replacement for ruby's huge and slow test/unit."
-HOMEPAGE="https://github.com/seattlerb/minitest"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc test"
-
-ruby_add_bdepend "
- doc? ( dev-ruby/hoe dev-ruby/rdoc )"
-
-each_ruby_prepare() {
- case ${RUBY} in
- *jruby)
- # Remove failing tests. Upstream claims that these are all
- # bugs in jruby. By removing the failing tests we can at
- # least run the remainder. See bug 321055 for details.
- rm -f test/minitest/test_minitest_unit.rb || die
- # Also add minitest_mock since there are jruby-specific failures.
- rm -f test/minitest/test_minitest_mock.rb || die
-
- # Our jruby throws a slightly different error
- sed -i -e 's/not :xxx/not \\"xxx\\"/' test/minitest/test_minitest_spec.rb || die
- ;;
- *)
- ;;
- esac
-}
-
-each_ruby_test() {
- case ${RUBY} in
- *jruby)
- # JRuby 1.6.x has threading bugs that are triggered by
- # minitests 4's new parallel test support. Should be fixed
- # in JRuby 1.7.
- N=1 ${RUBY} -Ilib:bin:test:. -S testrb test || die
- ;;
- *)
- ${RUBY} -Ilib:bin:test:. -S testrb test || die
- ;;
- esac
-}
diff --git a/dev-ruby/minitest/minitest-4.7.0.ebuild b/dev-ruby/minitest/minitest-4.7.0.ebuild
deleted file mode 100644
index 8cab2be259ec..000000000000
--- a/dev-ruby/minitest/minitest-4.7.0.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/minitest/minitest-4.7.0.ebuild,v 1.1 2013/04/04 05:46:44 graaff Exp $
-
-EAPI=5
-# jruby → tests fail, reported upstream
-# http://rubyforge.org/tracker/index.php?func=detail&aid=27657&group_id=1040&atid=4097
-USE_RUBY="ruby18 ruby19 jruby"
-
-RUBY_FAKEGEM_TASK_DOC="docs"
-
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="History.txt Manifest.txt README.txt"
-
-inherit ruby-fakegem
-
-DESCRIPTION="minitest/unit is a small and fast replacement for ruby's huge and slow test/unit."
-HOMEPAGE="https://github.com/seattlerb/minitest"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc test"
-
-ruby_add_bdepend "
- doc? ( dev-ruby/hoe dev-ruby/rdoc )"
-
-each_ruby_prepare() {
- case ${RUBY} in
- *jruby)
- # Remove failing tests. Upstream claims that these are all
- # bugs in jruby. By removing the failing tests we can at
- # least run the remainder. See bug 321055 for details.
- rm -f test/minitest/test_minitest_unit.rb || die
- # Also add minitest_mock since there are jruby-specific failures.
- rm -f test/minitest/test_minitest_mock.rb || die
-
- # Our jruby throws a slightly different error
- sed -i -e 's/not :xxx/not \\"xxx\\"/' test/minitest/test_minitest_spec.rb || die
- ;;
- *)
- ;;
- esac
-}
-
-each_ruby_test() {
- case ${RUBY} in
- *jruby)
- # JRuby 1.6.x has threading bugs that are triggered by
- # minitests 4's new parallel test support. Should be fixed
- # in JRuby 1.7.
- N=1 ${RUBY} -Ilib:bin:test:. -S testrb test || die
- ;;
- *)
- ${RUBY} -Ilib:bin:test:. -S testrb test || die
- ;;
- esac
-}
diff --git a/dev-ruby/minitest/minitest-5.0.3.ebuild b/dev-ruby/minitest/minitest-5.0.3.ebuild
deleted file mode 100644
index bdfd17b5c296..000000000000
--- a/dev-ruby/minitest/minitest-5.0.3.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/minitest/minitest-5.0.3.ebuild,v 1.1 2013/05/31 16:05:49 flameeyes Exp $
-
-EAPI=5
-USE_RUBY="ruby18 ruby19"
-
-# Rake is the easiest way to go through this unfortunately.
-RUBY_FAKEGEM_RECIPE_TEST="rake"
-
-RUBY_FAKEGEM_TASK_DOC="docs"
-
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="History.txt Manifest.txt README.txt"
-
-inherit ruby-fakegem
-
-DESCRIPTION="minitest/unit is a small and fast replacement for ruby's huge and slow test/unit."
-HOMEPAGE="https://github.com/seattlerb/minitest"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc test"
-
-ruby_add_bdepend "
- doc? ( dev-ruby/hoe dev-ruby/rdoc )
- ruby_targets_ruby18? ( !!dev-ruby/minitest[ruby_targets_ruby18] )"
-
-# There is a nasty bug that tests fail if minitest is loaded already
-# from the system.