summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-01-10 22:12:52 +0000
committerManuel Rüger <mrueg@gentoo.org>2015-01-10 22:12:52 +0000
commite48e3a3d40321c73236a6119667380bf8a2a6378 (patch)
tree6184032fcc26641736a707078290fc20e0bde3f3 /dev-ruby
parentVersion bump. (diff)
downloadgentoo-2-e48e3a3d40321c73236a6119667380bf8a2a6378.tar.gz
gentoo-2-e48e3a3d40321c73236a6119667380bf8a2a6378.tar.bz2
gentoo-2-e48e3a3d40321c73236a6119667380bf8a2a6378.zip
Version bump.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/json_pure/ChangeLog9
-rw-r--r--dev-ruby/json_pure/json_pure-1.8.2.ebuild41
2 files changed, 48 insertions, 2 deletions
diff --git a/dev-ruby/json_pure/ChangeLog b/dev-ruby/json_pure/ChangeLog
index fa8d4ec4031e..74583dad393b 100644
--- a/dev-ruby/json_pure/ChangeLog
+++ b/dev-ruby/json_pure/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/json_pure
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json_pure/ChangeLog,v 1.2 2014/10/17 19:43:34 mrueg Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json_pure/ChangeLog,v 1.3 2015/01/10 22:12:52 mrueg Exp $
+
+*json_pure-1.8.2 (10 Jan 2015)
+
+ 10 Jan 2015; Manuel Rüger <mrueg@gentoo.org> +json_pure-1.8.2.ebuild:
+ Version bump.
17 Oct 2014; Manuel Rüger <mrueg@gentoo.org> json_pure-1.8.1.ebuild:
Add ruby21 target.
diff --git a/dev-ruby/json_pure/json_pure-1.8.2.ebuild b/dev-ruby/json_pure/json_pure-1.8.2.ebuild
new file mode 100644
index 000000000000..98a073fdcbd5
--- /dev/null
+++ b/dev-ruby/json_pure/json_pure-1.8.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json_pure/json_pure-1.8.2.ebuild,v 1.1 2015/01/10 22:12:52 mrueg Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+RUBY_FAKEGEM_RECIPE_TEST="rake"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A JSON implementation in pure Ruby"
+HOMEPAGE="http://flori.github.com/json"
+
+LICENSE="Ruby-BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+ruby_add_bdepend "test? (
+ dev-ruby/sdoc
+ dev-ruby/permutation
+)"
+
+each_ruby_configure() {
+ ${RUBY} -Cext/json/ext/generator extconf.rb || die
+ ${RUBY} -Cext/json/ext/parser extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/json/ext/generator
+ emake V=1 -Cext/json/ext/parser
+ cp ext/json/ext/generator/generator$(get_modname) lib/ || die
+ cp ext/json/ext/parser/parser$(get_modname) lib/ || die
+}
+
+each_ruby_test() {
+ env JSON=pure ${RUBY} -S rake test_pure || die
+ env JSON=ext ${RUBY} -S rake test_ext || die
+}