summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-08-26 14:08:44 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-08-26 14:08:44 +0000
commitff7bae1bbf7d0ae1327cba20c7a5b771e8d9fea7 (patch)
treebbce149f3973405c2cd1d80a2724c8c694a6ca85 /dev-ruby
parentadd ~ia64 (diff)
downloadgentoo-2-ff7bae1bbf7d0ae1327cba20c7a5b771e8d9fea7.tar.gz
gentoo-2-ff7bae1bbf7d0ae1327cba20c7a5b771e8d9fea7.tar.bz2
gentoo-2-ff7bae1bbf7d0ae1327cba20c7a5b771e8d9fea7.zip
Fix cp -a usage for Gentoo/FreeBSD.
(Portage version: 2.0.51.22)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/ruby-libart/ChangeLog6
-rw-r--r--dev-ruby/ruby-libart/ruby-libart-0.30.ebuild6
-rw-r--r--dev-ruby/ruby-libart/ruby-libart-0.34.ebuild4
3 files changed, 10 insertions, 6 deletions
diff --git a/dev-ruby/ruby-libart/ChangeLog b/dev-ruby/ruby-libart/ChangeLog
index 65794af6fc03..1dfc171adbf3 100644
--- a/dev-ruby/ruby-libart/ChangeLog
+++ b/dev-ruby/ruby-libart/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/ruby-libart
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-libart/ChangeLog,v 1.10 2005/05/01 18:09:12 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-libart/ChangeLog,v 1.11 2005/08/26 14:08:44 flameeyes Exp $
+
+ 26 Aug 2005; Diego Pettenò <flameeyes@gentoo.org>
+ ruby-libart-0.30.ebuild, ruby-libart-0.34.ebuild:
+ Fix cp -a usage for Gentoo/FreeBSD.
01 May 2005; Michael Hanselmann <hansmi@gentoo.org>
ruby-libart-0.34.ebuild:
diff --git a/dev-ruby/ruby-libart/ruby-libart-0.30.ebuild b/dev-ruby/ruby-libart/ruby-libart-0.30.ebuild
index 40d6f9dcc515..d9a663d505cb 100644
--- a/dev-ruby/ruby-libart/ruby-libart-0.30.ebuild
+++ b/dev-ruby/ruby-libart/ruby-libart-0.30.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-libart/ruby-libart-0.30.ebuild,v 1.6 2004/07/14 22:10:46 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-libart/ruby-libart-0.30.ebuild,v 1.7 2005/08/26 14:08:44 flameeyes Exp $
S=${WORKDIR}/ruby-gnome-all-${PV}/libart
DESCRIPTION="Ruby libart bindings"
@@ -23,5 +23,5 @@ src_compile() {
src_install() {
make site-install DESTDIR=${D}
dodoc [A-Z]*
- cp -dr sample doc ${D}/usr/share/doc/${PF}
+ cp -pPR sample doc ${D}/usr/share/doc/${PF}
}
diff --git a/dev-ruby/ruby-libart/ruby-libart-0.34.ebuild b/dev-ruby/ruby-libart/ruby-libart-0.34.ebuild
index 4b0be67cca7f..6925d3e55e59 100644
--- a/dev-ruby/ruby-libart/ruby-libart-0.34.ebuild
+++ b/dev-ruby/ruby-libart/ruby-libart-0.34.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-libart/ruby-libart-0.34.ebuild,v 1.10 2005/05/01 18:09:12 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-libart/ruby-libart-0.34.ebuild,v 1.11 2005/08/26 14:08:44 flameeyes Exp $
inherit ruby
@@ -26,5 +26,5 @@ src_compile() {
src_install() {
make site-install DESTDIR=${D}
dodoc [A-Z]*
- cp -a sample ${D}/usr/share/doc/${PF}
+ cp -pPR sample ${D}/usr/share/doc/${PF}
}