summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2007-05-27 01:55:51 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2007-05-27 01:55:51 +0000
commit3db08a99397112c23b7cf10a5876730bd12499c4 (patch)
tree4162603ea426237949ef80fb6c2fd4d5794b5564 /dev-tcltk
parentStable on mips. (diff)
downloadgentoo-2-3db08a99397112c23b7cf10a5876730bd12499c4.tar.gz
gentoo-2-3db08a99397112c23b7cf10a5876730bd12499c4.tar.bz2
gentoo-2-3db08a99397112c23b7cf10a5876730bd12499c4.zip
Added examples USE flag, bug #165598. Fixed LICENSE.
(Portage version: 2.1.2.7)
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/snack/ChangeLog11
-rw-r--r--dev-tcltk/snack/files/digest-snack-2.2.10-r13
-rw-r--r--dev-tcltk/snack/snack-2.2.10-r1.ebuild66
-rw-r--r--dev-tcltk/snack/snack-2.2.10.ebuild6
4 files changed, 81 insertions, 5 deletions
diff --git a/dev-tcltk/snack/ChangeLog b/dev-tcltk/snack/ChangeLog
index d7a1cb62ab8f..17e822b2e6ba 100644
--- a/dev-tcltk/snack/ChangeLog
+++ b/dev-tcltk/snack/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-tcltk/snack
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/snack/ChangeLog,v 1.18 2006/09/14 23:38:42 matsuu Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/snack/ChangeLog,v 1.19 2007/05/27 01:55:51 matsuu Exp $
+
+*snack-2.2.10-r1 (27 May 2007)
+
+ 27 May 2007; MATSUU Takuto <matsuu@gentoo.org> snack-2.2.10.ebuild,
+ +snack-2.2.10-r1.ebuild:
+ Added examples USE flag, bug #165598.
+ Fixed LICENSE.
14 Sep 2006; MATSUU Takuto <matsuu@gentoo.org> snack-2.2.9.ebuild,
snack-2.2.10.ebuild:
diff --git a/dev-tcltk/snack/files/digest-snack-2.2.10-r1 b/dev-tcltk/snack/files/digest-snack-2.2.10-r1
new file mode 100644
index 000000000000..fba1a9d67d8d
--- /dev/null
+++ b/dev-tcltk/snack/files/digest-snack-2.2.10-r1
@@ -0,0 +1,3 @@
+MD5 98da0dc73599b3a039cba1b7ff169399 snack2.2.10.tar.gz 1798252
+RMD160 52616bc4cf06baee0e5d7a91faa5b385ee60c7a7 snack2.2.10.tar.gz 1798252
+SHA256 4bfe764547ab92ba58f43b77366dbb7c7b3512d65a27cdbf9e585a9cb64ce81e snack2.2.10.tar.gz 1798252
diff --git a/dev-tcltk/snack/snack-2.2.10-r1.ebuild b/dev-tcltk/snack/snack-2.2.10-r1.ebuild
new file mode 100644
index 000000000000..bae7bce7a780
--- /dev/null
+++ b/dev-tcltk/snack/snack-2.2.10-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/snack/snack-2.2.10-r1.ebuild,v 1.1 2007/05/27 01:55:51 matsuu Exp $
+
+inherit eutils multilib
+
+DESCRIPTION="The Snack Sound Toolkit (Tcl)"
+HOMEPAGE="http://www.speech.kth.se/snack/"
+SRC_URI="http://www.speech.kth.se/snack/dist/${PN}${PV}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+IUSE="alsa examples python threads vorbis"
+
+RESTRICT="test" # Bug 78354
+
+DEPEND=">dev-lang/tcl-8.4.3
+ >dev-lang/tk-8.4.3
+ alsa? ( media-libs/alsa-lib )
+ vorbis? ( media-libs/libvorbis )
+ python? ( virtual/python )"
+
+S="${WORKDIR}/${PN}${PV}/unix"
+
+src_compile() {
+ local myconf="--libdir=/usr/$(get_libdir) --includedir=/usr/include"
+
+ use alsa && myconf="${myconf} --enable-alsa"
+ use threads && myconf="${myconf} --enable-threads"
+
+ if use vorbis ; then
+ myconf="${myconf} --with-ogg-include=${ROOT}/usr/include"
+ myconf="${myconf} --with-ogg-lib=${ROOT}/usr/$(get_libdir)"
+ fi
+
+ econf ${myconf} || die "configure failed"
+ emake || die "make failed"
+
+
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ if use python ; then
+ cd "${S}"/../python
+ python setup.py install --root="${D}" || die
+ fi
+
+ cd "${S}"/..
+
+ dodoc README changes
+ dohtml doc/*
+
+ if use examples ; then
+ sed -i -e 's/wish[0-9.]+/wish/g' demos/tcl/* || die
+ docinto examples/tcl
+ dodoc demos/tcl/*
+
+ if use python ; then
+ docinto examples/python
+ dodoc demos/python/*
+ fi
+ fi
+}
diff --git a/dev-tcltk/snack/snack-2.2.10.ebuild b/dev-tcltk/snack/snack-2.2.10.ebuild
index 7f58255bfafe..a473908bb851 100644
--- a/dev-tcltk/snack/snack-2.2.10.ebuild
+++ b/dev-tcltk/snack/snack-2.2.10.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/snack/snack-2.2.10.ebuild,v 1.2 2006/09/14 23:38:42 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/snack/snack-2.2.10.ebuild,v 1.3 2007/05/27 01:55:51 matsuu Exp $
inherit eutils multilib
@@ -8,7 +8,7 @@ DESCRIPTION="The Snack Sound Toolkit (Tcl)"
HOMEPAGE="http://www.speech.kth.se/snack/"
SRC_URI="http://www.speech.kth.se/snack/dist/${PN}${PV}.tar.gz"
-LICENSE="BSD"
+LICENSE="GPL-2"
KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
SLOT="0"
IUSE="alsa python threads vorbis"