summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2010-10-28 16:40:39 +0000
committerUlrich Müller <ulm@gentoo.org>2010-10-28 16:40:39 +0000
commit1e44f93a59d80964309a1a239db6bbca48a09b02 (patch)
tree2e76ecce5dad4e0aba835916af45286cf04ecd62 /dev-tex/catdvi
parentDon't mess with ck-launch-session from xinitrc. (diff)
downloadgentoo-2-1e44f93a59d80964309a1a239db6bbca48a09b02.tar.gz
gentoo-2-1e44f93a59d80964309a1a239db6bbca48a09b02.tar.bz2
gentoo-2-1e44f93a59d80964309a1a239db6bbca48a09b02.zip
Fix the kpathsea_version_string problem in a way that doesn't break compilation with TeX Live 2008.
(Portage version: 2.1.9.21/cvs/Linux x86_64)
Diffstat (limited to 'dev-tex/catdvi')
-rw-r--r--dev-tex/catdvi/ChangeLog7
-rw-r--r--dev-tex/catdvi/catdvi-0.14-r1.ebuild5
-rw-r--r--dev-tex/catdvi/files/catdvi-0.14-kpathsea.patch50
3 files changed, 58 insertions, 4 deletions
diff --git a/dev-tex/catdvi/ChangeLog b/dev-tex/catdvi/ChangeLog
index 1b00d0d74fe0..0405dc78b99c 100644
--- a/dev-tex/catdvi/ChangeLog
+++ b/dev-tex/catdvi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-tex/catdvi
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/catdvi/ChangeLog,v 1.6 2010/10/27 21:54:21 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/catdvi/ChangeLog,v 1.7 2010/10/28 16:40:39 ulm Exp $
+
+ 28 Oct 2010; Ulrich Mueller <ulm@gentoo.org> catdvi-0.14-r1.ebuild,
+ files/catdvi-0.14-kpathsea.patch:
+ Fix the kpathsea_version_string problem in a way that doesn't break
+ compilation with TeX Live 2008. Thanks aballier.
*catdvi-0.14-r1 (26 Oct 2010)
diff --git a/dev-tex/catdvi/catdvi-0.14-r1.ebuild b/dev-tex/catdvi/catdvi-0.14-r1.ebuild
index d0ef3d05a63c..4b6cfc0fed01 100644
--- a/dev-tex/catdvi/catdvi-0.14-r1.ebuild
+++ b/dev-tex/catdvi/catdvi-0.14-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/catdvi/catdvi-0.14-r1.ebuild,v 1.1 2010/10/27 21:54:21 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/catdvi/catdvi-0.14-r1.ebuild,v 1.2 2010/10/28 16:40:39 ulm Exp $
EAPI=2
-inherit eutils toolchain-funcs
+inherit eutils autotools toolchain-funcs
DESCRIPTION="DVI to plain text translator"
HOMEPAGE="http://catdvi.sourceforge.net"
@@ -20,6 +20,7 @@ RDEPEND="${DEPEND}"
src_prepare() {
epatch "${FILESDIR}/${P}-kpathsea.patch"
+ eautoconf
}
src_compile() {
diff --git a/dev-tex/catdvi/files/catdvi-0.14-kpathsea.patch b/dev-tex/catdvi/files/catdvi-0.14-kpathsea.patch
index c94e6d4aef95..799cd1512018 100644
--- a/dev-tex/catdvi/files/catdvi-0.14-kpathsea.patch
+++ b/dev-tex/catdvi/files/catdvi-0.14-kpathsea.patch
@@ -1,8 +1,56 @@
http://bugs.gentoo.org/342817
+--- catdvi-0.14-orig/config.mk.in
++++ catdvi-0.14/config.mk.in
+@@ -23,6 +23,7 @@
+
+ CFG_HAS_GETOPT_LONG = @CFG_HAS_GETOPT_LONG@
+ CFG_HAS_KPATHSEA = @CFG_HAS_KPATHSEA@
++CFG_HAS_KPATHSEA_VERSION_H = @CFG_HAS_KPATHSEA_VERSION_H@
+ CFG_KPATHSEA_HAS_GETOPT_LONG = @CFG_KPATHSEA_HAS_GETOPT_LONG@
+ CFG_SHOW_PSE2UNIC_WARNINGS = @CFG_SHOW_PSETOUNIC_WARNINGS@
+
+--- catdvi-0.14-orig/configure.in
++++ catdvi-0.14/configure.in
+@@ -48,6 +48,9 @@
+ AC_MSG_ERROR([*** kpathsea library (required) not found; try to use the --with-kpathsea-prefix option ***])
+ fi
+
++AC_CHECK_HEADERS([kpathsea/version.h], CFG_HAS_KPATHSEA_VERSION_H=yes, CFG_HAS_KPATHSEA_VERSION_H=no)
++AC_SUBST(CFG_HAS_KPATHSEA_VERSION_H)
++
+ dnl It seem libkpathsea provides a getopt_long() implementation
+ dnl if and only if the C library does not.
+ dnl
+--- catdvi-0.14-orig/GNUmakefile
++++ catdvi-0.14/GNUmakefile
+@@ -36,6 +36,10 @@
+ endif
+ endif
+
++ifeq ($(CFG_HAS_KPATHSEA_VERSION_H),yes)
++CPPFLAGS += -DCFG_HAS_KPATHSEA_VERSION_H
++endif
++
+ ifeq ($(CFG_HAS_KPATHSEA),yes)
+ FINDTFM = kpathsea.o
+ LDLIBS = -lkpathsea
--- catdvi-0.14-orig/kpathsea.c
+++ catdvi-0.14/kpathsea.c
-@@ -36,7 +36,6 @@
+@@ -21,6 +21,12 @@
+ #include "findtfm.h"
+ #include "version.h"
+
++#ifdef CFG_HAS_KPATHSEA_VERSION_H
++#include <kpathsea/version.h>
++#else
++extern char * kpathsea_version_string;
++#endif
++
+ void setup_findtfm(char const * progname)
+ {
+ kpse_set_program_name(progname, PACKAGE);
+@@ -36,7 +42,6 @@
void version_findtfm(void)
{