summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Turk <satai@gentoo.org>2003-07-14 03:07:30 +0000
committerMatthew Turk <satai@gentoo.org>2003-07-14 03:07:30 +0000
commit48103466eb2665a5bf3831a363e3d5bd6f6cf76c (patch)
tree73e3214cbe3537662923552b96609a15691136f8 /dev-tex/cweb_latex/cweb_latex-1.1.1.ebuild
parentAdding ebuild for cweb code directly in LaTeX. Fixes bug 16908. (diff)
downloadgentoo-2-48103466eb2665a5bf3831a363e3d5bd6f6cf76c.tar.gz
gentoo-2-48103466eb2665a5bf3831a363e3d5bd6f6cf76c.tar.bz2
gentoo-2-48103466eb2665a5bf3831a363e3d5bd6f6cf76c.zip
Adding ebuild for cweb code directly in LaTeX. Fixes bug 16908.
Diffstat (limited to 'dev-tex/cweb_latex/cweb_latex-1.1.1.ebuild')
-rw-r--r--dev-tex/cweb_latex/cweb_latex-1.1.1.ebuild17
1 files changed, 17 insertions, 0 deletions
diff --git a/dev-tex/cweb_latex/cweb_latex-1.1.1.ebuild b/dev-tex/cweb_latex/cweb_latex-1.1.1.ebuild
new file mode 100644
index 000000000000..887ad91cce3a
--- /dev/null
+++ b/dev-tex/cweb_latex/cweb_latex-1.1.1.ebuild
@@ -0,0 +1,17 @@
+inherit latex-package
+
+S="${WORKDIR}/cweb-sty-${PV}"
+DESCRIPTION="LaTeX package for using LaTeX with CWEB"
+SRC_URI="ftp://ftp.th-darmstadt.de//programming/literate-programming/c.c++/cweb-sty-${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 mips"
+PATCHES="${FILESDIR}/cweb.cls.patch"
+
+# this package has a .tex file which needs to go with the cweb.sty
+src_install() {
+ cd ${S}
+ latex-package_src_install
+ insinto ${TEXMF}/tex/latex/${PN}
+ doins cwebbase.tex
+}