summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-06-28 03:36:05 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-06-28 03:36:05 +0000
commit7e8f25671f3ada5ba742d696c72223e770c9f3e7 (patch)
tree35c0d9b2007fe5b2bd34d7d1f925435238e6551b /dev-tex
parentfix the target of the udev symbolic link that is installed into the stages. (diff)
downloadgentoo-2-7e8f25671f3ada5ba742d696c72223e770c9f3e7.tar.gz
gentoo-2-7e8f25671f3ada5ba742d696c72223e770c9f3e7.tar.bz2
gentoo-2-7e8f25671f3ada5ba742d696c72223e770c9f3e7.zip
add version from texlive 2011 pretest that supports both old and new kpathsea
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'dev-tex')
-rw-r--r--dev-tex/bibtexu/ChangeLog9
-rw-r--r--dev-tex/bibtexu/bibtexu-3.71_p20110627.ebuild41
-rw-r--r--dev-tex/bibtexu/files/bibtexu-3.71_p20110627-invoc_name.patch16
3 files changed, 65 insertions, 1 deletions
diff --git a/dev-tex/bibtexu/ChangeLog b/dev-tex/bibtexu/ChangeLog
index b013a82c171e..6fb2e235e060 100644
--- a/dev-tex/bibtexu/ChangeLog
+++ b/dev-tex/bibtexu/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-tex/bibtexu
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/bibtexu/ChangeLog,v 1.8 2011/06/13 20:59:48 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/bibtexu/ChangeLog,v 1.9 2011/06/28 03:36:05 aballier Exp $
+
+*bibtexu-3.71_p20110627 (28 Jun 2011)
+
+ 28 Jun 2011; Alexis Ballier <aballier@gentoo.org>
+ +bibtexu-3.71_p20110627.ebuild,
+ +files/bibtexu-3.71_p20110627-invoc_name.patch:
+ add version from texlive 2011 pretest that supports both old and new kpathsea
13 Jun 2011; Matt Turner <mattst88@gentoo.org> bibtexu-3.71_p20100722.ebuild:
Added ~mips, bug 342513
diff --git a/dev-tex/bibtexu/bibtexu-3.71_p20110627.ebuild b/dev-tex/bibtexu/bibtexu-3.71_p20110627.ebuild
new file mode 100644
index 000000000000..8c701d1dba4a
--- /dev/null
+++ b/dev-tex/bibtexu/bibtexu-3.71_p20110627.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/bibtexu/bibtexu-3.71_p20110627.ebuild,v 1.1 2011/06/28 03:36:05 aballier Exp $
+
+EAPI=3
+
+inherit eutils
+
+DESCRIPTION="8-bit Implementation of BibTeX 0.99 with a Very Large Capacity"
+HOMEPAGE="http://tug.org/texlive/"
+SRC_URI="mirror://gentoo/texlive-${PV#*_p}-source.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="dev-libs/kpathsea
+ >=dev-libs/icu-4.4"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/texlive-${PV#*_p}-source/texk/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-invoc_name.patch"
+}
+
+src_configure() {
+ econf --with-system-kpathsea \
+ --with-system-icu
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ csfdir="${EPREFIX}/usr/share/texmf-dist/bibtexu/csf/base" \
+ btdocdir="${EPREFIX}/usr/share/doc/${PF}" \
+ install || die
+ dodoc 00readme.txt ChangeLog csfile.txt HISTORY || die
+}
diff --git a/dev-tex/bibtexu/files/bibtexu-3.71_p20110627-invoc_name.patch b/dev-tex/bibtexu/files/bibtexu-3.71_p20110627-invoc_name.patch
new file mode 100644
index 000000000000..8991c3c88959
--- /dev/null
+++ b/dev-tex/bibtexu/files/bibtexu-3.71_p20110627-invoc_name.patch
@@ -0,0 +1,16 @@
+Index: texlive-20110627-source/texk/bibtexu/utils.c
+===================================================================
+--- texlive-20110627-source.orig/texk/bibtexu/utils.c
++++ texlive-20110627-source/texk/bibtexu/utils.c
+@@ -1261,7 +1261,11 @@ static void setup_bound_variable (Intege
+ {
+ #ifdef KPATHSEA
+ char *expansion = kpse_var_value (name);
++#ifdef kpse_invocation_name
+ const char *me = kpse_invocation_name;
++#else
++ const char *me = program_invocation_name;
++#endif
+ const char *src = " or texmf.cnf";
+ #else
+ char *expansion = getenv (name);