summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlistair Bush <ali_bush@gentoo.org>2011-06-22 09:42:52 +0000
committerAlistair Bush <ali_bush@gentoo.org>2011-06-22 09:42:52 +0000
commit29e195776b2b3baa0323cbfbfb46b09e5eab80f9 (patch)
tree40ddfba87e6584c05c546fcbe532e99fbc4b77ea /dev-util/argouml
parentx86 stable wrt security bug #371320 (diff)
downloadgentoo-2-29e195776b2b3baa0323cbfbfb46b09e5eab80f9.tar.gz
gentoo-2-29e195776b2b3baa0323cbfbfb46b09e5eab80f9.tar.bz2
gentoo-2-29e195776b2b3baa0323cbfbfb46b09e5eab80f9.zip
Version Bump.
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/argouml')
-rw-r--r--dev-util/argouml/ChangeLog7
-rw-r--r--dev-util/argouml/argouml-0.32.2.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/dev-util/argouml/ChangeLog b/dev-util/argouml/ChangeLog
index 786fb0475d0e..86e1e8380446 100644
--- a/dev-util/argouml/ChangeLog
+++ b/dev-util/argouml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/argouml
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/argouml/ChangeLog,v 1.30 2011/01/18 15:55:40 fordfrog Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/argouml/ChangeLog,v 1.31 2011/06/22 09:42:52 ali_bush Exp $
+
+*argouml-0.32.2 (22 Jun 2011)
+
+ 22 Jun 2011; Alistair Bush <ali_bush@gentoo.org> +argouml-0.32.2.ebuild:
+ Version Bump.
*argouml-0.30.2 (18 Jan 2011)
diff --git a/dev-util/argouml/argouml-0.32.2.ebuild b/dev-util/argouml/argouml-0.32.2.ebuild
new file mode 100644
index 000000000000..aa710193d1d7
--- /dev/null
+++ b/dev-util/argouml/argouml-0.32.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/argouml/argouml-0.32.2.ebuild,v 1.1 2011/06/22 09:42:52 ali_bush Exp $
+
+EAPI="3"
+
+inherit fdo-mime java-pkg-2
+
+DESCRIPTION="modelling tool that helps you do your design using UML"
+HOMEPAGE="http://argouml.tigris.org"
+BASE_URI="http://argouml-downloads.tigris.org/nonav/${P}"
+SRC_URI="${BASE_URI}/ArgoUML-${PV}.tar.gz
+ http://argouml-downloads.tigris.org/nonav/argouml-db-1.0/dbuml-module-1.0.4.zip
+ doc? (
+ ${BASE_URI}/manual-${PV}.pdf
+ ${BASE_URI}/quickguide-${PV}.pdf
+ )"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="doc"
+
+DEPEND="app-arch/unzip"
+RDEPEND=">=virtual/jre-1.5"
+
+S="${WORKDIR}"
+
+src_compile() { :; }
+
+src_install() {
+ java-pkg_jarinto /opt/${PN}/lib
+ java-pkg_dojar ${P}/*.jar
+
+ java-pkg_jarinto /opt/${PN}/lib/ext
+ java-pkg_dojar ${P}/ext/*.jar release/ext/*.jar
+
+ java-pkg_dolauncher ${PN} --main org.argouml.application.Main
+
+ dodoc ${P}/README.txt || die
+
+ if use doc ; then
+ dohtml -r release/{Readme.htm,www}
+ insinto /usr/share/doc/${P}
+ doins "${DISTDIR}/manual-${PV}.pdf"
+ doins "${DISTDIR}/quickguide-${PV}.pdf"
+ fi
+
+ doicon "${FILESDIR}"/${PN}.png || die
+ make_desktop_entry ${PN} "ArgoUML" ${PN} "Graphics"
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}