summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2011-11-19 17:26:48 +0000
committerMichał Górny <mgorny@gentoo.org>2011-11-19 17:26:48 +0000
commit6a25c45cf54fd695cb574a428cb930a61694bb9c (patch)
treedaef5851e761d4816b00d3760a224a79c4a128f5 /dev-util/atomic-install/atomic-install-0.1.1.ebuild
parentUpdate v8 dependency to 3.7.7, thanks to Martin Jansa in bug 391007. Make liv... (diff)
downloadgentoo-2-6a25c45cf54fd695cb574a428cb930a61694bb9c.tar.gz
gentoo-2-6a25c45cf54fd695cb574a428cb930a61694bb9c.tar.bz2
gentoo-2-6a25c45cf54fd695cb574a428cb930a61694bb9c.zip
Version bump. The new version fixes copying empty files and a few minor warnings.
(Portage version: 2.2.0_alpha75_p11/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/atomic-install/atomic-install-0.1.1.ebuild')
-rw-r--r--dev-util/atomic-install/atomic-install-0.1.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/atomic-install/atomic-install-0.1.1.ebuild b/dev-util/atomic-install/atomic-install-0.1.1.ebuild
new file mode 100644
index 000000000000..c45a9cf8e3da
--- /dev/null
+++ b/dev-util/atomic-install/atomic-install-0.1.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/atomic-install/atomic-install-0.1.1.ebuild,v 1.1 2011/11/19 17:26:48 mgorny Exp $
+
+EAPI=4
+inherit autotools-utils
+
+DESCRIPTION="A library and tool to atomically install sets of files"
+HOMEPAGE="https://github.com/mgorny/atomic-install/"
+SRC_URI="mirror://github/mgorny/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc static-libs xattr"
+
+RDEPEND="xattr? ( sys-apps/attr )"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-util/gtk-doc-1.18 )"
+
+src_configure() {
+ myeconfargs=(
+ $(use_enable doc gtk-doc)
+ $(use_enable xattr libattr)
+ )
+
+ autotools-utils_src_configure
+}