summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2013-09-05 16:21:34 +0000
committerMichael Weber <xmw@gentoo.org>2013-09-05 16:21:34 +0000
commitec3e04bcabab93ff4a6003a511227ca1548b7674 (patch)
tree88db319e06945c1e79f7e342c8c6655ac722d30b /dev-util/biew
parentRewrite init.d-script to avoid -D as a workaround for bug #344875, import som... (diff)
downloadgentoo-2-ec3e04bcabab93ff4a6003a511227ca1548b7674.tar.gz
gentoo-2-ec3e04bcabab93ff4a6003a511227ca1548b7674.tar.bz2
gentoo-2-ec3e04bcabab93ff4a6003a511227ca1548b7674.zip
Respect AR, thanks ago, bug 483734.
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'dev-util/biew')
-rw-r--r--dev-util/biew/ChangeLog10
-rw-r--r--dev-util/biew/biew-6.1.0-r3.ebuild66
2 files changed, 73 insertions, 3 deletions
diff --git a/dev-util/biew/ChangeLog b/dev-util/biew/ChangeLog
index fb251767cac1..e690562ba7b7 100644
--- a/dev-util/biew/ChangeLog
+++ b/dev-util/biew/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/biew
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/biew/ChangeLog,v 1.36 2012/06/08 11:38:20 phajdan.jr Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/biew/ChangeLog,v 1.37 2013/09/05 16:21:34 xmw Exp $
+
+*biew-6.1.0-r3 (05 Sep 2013)
+
+ 05 Sep 2013; Michael Weber <xmw@gentoo.org> +biew-6.1.0-r3.ebuild:
+ Respect AR, thanks ago, bug 483734.
08 Jun 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> biew-6.1.0-r2.ebuild:
x86 stable wrt bug #418943
@@ -146,4 +151,3 @@
metadata.xml:
Initial commit, closes #41027. Thanks to Daniel Fullmer <lsmod@hotmail.com>
for the original ebuild.
-
diff --git a/dev-util/biew/biew-6.1.0-r3.ebuild b/dev-util/biew/biew-6.1.0-r3.ebuild
new file mode 100644
index 000000000000..df7d87f7d6a2
--- /dev/null
+++ b/dev-util/biew/biew-6.1.0-r3.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/biew/biew-6.1.0-r3.ebuild,v 1.1 2013/09/05 16:21:34 xmw Exp $
+
+EAPI=4
+inherit eutils flag-o-matic toolchain-funcs versionator
+
+MY_P=${PN}-$(replace_all_version_separators "")
+
+DESCRIPTION="A portable viewer of binary files, hexadecimal and disassembler modes."
+HOMEPAGE="http://beye.sourceforge.net/"
+SRC_URI="mirror://sourceforge/beye/${PV}/${MY_P}-src.tar.bz2"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gpm mmx sse"
+REQUIRED_USE="mmx sse"
+
+RDEPEND="gpm? ( sys-libs/gpm )"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ append-flags -mmmx -msse #362043
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-610-fix_localedep-1.patch"
+ epatch "${FILESDIR}/${PN}-610-portable_configure-1.patch"
+ epatch "${FILESDIR}/${PN}-610-crash.patch"
+ sed -i -e 's^man/man1/biew.1^share/man/man1/biew.1^' makefile || die "Failed to edit makefile."
+}
+
+src_configure() {
+ if use gpm; then
+ append-cppflags -DHAVE_MOUSE
+ else
+ append-cppflags -UHAVE_MOUSE
+ fi
+ ./configure --datadir=/usr/share/${PN} \
+ --prefix=/usr \
+ --cc="$(tc-getCC)" \
+ --ld="$(tc-getCC)" \
+ --ar="$(tc-getAR) -rcu" \
+ --as="$(tc-getAS)" \
+ --ranlib="$(tc-getRANLIB)" || die "configure failed."
+}
+
+src_compile() {
+ emake LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc doc/{biew_en,release,unix}.txt
+}
+
+pkg_postinst() {
+ elog
+ elog "Note: if you are upgrading from <=dev-util/biew-6.1.0 you will need"
+ elog "to change the paths in the setup dialog (F9) from /usr/share/ to"
+ elog "/usr/share/biew/ Alternatively, you can delete ~/.biewrc and it will"
+ elog "automatically determine the correct locations on the next run."
+ elog
+}