summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Kolmodin <kolmodin@gentoo.org>2006-10-11 21:52:53 +0000
committerLennart Kolmodin <kolmodin@gentoo.org>2006-10-11 21:52:53 +0000
commit2fe9bf97f11b02acc42997a6261f96be6bdeaa94 (patch)
treee4679b9ae9fadb6c3fa0553e6cc0ba447f9f396f /dev-util/bnfc/bnfc-2.2.ebuild
parentversion bump (diff)
downloadgentoo-2-2fe9bf97f11b02acc42997a6261f96be6bdeaa94.tar.gz
gentoo-2-2fe9bf97f11b02acc42997a6261f96be6bdeaa94.tar.bz2
gentoo-2-2fe9bf97f11b02acc42997a6261f96be6bdeaa94.zip
Made bnfc-* play nice with dev-lang/ghc-6.6
(Portage version: 2.1.2_pre1-r1)
Diffstat (limited to 'dev-util/bnfc/bnfc-2.2.ebuild')
-rw-r--r--dev-util/bnfc/bnfc-2.2.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/dev-util/bnfc/bnfc-2.2.ebuild b/dev-util/bnfc/bnfc-2.2.ebuild
index 2e167e8f77df..cf695a1c62c1 100644
--- a/dev-util/bnfc/bnfc-2.2.ebuild
+++ b/dev-util/bnfc/bnfc-2.2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/bnfc/bnfc-2.2.ebuild,v 1.1 2005/10/08 17:22:30 kosmikus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bnfc/bnfc-2.2.ebuild,v 1.2 2006/10/11 21:52:53 kolmodin Exp $
-inherit ghc-package
+inherit base ghc-package
MY_PN="BNFC"
@@ -22,6 +22,12 @@ RDEPEND="virtual/libc"
S="${WORKDIR}/${MY_PN}_${PV}"
+src_unpack() {
+ base_src_unpack
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-ghc66-utf8.patch"
+}
+
src_compile() {
emake GHC="$(ghc-getghc) -O" || die "emake failed"
if use doc ; then