summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-20 20:16:13 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-20 20:16:13 +0000
commit72fd2ec2280997ff6ba26a14923d25915889a569 (patch)
treee43b81e15c5ecb84f5c398148265f220a107d996 /dev-util/buildbot-slave
parentx86 stable wrt bug #323573 (diff)
downloadgentoo-2-72fd2ec2280997ff6ba26a14923d25915889a569.tar.gz
gentoo-2-72fd2ec2280997ff6ba26a14923d25915889a569.tar.bz2
gentoo-2-72fd2ec2280997ff6ba26a14923d25915889a569.zip
Version bump.
(Portage version: 2.2.0_alpha9_p9/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/buildbot-slave')
-rw-r--r--dev-util/buildbot-slave/ChangeLog8
-rw-r--r--dev-util/buildbot-slave/buildbot-slave-0.8.3.ebuild53
2 files changed, 60 insertions, 1 deletions
diff --git a/dev-util/buildbot-slave/ChangeLog b/dev-util/buildbot-slave/ChangeLog
index 54f77cce40da..216a06acfeb6 100644
--- a/dev-util/buildbot-slave/ChangeLog
+++ b/dev-util/buildbot-slave/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/buildbot-slave
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot-slave/ChangeLog,v 1.2 2010/12/20 09:38:47 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot-slave/ChangeLog,v 1.3 2010/12/20 20:16:13 arfrever Exp $
+
+*buildbot-slave-0.8.3 (20 Dec 2010)
+
+ 20 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +buildbot-slave-0.8.3.ebuild:
+ Version bump.
20 Dec 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
buildbot-slave-0.8.2.ebuild:
diff --git a/dev-util/buildbot-slave/buildbot-slave-0.8.3.ebuild b/dev-util/buildbot-slave/buildbot-slave-0.8.3.ebuild
new file mode 100644
index 000000000000..eace97f98078
--- /dev/null
+++ b/dev-util/buildbot-slave/buildbot-slave-0.8.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot-slave/buildbot-slave-0.8.3.ebuild,v 1.1 2010/12/20 20:16:13 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+DISTUTILS_SRC_TEST="trial buildslave"
+DISTUTILS_DISABLE_TEST_DEPENDENCY="1"
+
+inherit distutils eutils
+
+DESCRIPTION="BuildBot Slave Daemon"
+HOMEPAGE="http://trac.buildbot.net/ http://code.google.com/p/buildbot/ http://pypi.python.org/pypi/buildbot-slave"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/setuptools
+ >=dev-python/twisted-2
+ !!<dev-util/buildbot-0.8.1"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock )"
+
+PYTHON_MODNAME="buildslave"
+
+pkg_setup() {
+ python_pkg_setup
+ enewuser buildbot
+}
+
+src_install() {
+ distutils_src_install
+
+ newconfd "${FILESDIR}/buildslave.confd" buildslave || die "newconfd failed"
+ newinitd "${FILESDIR}/buildslave.initd" buildslave || die "newinitd failed"
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ elog "The \"buildbot\" user and the \"buildslave\" init script has been added"
+ elog "to support starting buildslave through Gentoo's init system. To use this,"
+ elog "set up your build slave following the documentation, make sure the"
+ elog "resulting directories are owned by the \"buildbot\" user and point"
+ elog "\"${ROOT}etc/conf.d/buildslave\" at the right location. The scripts can"
+ elog "run as a different user if desired. If you need to run more than one"
+ elog "build slave, just copy the scripts."
+}