summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2007-03-06 19:25:40 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2007-03-06 19:25:40 +0000
commit019c7adfdcd8b78e6c0d22cdffec0dbb57d38895 (patch)
tree0c224652d0d8894f7004b1dc89de1a066577cca8 /dev-util/catalyst
parentStable on ppc wrt bug #153911. (diff)
downloadgentoo-2-019c7adfdcd8b78e6c0d22cdffec0dbb57d38895.tar.gz
gentoo-2-019c7adfdcd8b78e6c0d22cdffec0dbb57d38895.tar.bz2
gentoo-2-019c7adfdcd8b78e6c0d22cdffec0dbb57d38895.zip
Version bump to the latest catalyst 2.0.3 pre-release to fix bug #166294, bug #166420, bug #166426, bug #166695, and bug #166363.
(Portage version: 2.1.2.1)
Diffstat (limited to 'dev-util/catalyst')
-rw-r--r--dev-util/catalyst/ChangeLog9
-rw-r--r--dev-util/catalyst/catalyst-2.0.3_pre3.ebuild76
-rw-r--r--dev-util/catalyst/files/digest-catalyst-2.0.3_pre33
3 files changed, 87 insertions, 1 deletions
diff --git a/dev-util/catalyst/ChangeLog b/dev-util/catalyst/ChangeLog
index c319200f8242..9a2177a8fbc8 100644
--- a/dev-util/catalyst/ChangeLog
+++ b/dev-util/catalyst/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/catalyst
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/ChangeLog,v 1.163 2007/03/05 03:25:22 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/ChangeLog,v 1.164 2007/03/06 19:25:40 wolf31o2 Exp $
+
+*catalyst-2.0.3_pre3 (06 Mar 2007)
+
+ 06 Mar 2007; Chris Gianelloni <wolf31o2@gentoo.org>
+ +catalyst-2.0.3_pre3.ebuild:
+ Version bump to the latest catalyst 2.0.3 pre-release to fix bug #166294,
+ bug #166420, bug #166426, bug #166695, and bug #166363.
05 Mar 2007; Marius Mauch <genone@gentoo.org> catalyst-1.1.10.10.ebuild,
catalyst-2.0.2.ebuild, catalyst-2.0.3_pre1.ebuild,
diff --git a/dev-util/catalyst/catalyst-2.0.3_pre3.ebuild b/dev-util/catalyst/catalyst-2.0.3_pre3.ebuild
new file mode 100644
index 000000000000..ca0bdf8e572f
--- /dev/null
+++ b/dev-util/catalyst/catalyst-2.0.3_pre3.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0.3_pre3.ebuild,v 1.1 2007/03/06 19:25:40 wolf31o2 Exp $
+
+inherit eutils
+
+DESCRIPTION="Gentoo Linux official release metatool"
+HOMEPAGE="http://www.gentoo.org/proj/en/releng/catalyst"
+SRC_URI="http://dev.gentoo.org/~wolf31o2/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="ccache cdr"
+
+DEPEND=""
+RDEPEND="dev-lang/python
+ app-crypt/shash
+ amd64? ( sys-apps/setarch )
+ ppc64? ( sys-apps/setarch )
+ ccache? ( dev-util/ccache )
+ cdr? (
+ virtual/cdrtools
+ ia64? ( sys-fs/dosfstools )
+ app-misc/zisofs-tools
+ >=sys-fs/squashfs-tools-2.1 )"
+
+pkg_setup() {
+ if use ccache ; then
+ einfo "Enabling ccache support for catalyst."
+ else
+ ewarn "By default, ccache support for catalyst is disabled."
+ ewarn "If this is not what you intended,"
+ ewarn "then you should add ccache to your USE."
+ fi
+ echo
+ elog "The template spec files are now installed by default. You can find"
+ elog "them under /usr/share/doc/${PF}/examples"
+ elog "and they are considered to be the authorative source of information"
+ elog "on catalyst."
+}
+
+src_install() {
+ insinto /usr/lib/${PN}/arch
+ doins arch/* || die "copying arch/*"
+ insinto /usr/lib/${PN}/modules
+ doins modules/* || die "copying modules/*"
+ insinto /usr/lib/${PN}/livecd/cdtar
+ doins livecd/cdtar/* || die "copying cdtar/*"
+ insinto /usr/lib/${PN}/livecd/files
+ doins livecd/files/* || die "copying files/*"
+ for x in targets/*; do
+ exeinto /usr/lib/${PN}/$x
+ doexe $x/* || die "copying ${x}"
+ done
+ exeinto /usr/lib/${PN}
+ doexe catalyst || die "copying catalyst"
+ dodir /usr/bin
+ dosym /usr/lib/${PN}/catalyst /usr/bin/catalyst
+ insinto /etc/catalyst
+ doins files/catalyst.conf files/catalystrc || die "copying configuration"
+ DOCDESTTREE="." dohtml -A spec,msg,example -r examples files
+ dodoc README ChangeLog ChangeLog.old AUTHORS
+ doman files/catalyst.1
+ # Here is where we actually enable ccache
+ use ccache && \
+ dosed 's:options="autoresume kern:options="autoresume ccache kern:' \
+ /etc/catalyst/catalyst.conf
+}
+
+pkg_postinst() {
+ elog "You can find more information about catalyst by checking out the"
+ elog "catalyst project page at:"
+ elog "http://www.gentoo.org/proj/en/releng/catalyst/index.xml"
+ echo
+}
diff --git a/dev-util/catalyst/files/digest-catalyst-2.0.3_pre3 b/dev-util/catalyst/files/digest-catalyst-2.0.3_pre3
new file mode 100644
index 000000000000..8dd31e84e8da
--- /dev/null
+++ b/dev-util/catalyst/files/digest-catalyst-2.0.3_pre3
@@ -0,0 +1,3 @@
+MD5 ead55e988e5da610099f7e83fe9f1ec1 catalyst-2.0.3_pre3.tar.bz2 783672
+RMD160 9125a549d3804516fc261d7ebda62363ee624dcd catalyst-2.0.3_pre3.tar.bz2 783672
+SHA256 7fcdc5fc75f8cb0b4432de031d5c0c1c485db6afdd9e6ead25284685344a6b5b catalyst-2.0.3_pre3.tar.bz2 783672