summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2011-07-17 00:29:56 +0000
committerMatt Turner <mattst88@gentoo.org>2011-07-17 00:29:56 +0000
commit5fed0f17f125a346d506c4cc0ab27ccff3cccbf3 (patch)
treeff934caec9c562b8b1f6c2c91df5beda97200c34 /dev-util/catalyst
parentVersion bump for dev channel release. Fixes bug #372561 by Florian Scandella ... (diff)
downloadgentoo-2-5fed0f17f125a346d506c4cc0ab27ccff3cccbf3.tar.gz
gentoo-2-5fed0f17f125a346d506c4cc0ab27ccff3cccbf3.tar.bz2
gentoo-2-5fed0f17f125a346d506c4cc0ab27ccff3cccbf3.zip
Add catalyst-2.9999.ebuild for catalyst_2 git branch. Clean up other ebuilds.
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/catalyst')
-rw-r--r--dev-util/catalyst/ChangeLog9
-rw-r--r--dev-util/catalyst/catalyst-2.0.6.916.ebuild23
-rw-r--r--dev-util/catalyst/catalyst-2.0.6.918.ebuild23
-rw-r--r--dev-util/catalyst/catalyst-2.0.6.ebuild29
-rw-r--r--dev-util/catalyst/catalyst-2.9999.ebuild97
-rw-r--r--dev-util/catalyst/catalyst-9999.ebuild28
6 files changed, 147 insertions, 62 deletions
diff --git a/dev-util/catalyst/ChangeLog b/dev-util/catalyst/ChangeLog
index 8a97bbe643d8..c7527535dbf6 100644
--- a/dev-util/catalyst/ChangeLog
+++ b/dev-util/catalyst/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/catalyst
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/ChangeLog,v 1.232 2011/07/16 18:25:50 jmbsvicetto Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/ChangeLog,v 1.233 2011/07/17 00:29:56 mattst88 Exp $
+
+*catalyst-2.9999 (17 Jul 2011)
+
+ 17 Jul 2011; Matt Turner <mattst88@gentoo.org> catalyst-2.0.6.ebuild,
+ catalyst-2.0.6.916.ebuild, catalyst-2.0.6.918.ebuild,
+ +catalyst-2.9999.ebuild, catalyst-9999.ebuild:
+ Add catalyst-2.9999.ebuild for catalyst_2 git branch. Clean up other ebuilds.
*catalyst-2.0.6.918 (16 Jul 2011)
diff --git a/dev-util/catalyst/catalyst-2.0.6.916.ebuild b/dev-util/catalyst/catalyst-2.0.6.916.ebuild
index f7d8e5d71636..f43cbebc742d 100644
--- a/dev-util/catalyst/catalyst-2.0.6.916.ebuild
+++ b/dev-util/catalyst/catalyst-2.0.6.916.ebuild
@@ -1,21 +1,21 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0.6.916.ebuild,v 1.4 2011/06/27 05:04:18 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0.6.916.ebuild,v 1.5 2011/07/17 00:29:56 mattst88 Exp $
# catalyst-9999 -> latest Git
+# catalyst-2.9999 -> catalyst_2 branch from Git
# catalyst-VER -> normal catalyst release
EAPI=2
-if [[ ${PV} == 9999* ]]; then
+if [[ ${PV} == 9999* || ${PV} == 2.9999* ]]; then
EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/catalyst.git"
inherit git-2
SRC_URI=""
S="${WORKDIR}/${PN}"
KEYWORDS=""
else
- SRC_URI="mirror://gentoo/${P}.tar.bz2
- http://wolf31o2.org/sources/${PN}/${P}.tar.bz2"
+ SRC_URI="mirror://gentoo/${P}.tar.bz2"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
fi
inherit eutils multilib
@@ -50,11 +50,13 @@ pkg_setup() {
einfo "and they are considered to be the authorative source of information"
einfo "on catalyst."
echo
- ewarn "The git master branch (what you get with this -9999 ebuild) for catalyst"
- ewarn "now contains the work-in-progress code for catalyst-3.x. Be aware that"
- ewarn "it's very likely that it will not be in a working state at any given"
- ewarn "point. Please do not file bugs until you have posted on the gentoo-catalyst"
- ewarn "mailing list and we have asked you to do so."
+ if [[ ${PV} == 9999* || ${PV} == 2.9999* ]]; then
+ ewarn "The ${EGIT_BRANCH:-master} branch (what you get with this ${PV} ebuild) contains"
+ ewarn "work-in-progress code. Be aware that it's likely that it will not"
+ ewarn "be in a working state at any given point. Please do not file bugs"
+ ewarn "until you have posted on the gentoo-catalyst mailing list and we"
+ ewarn "have asked you to do so."
+ fi
}
src_install() {
@@ -63,9 +65,6 @@ src_install() {
doexe catalyst || die "copying catalyst"
if [[ ${PV} == 9999* ]]; then
doins -r modules files || die "copying files"
-
- # arch files don't live in modules/ in catalyst_2
- [[ ${EGIT_BRANCH} == "catalyst_2" ]] && { doins -r arch || die "copying files"; }
else
doins -r arch modules livecd || die "copying files"
fi
diff --git a/dev-util/catalyst/catalyst-2.0.6.918.ebuild b/dev-util/catalyst/catalyst-2.0.6.918.ebuild
index 2bdde3bc298a..0cee8ca37fd0 100644
--- a/dev-util/catalyst/catalyst-2.0.6.918.ebuild
+++ b/dev-util/catalyst/catalyst-2.0.6.918.ebuild
@@ -1,13 +1,14 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0.6.918.ebuild,v 1.1 2011/07/16 18:25:50 jmbsvicetto Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0.6.918.ebuild,v 1.2 2011/07/17 00:29:56 mattst88 Exp $
# catalyst-9999 -> latest Git
+# catalyst-2.9999 -> catalyst_2 branch from Git
# catalyst-VER -> normal catalyst release
EAPI=2
-if [[ ${PV} == 9999* ]]; then
+if [[ ${PV} == 9999* || ${PV} == 2.9999* ]]; then
EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/catalyst.git"
inherit git-2
SRC_URI=""
@@ -15,8 +16,7 @@ if [[ ${PV} == 9999* ]]; then
KEYWORDS=""
else
SRC_URI="mirror://gentoo/${P}.tar.bz2
- http://dev.gentoo.org/~jmbsvicetto/distfiles/${P}.tar.bz2
- http://wolf31o2.org/sources/${PN}/${P}.tar.bz2"
+ http://dev.gentoo.org/~jmbsvicetto/distfiles/${P}.tar.bz2"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
fi
inherit eutils multilib
@@ -51,11 +51,13 @@ pkg_setup() {
einfo "and they are considered to be the authorative source of information"
einfo "on catalyst."
echo
- ewarn "The git master branch (what you get with this -9999 ebuild) for catalyst"
- ewarn "now contains the work-in-progress code for catalyst-3.x. Be aware that"
- ewarn "it's very likely that it will not be in a working state at any given"
- ewarn "point. Please do not file bugs until you have posted on the gentoo-catalyst"
- ewarn "mailing list and we have asked you to do so."
+ if [[ ${PV} == 9999* || ${PV} == 2.9999* ]]; then
+ ewarn "The ${EGIT_BRANCH:-master} branch (what you get with this ${PV} ebuild) contains"
+ ewarn "work-in-progress code. Be aware that it's likely that it will not"
+ ewarn "be in a working state at any given point. Please do not file bugs"
+ ewarn "until you have posted on the gentoo-catalyst mailing list and we"
+ ewarn "have asked you to do so."
+ fi
}
src_install() {
@@ -64,9 +66,6 @@ src_install() {
doexe catalyst || die "copying catalyst"
if [[ ${PV} == 9999* ]]; then
doins -r modules files || die "copying files"
-
- # arch files don't live in modules/ in catalyst_2
- [[ ${EGIT_BRANCH} == "catalyst_2" ]] && { doins -r arch || die "copying files"; }
else
doins -r arch modules livecd || die "copying files"
fi
diff --git a/dev-util/catalyst/catalyst-2.0.6.ebuild b/dev-util/catalyst/catalyst-2.0.6.ebuild
index 1be42a67497f..774a909ce8a3 100644
--- a/dev-util/catalyst/catalyst-2.0.6.ebuild
+++ b/dev-util/catalyst/catalyst-2.0.6.ebuild
@@ -1,23 +1,14 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0.6.ebuild,v 1.6 2011/06/22 19:36:33 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0.6.ebuild,v 1.7 2011/07/17 00:29:56 mattst88 Exp $
-# catalyst-9999 -> latest SVN
-# catalyst-9999.REV -> use SVN REV
+# catalyst-9999 -> latest Git
+# catalyst-2.9999 -> catalyst_2 branch from Git
# catalyst-VER -> normal catalyst release
-if [[ ${PV} == 9999* ]]
-then
- [[ ${PV} == 9999.* ]] && ESVN_UPDATE_CMD="svn up -r ${PV/9999./}"
- ESVN_REPO_URI="svn://anonsvn.gentoo.org/catalyst/trunk"
- inherit subversion eutils multilib
- SRC_URI=""
- S=${WORKDIR}/trunk
-else
- inherit eutils multilib
- SRC_URI="mirror://gentoo/${P}.tar.bz2
- http://wolf31o2.org/sources/${PN}/${P}.tar.bz2"
-fi
+inherit eutils multilib
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://wolf31o2.org/sources/${PN}/${P}.tar.bz2"
DESCRIPTION="release metatool used for creating releases based on Gentoo Linux"
HOMEPAGE="http://www.gentoo.org/proj/en/releng/catalyst/"
@@ -54,12 +45,8 @@ pkg_setup() {
}
src_unpack() {
- if [[ ${PV} == 9999* ]] ; then
- subversion_src_unpack
- else
- unpack ${A}
- cd "${S}"
- fi
+ unpack ${A}
+ cd "${S}"
}
src_install() {
diff --git a/dev-util/catalyst/catalyst-2.9999.ebuild b/dev-util/catalyst/catalyst-2.9999.ebuild
new file mode 100644
index 000000000000..b97fc999b5de
--- /dev/null
+++ b/dev-util/catalyst/catalyst-2.9999.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.9999.ebuild,v 1.1 2011/07/17 00:29:56 mattst88 Exp $
+
+# catalyst-9999 -> latest Git
+# catalyst-2.9999 -> catalyst_2 branch from Git
+# catalyst-VER -> normal catalyst release
+
+EAPI=2
+
+if [[ ${PV} == 9999* || ${PV} == 2.9999* ]]; then
+ EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/catalyst.git"
+ EGIT_BRANCH="catalyst_2"
+ inherit git-2
+ SRC_URI=""
+ S="${WORKDIR}/${PN}"
+ KEYWORDS=""
+else
+ SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://dev.gentoo.org/~jmbsvicetto/distfiles/${P}.tar.bz2"
+ KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
+fi
+inherit eutils multilib
+
+DESCRIPTION="release metatool used for creating releases based on Gentoo Linux"
+HOMEPAGE="http://www.gentoo.org/proj/en/releng/catalyst/"
+
+LICENSE="GPL-2"
+SLOT="0"
+RESTRICT=""
+IUSE="ccache"
+
+DEPEND="app-text/asciidoc"
+RDEPEND="dev-lang/python
+ app-crypt/shash
+ virtual/cdrtools
+ ccache? ( dev-util/ccache )
+ ia64? ( sys-fs/dosfstools )
+ kernel_linux? ( app-misc/zisofs-tools >=sys-fs/squashfs-tools-2.1 )"
+
+pkg_setup() {
+ if use ccache ; then
+ einfo "Enabling ccache support for catalyst."
+ else
+ ewarn "By default, ccache support for catalyst is disabled."
+ ewarn "If this is not what you intended,"
+ ewarn "then you should add ccache to your USE."
+ fi
+ echo
+ einfo "The template spec files are now installed by default. You can find"
+ einfo "them under /usr/share/doc/${PF}/examples"
+ einfo "and they are considered to be the authorative source of information"
+ einfo "on catalyst."
+ echo
+ if [[ ${PV} == 9999* || ${PV} == 2.9999* ]]; then
+ ewarn "The ${EGIT_BRANCH:-master} branch (what you get with this ${PV} ebuild) contains"
+ ewarn "work-in-progress code. Be aware that it's likely that it will not"
+ ewarn "be in a working state at any given point. Please do not file bugs"
+ ewarn "until you have posted on the gentoo-catalyst mailing list and we"
+ ewarn "have asked you to do so."
+ fi
+}
+
+src_install() {
+ insinto /usr/$(get_libdir)/${PN}
+ exeinto /usr/$(get_libdir)/${PN}
+ doexe catalyst || die "copying catalyst"
+ if [[ ${PV} == 9999* ]]; then
+ doins -r modules files || die "copying files"
+ else
+ doins -r arch modules livecd || die "copying files"
+ fi
+ for x in targets/*; do
+ exeinto /usr/$(get_libdir)/${PN}/$x
+ doexe $x/* || die "copying ${x}"
+ done
+ make_wrapper catalyst /usr/$(get_libdir)/${PN}/catalyst
+ insinto /etc/catalyst
+ doins files/catalyst.conf files/catalystrc || die "copying configuration"
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/* || die
+ dodoc README ChangeLog AUTHORS
+ doman files/catalyst.1
+ # Here is where we actually enable ccache
+ use ccache && \
+ dosed 's:options="autoresume kern:options="autoresume ccache kern:' \
+ /etc/catalyst/catalyst.conf
+ dosed "s:/usr/lib/catalyst:/usr/$(get_libdir)/catalyst:" \
+ /etc/catalyst/catalyst.conf
+}
+
+pkg_postinst() {
+ einfo "You can find more information about catalyst by checking out the"
+ einfo "catalyst project page at:"
+ einfo "http://www.gentoo.org/proj/en/releng/catalyst/index.xml"
+ echo
+}
diff --git a/dev-util/catalyst/catalyst-9999.ebuild b/dev-util/catalyst/catalyst-9999.ebuild
index b5a7094a4e08..6274ab1fb119 100644
--- a/dev-util/catalyst/catalyst-9999.ebuild
+++ b/dev-util/catalyst/catalyst-9999.ebuild
@@ -1,13 +1,14 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-9999.ebuild,v 1.14 2011/06/27 05:04:18 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-9999.ebuild,v 1.15 2011/07/17 00:29:56 mattst88 Exp $
# catalyst-9999 -> latest Git
+# catalyst-2.9999 -> catalyst_2 branch from Git
# catalyst-VER -> normal catalyst release
EAPI=2
-if [[ ${PV} == 9999* ]]; then
+if [[ ${PV} == 9999* || ${PV} == 2.9999* ]]; then
EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/catalyst.git"
inherit git-2
SRC_URI=""
@@ -15,7 +16,7 @@ if [[ ${PV} == 9999* ]]; then
KEYWORDS=""
else
SRC_URI="mirror://gentoo/${P}.tar.bz2
- http://wolf31o2.org/sources/${PN}/${P}.tar.bz2"
+ http://dev.gentoo.org/~jmbsvicetto/distfiles/${P}.tar.bz2"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
fi
inherit eutils multilib
@@ -28,7 +29,7 @@ SLOT="0"
RESTRICT=""
IUSE="ccache"
-DEPEND=""
+DEPEND="app-text/asciidoc"
RDEPEND="dev-lang/python
app-crypt/shash
virtual/cdrtools
@@ -36,10 +37,6 @@ RDEPEND="dev-lang/python
ia64? ( sys-fs/dosfstools )
kernel_linux? ( app-misc/zisofs-tools >=sys-fs/squashfs-tools-2.1 )"
-if [[ ${PV} == 9999* ]]; then
- DEPEND="${DEPEND} app-text/asciidoc"
-fi
-
pkg_setup() {
if use ccache ; then
einfo "Enabling ccache support for catalyst."
@@ -54,11 +51,13 @@ pkg_setup() {
einfo "and they are considered to be the authorative source of information"
einfo "on catalyst."
echo
- ewarn "The git master branch (what you get with this -9999 ebuild) for catalyst"
- ewarn "now contains the work-in-progress code for catalyst-3.x. Be aware that"
- ewarn "it's very likely that it will not be in a working state at any given"
- ewarn "point. Please do not file bugs until you have posted on the gentoo-catalyst"
- ewarn "mailing list and we have asked you to do so."
+ if [[ ${PV} == 9999* || ${PV} == 2.9999* ]]; then
+ ewarn "The ${EGIT_BRANCH:-master} branch (what you get with this ${PV} ebuild) contains"
+ ewarn "work-in-progress code. Be aware that it's likely that it will not"
+ ewarn "be in a working state at any given point. Please do not file bugs"
+ ewarn "until you have posted on the gentoo-catalyst mailing list and we"
+ ewarn "have asked you to do so."
+ fi
}
src_install() {
@@ -67,9 +66,6 @@ src_install() {
doexe catalyst || die "copying catalyst"
if [[ ${PV} == 9999* ]]; then
doins -r modules files || die "copying files"
-
- # arch files don't live in modules/ in catalyst_2
- [[ ${EGIT_BRANCH} == "catalyst_2" ]] && { doins -r arch || die "copying files"; }
else
doins -r arch modules livecd || die "copying files"
fi