summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-08-11 16:04:33 +0000
committerMike Frysinger <vapier@gentoo.org>2012-08-11 16:04:33 +0000
commit58369324e6f5c485cde55a08c88139de20e2465a (patch)
tree1095430c5a3df659b894c96bc7e56b0913df26f8 /dev-util/ccache
parentFix building against sys-libs/glibc-2.16 by Diego Elio Pettenò (bug #426188). (diff)
downloadgentoo-2-58369324e6f5c485cde55a08c88139de20e2465a.tar.gz
gentoo-2-58369324e6f5c485cde55a08c88139de20e2465a.tar.bz2
gentoo-2-58369324e6f5c485cde55a08c88139de20e2465a.zip
Version bump.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/ccache')
-rw-r--r--dev-util/ccache/ChangeLog7
-rw-r--r--dev-util/ccache/ccache-3.1.8.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/dev-util/ccache/ChangeLog b/dev-util/ccache/ChangeLog
index c3ec45bf5e47..1cd504f3565d 100644
--- a/dev-util/ccache/ChangeLog
+++ b/dev-util/ccache/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/ccache
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/ccache/ChangeLog,v 1.98 2012/07/01 16:39:59 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ccache/ChangeLog,v 1.99 2012/08/11 16:04:33 vapier Exp $
+
+*ccache-3.1.8 (11 Aug 2012)
+
+ 11 Aug 2012; Mike Frysinger <vapier@gentoo.org> +ccache-3.1.8.ebuild:
+ Version bump.
01 Jul 2012; Raúl Porcel <armin76@gentoo.org> ccache-3.1.7.ebuild:
alpha/ia64/m68k/s390/sh/sparc stable wrt #418945
diff --git a/dev-util/ccache/ccache-3.1.8.ebuild b/dev-util/ccache/ccache-3.1.8.ebuild
new file mode 100644
index 000000000000..fcc18f583164
--- /dev/null
+++ b/dev-util/ccache/ccache-3.1.8.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ccache/ccache-3.1.8.ebuild,v 1.1 2012/08/11 16:04:33 vapier Exp $
+
+EAPI="4"
+
+inherit multilib eutils
+
+DESCRIPTION="fast compiler cache"
+HOMEPAGE="http://ccache.samba.org/"
+SRC_URI="http://samba.org/ftp/ccache/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ # make sure we always use system zlib
+ rm -rf zlib
+ epatch "${FILESDIR}"/${PN}-3.1.7-no-perl.patch #421609
+ sed \
+ -e "/^LIBDIR=/s:lib:$(get_libdir):" \
+ "${FILESDIR}"/ccache-config > ccache-config || die
+}
+
+src_install() {
+ default
+ dodoc AUTHORS.txt MANUAL.txt NEWS.txt README.txt
+
+ dobin ccache-config
+}
+
+pkg_postinst() {
+ "${ROOT}"/usr/bin/ccache-config --install-links
+ "${ROOT}"/usr/bin/ccache-config --install-links ${CHOST}
+
+ # nuke broken symlinks from previous versions that shouldn't exist
+ rm -f "${ROOT}/usr/$(get_libdir)/ccache/bin/${CHOST}-cc"
+ [[ -d "${ROOT}/usr/$(get_libdir)/ccache.backup" ]] && \
+ rm -rf "${ROOT}/usr/$(get_libdir)/ccache.backup"
+
+ elog "To use ccache with **non-Portage** C compiling, add"
+ elog "/usr/$(get_libdir)/ccache/bin to the beginning of your path, before /usr/bin."
+ elog "Portage 2.0.46-r11+ will automatically take advantage of ccache with"
+ elog "no additional steps. If this is your first install of ccache, type"
+ elog "something like this to set a maximum cache size of 2GB:"
+ elog "# ccache -M 2G"
+ elog
+ elog "If you are upgrading from an older version than 3.x you should clear"
+ elog "all of your caches like so:"
+ elog "# CCACHE_DIR='${CCACHE_DIR:-${PORTAGE_TMPDIR}/ccache}' ccache -C"
+}