summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-11-20 00:06:03 +0000
committerMike Frysinger <vapier@gentoo.org>2014-11-20 00:06:03 +0000
commite8cd007d0125e8e5570508ad3c1dd90804e0a43a (patch)
treee035923f1eff81454ccfe32bd4ea5215e64d5bb6 /dev-util/ccache
parentafl bump (diff)
downloadgentoo-2-e8cd007d0125e8e5570508ad3c1dd90804e0a43a.tar.gz
gentoo-2-e8cd007d0125e8e5570508ad3c1dd90804e0a43a.tar.bz2
gentoo-2-e8cd007d0125e8e5570508ad3c1dd90804e0a43a.zip
Version bump.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'dev-util/ccache')
-rw-r--r--dev-util/ccache/ChangeLog7
-rw-r--r--dev-util/ccache/ccache-3.2.ebuild68
2 files changed, 74 insertions, 1 deletions
diff --git a/dev-util/ccache/ChangeLog b/dev-util/ccache/ChangeLog
index fe6ccf8f8c51..f27f0feeaa53 100644
--- a/dev-util/ccache/ChangeLog
+++ b/dev-util/ccache/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/ccache
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/ccache/ChangeLog,v 1.142 2014/11/04 04:51:22 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ccache/ChangeLog,v 1.143 2014/11/20 00:06:03 vapier Exp $
+
+*ccache-3.2 (20 Nov 2014)
+
+ 20 Nov 2014; Mike Frysinger <vapier@gentoo.org> +ccache-3.2.ebuild:
+ Version bump.
04 Nov 2014; Mike Frysinger <vapier@gentoo.org> files/ccache-config-2:
Trim empty ccache dirs automatically #517242 by Arfrever Frehtes Taifersar
diff --git a/dev-util/ccache/ccache-3.2.ebuild b/dev-util/ccache/ccache-3.2.ebuild
new file mode 100644
index 000000000000..467e59c93c50
--- /dev/null
+++ b/dev-util/ccache/ccache-3.2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ccache/ccache-3.2.ebuild,v 1.1 2014/11/20 00:06:03 vapier Exp $
+
+EAPI="4"
+
+inherit eutils readme.gentoo
+
+DESCRIPTION="fast compiler cache"
+HOMEPAGE="http://ccache.samba.org/"
+SRC_URI="http://samba.org/ftp/ccache/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils"
+
+src_prepare() {
+ # make sure we always use system zlib
+ rm -rf zlib
+ epatch "${FILESDIR}"/${PN}-3.1.7-no-perl.patch #421609
+ epatch "${FILESDIR}"/${PN}-3.1.10-size-on-disk.patch #456178
+ sed \
+ -e "/^EPREFIX=/s:'':'${EPREFIX}':" \
+ "${FILESDIR}"/ccache-config-2 > ccache-config || die
+}
+
+src_install() {
+ default
+ dodoc AUTHORS.txt MANUAL.txt NEWS.txt README.txt
+
+ dobin ccache-config
+
+ DOC_CONTENTS="
+To use ccache with **non-Portage** C compiling, add
+${EPREFIX}/usr/lib/ccache/bin to the beginning of your path, before ${EPREFIX}usr/bin.
+Portage 2.0.46-r11+ will automatically take advantage of ccache with
+no additional steps. If this is your first install of ccache, type
+something like this to set a maximum cache size of 2GB:\\n
+# ccache -M 2G\\n
+If you are upgrading from an older version than 3.x you should clear all of your caches like so:\\n
+# CCACHE_DIR='${CCACHE_DIR:-${PORTAGE_TMPDIR}/ccache}' ccache -C\\n
+ccache now supports sys-devel/clang and dev-lang/icc, too!"
+
+ readme.gentoo_create_doc
+}
+
+pkg_prerm() {
+ if [[ -z ${REPLACED_BY_VERSION} ]] ; then
+ "${EROOT}"/usr/bin/ccache-config --remove-links
+ "${EROOT}"/usr/bin/ccache-config --remove-links ${CHOST}
+ fi
+}
+
+pkg_postinst() {
+ "${EROOT}"/usr/bin/ccache-config --install-links
+ "${EROOT}"/usr/bin/ccache-config --install-links ${CHOST}
+
+ # nuke broken symlinks from previous versions that shouldn't exist
+ rm -f "${EROOT}"/usr/lib/ccache/bin/${CHOST}-cc
+ rm -rf "${EROOT}"/usr/lib/ccache.backup
+
+ readme.gentoo_print_elog
+}