summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2010-05-06 06:08:10 +0000
committerRyan Hill <dirtyepic@gentoo.org>2010-05-06 06:08:10 +0000
commit343d44f221ce7074d583e5b58247110230021a94 (patch)
tree7c273976183196e987466b3a1c403db96dd7d13e /dev-util/codeblocks
parentStable for HPPA (bug #315163). (diff)
downloadgentoo-2-343d44f221ce7074d583e5b58247110230021a94.tar.gz
gentoo-2-343d44f221ce7074d583e5b58247110230021a94.tar.bz2
gentoo-2-343d44f221ce7074d583e5b58247110230021a94.zip
Patch from upstream to fix building with USE="pch contrib" and new glib
versions. (bug #307603) (Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/codeblocks')
-rw-r--r--dev-util/codeblocks/ChangeLog7
-rw-r--r--dev-util/codeblocks/codeblocks-8.02-r1.ebuild3
-rw-r--r--dev-util/codeblocks/files/codeblocks-8.02-gsocket.patch35
-rw-r--r--dev-util/codeblocks/metadata.xml2
4 files changed, 44 insertions, 3 deletions
diff --git a/dev-util/codeblocks/ChangeLog b/dev-util/codeblocks/ChangeLog
index 2cb77541c644..0f41195c960b 100644
--- a/dev-util/codeblocks/ChangeLog
+++ b/dev-util/codeblocks/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/codeblocks
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/codeblocks/ChangeLog,v 1.16 2010/01/24 23:12:00 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/codeblocks/ChangeLog,v 1.17 2010/05/06 06:08:10 dirtyepic Exp $
+
+ 06 May 2010; Ryan Hill <dirtyepic@gentoo.org> codeblocks-8.02-r1.ebuild,
+ +files/codeblocks-8.02-gsocket.patch, metadata.xml:
+ Patch from upstream to fix building with USE="pch contrib" and new glib
+ versions. (bug #307603)
24 Jan 2010; Brent Baude <ranger@gentoo.org> codeblocks-8.02-r1.ebuild:
keyworded ~arch for ppc, bug 295271
diff --git a/dev-util/codeblocks/codeblocks-8.02-r1.ebuild b/dev-util/codeblocks/codeblocks-8.02-r1.ebuild
index bbef30182b33..55290709a75f 100644
--- a/dev-util/codeblocks/codeblocks-8.02-r1.ebuild
+++ b/dev-util/codeblocks/codeblocks-8.02-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/codeblocks/codeblocks-8.02-r1.ebuild,v 1.2 2010/01/24 23:12:00 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/codeblocks/codeblocks-8.02-r1.ebuild,v 1.3 2010/05/06 06:08:10 dirtyepic Exp $
inherit autotools wxwidgets flag-o-matic eutils
@@ -35,6 +35,7 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-gcc44.patch
#epatch "${FILESDIR}/${PV}-install-plugins.patch"
cd "${S}"
+ epatch "${FILESDIR}"/${P}-gsocket.patch
find src/plugins -name Makefile.am -exec \
sed -i -e 's#^libdir#pluginsdir#' \
-e 's#^lib_LTLIBRARIES#plugins_LTLIBRARIES#' \
diff --git a/dev-util/codeblocks/files/codeblocks-8.02-gsocket.patch b/dev-util/codeblocks/files/codeblocks-8.02-gsocket.patch
new file mode 100644
index 000000000000..57072e5168f7
--- /dev/null
+++ b/dev-util/codeblocks/files/codeblocks-8.02-gsocket.patch
@@ -0,0 +1,35 @@
+https://bugs.gentoo.org/307603
+http://svn.berlios.de/wsvn/codeblocks/?op=comp&compare[]=%2Ftrunk%2Fsrc%2Fplugins%2Fcontrib%2Fcodesnippets@5713&compare[]=%2Ftrunk%2Fsrc%2Fplugins%2Fcontrib%2Fcodesnippets@5716
+
+--- a/src/plugins/contrib/codesnippets/codesnippets.cpp
++++ b/src/plugins/contrib/codesnippets/codesnippets.cpp
+@@ -52,8 +52,12 @@
+ #include "memorymappedfile.h"
+
+ #if defined(__WXGTK__)
++ // hack to avoid name-conflict between wxWidgets GSocket and the one defined
++ // in newer glib-headers
++ #define GSocket GLibSocket
++ #include <gdk/gdkx.h>
++ #undef GSocket
+ #include "wx/gtk/win_gtk.h"
+- #include <gdk/gdkx.h>
+ #endif
+
+ // The plugin needs a flag ON to enable some code for the plugin
+--- a/src/plugins/contrib/codesnippets/codesnippetstreectrl.cpp
++++ b/src/plugins/contrib/codesnippets/codesnippetstreectrl.cpp
+@@ -49,8 +49,12 @@
+ #include "menuidentifiers.h"
+ #include "editsnippetframe.h"
+ #if defined(__WXGTK__)
++ // hack to avoid name-conflict between wxWidgets GSocket and the one defined
++ // in newer glib-headers
++ #define GSocket GLibSocket
++ #include <gdk/gdkx.h>
++ #undef GSocket
+ #include "wx/gtk/win_gtk.h"
+- #include <gdk/gdkx.h>
+ #endif
+
+ IMPLEMENT_DYNAMIC_CLASS(CodeSnippetsTreeCtrl, wxTreeCtrl)
diff --git a/dev-util/codeblocks/metadata.xml b/dev-util/codeblocks/metadata.xml
index 7cc466e8d38a..f3cd9a6101fc 100644
--- a/dev-util/codeblocks/metadata.xml
+++ b/dev-util/codeblocks/metadata.xml
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>no-herd</herd>
+ <herd>wxwidgets</herd>
<maintainer>
<email>jurek@gentoo.org</email>
<name>Jurek Bartuszek</name>