summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2012-11-03 17:32:27 +0000
committerMichael Weber <xmw@gentoo.org>2012-11-03 17:32:27 +0000
commit3a54b0c7f78217ec8ad326690a961abba1b0e36d (patch)
treea34664ba18993333f0b4ace737a583663b80f10a /dev-util/cppcheck
parentstable ppc ppc64, bug #441408 (diff)
downloadgentoo-2-3a54b0c7f78217ec8ad326690a961abba1b0e36d.tar.gz
gentoo-2-3a54b0c7f78217ec8ad326690a961abba1b0e36d.tar.bz2
gentoo-2-3a54b0c7f78217ec8ad326690a961abba1b0e36d.zip
Drop old.
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'dev-util/cppcheck')
-rw-r--r--dev-util/cppcheck/ChangeLog6
-rw-r--r--dev-util/cppcheck/cppcheck-1.53.ebuild77
-rw-r--r--dev-util/cppcheck/cppcheck-1.54.ebuild77
-rw-r--r--dev-util/cppcheck/cppcheck-1.55.ebuild77
4 files changed, 5 insertions, 232 deletions
diff --git a/dev-util/cppcheck/ChangeLog b/dev-util/cppcheck/ChangeLog
index 40c3f7ec4c5c..69a90030b260 100644
--- a/dev-util/cppcheck/ChangeLog
+++ b/dev-util/cppcheck/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/cppcheck
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/ChangeLog,v 1.33 2012/09/06 06:58:58 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/ChangeLog,v 1.34 2012/11/03 17:32:27 xmw Exp $
+
+ 03 Nov 2012; Michael Weber <xmw@gentoo.org> -cppcheck-1.53.ebuild,
+ -cppcheck-1.54.ebuild, -cppcheck-1.55.ebuild:
+ Drop old.
*cppcheck-1.56 (06 Sep 2012)
diff --git a/dev-util/cppcheck/cppcheck-1.53.ebuild b/dev-util/cppcheck/cppcheck-1.53.ebuild
deleted file mode 100644
index b97532e3ab17..000000000000
--- a/dev-util/cppcheck/cppcheck-1.53.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/cppcheck-1.53.ebuild,v 1.1 2012/03/13 13:47:23 xmw Exp $
-
-EAPI="3"
-PYTHON_DEPEND="htmlreport? 2"
-
-inherit distutils eutils qt4-r2 toolchain-funcs
-
-DESCRIPTION="static analyzer of C/C++ code"
-HOMEPAGE="http://apps.sourceforge.net/trac/cppcheck/"
-SRC_URI="mirror://sourceforge/cppcheck/${P}.tar.bz2"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="htmlreport qt4"
-
-DEPEND="htmlreport? ( dev-python/pygments )
- qt4? ( x11-libs/qt-gui:4
- x11-libs/qt-assistant:4 )"
-RDEPEND="${DEPEND}"
-
-DISTUTILS_SETUP_FILES=("htmlreport|setup.py")
-
-pkg_setup() {
- if use htmlreport ; then
- python_set_active_version 2
- python_pkg_setup
- fi
-}
-
-src_prepare() {
- if use htmlreport ; then
- pushd htmlreport
- python_convert_shebangs -r 2 .
- distutils_src_prepare
- popd
- fi
-}
-
-src_configure() {
- tc-export CXX
- if use qt4 ; then
- pushd gui
- qt4-r2_src_configure
- popd
- fi
-}
-
-src_compile() {
- emake || die
- if use qt4 ; then
- pushd gui
- qt4-r2_src_compile
- popd
- fi
- use htmlreport && distutils_src_compile
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die
- dodoc readme.txt || die
- if use qt4 ; then
- dobin gui/${PN}-gui || die
- dodoc readme_gui.txt gui/{projectfile.txt,gui.cppcheck} || die
- fi
- use htmlreport && distutils_src_install
-}
-
-pkg_postinst() {
- use htmlreport && distutils_pkg_postinst
-}
-
-pkg_postrm() {
- use htmlreport && distutils_pkg_postrm
-}
diff --git a/dev-util/cppcheck/cppcheck-1.54.ebuild b/dev-util/cppcheck/cppcheck-1.54.ebuild
deleted file mode 100644
index 3b1928712f1c..000000000000
--- a/dev-util/cppcheck/cppcheck-1.54.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/cppcheck-1.54.ebuild,v 1.1 2012/04/20 10:02:48 xmw Exp $
-
-EAPI="3"
-PYTHON_DEPEND="htmlreport? 2"
-
-inherit distutils eutils qt4-r2 toolchain-funcs
-
-DESCRIPTION="static analyzer of C/C++ code"
-HOMEPAGE="http://apps.sourceforge.net/trac/cppcheck/"
-SRC_URI="mirror://sourceforge/cppcheck/${P}.tar.bz2"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="htmlreport qt4"
-
-DEPEND="htmlreport? ( dev-python/pygments )
- qt4? ( x11-libs/qt-gui:4
- x11-libs/qt-assistant:4 )"
-RDEPEND="${DEPEND}"
-
-DISTUTILS_SETUP_FILES=("htmlreport|setup.py")
-
-pkg_setup() {
- if use htmlreport ; then
- python_set_active_version 2
- python_pkg_setup
- fi
-}
-
-src_prepare() {
- if use htmlreport ; then
- pushd htmlreport
- python_convert_shebangs -r 2 .
- distutils_src_prepare
- popd
- fi
-}
-
-src_configure() {
- tc-export CXX
- if use qt4 ; then
- pushd gui
- qt4-r2_src_configure
- popd
- fi
-}
-
-src_compile() {
- emake || die
- if use qt4 ; then
- pushd gui
- qt4-r2_src_compile
- popd
- fi
- use htmlreport && distutils_src_compile
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die
- dodoc readme.txt || die
- if use qt4 ; then
- dobin gui/${PN}-gui || die
- dodoc readme_gui.txt gui/{projectfile.txt,gui.cppcheck} || die
- fi
- use htmlreport && distutils_src_install
-}
-
-pkg_postinst() {
- use htmlreport && distutils_pkg_postinst
-}
-
-pkg_postrm() {
- use htmlreport && distutils_pkg_postrm
-}
diff --git a/dev-util/cppcheck/cppcheck-1.55.ebuild b/dev-util/cppcheck/cppcheck-1.55.ebuild
deleted file mode 100644
index 892cc0ba3c5a..000000000000
--- a/dev-util/cppcheck/cppcheck-1.55.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/cppcheck-1.55.ebuild,v 1.1 2012/07/05 12:44:26 xmw Exp $
-
-EAPI="3"
-PYTHON_DEPEND="htmlreport? 2"
-
-inherit distutils eutils qt4-r2 toolchain-funcs
-
-DESCRIPTION="static analyzer of C/C++ code"
-HOMEPAGE="http://apps.sourceforge.net/trac/cppcheck/"
-SRC_URI="mirror://sourceforge/cppcheck/${P}.tar.bz2"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="htmlreport qt4"
-
-DEPEND="htmlreport? ( dev-python/pygments )
- qt4? ( x11-libs/qt-gui:4
- x11-libs/qt-assistant:4 )"
-RDEPEND="${DEPEND}"
-
-DISTUTILS_SETUP_FILES=("htmlreport|setup.py")
-
-pkg_setup() {
- if use htmlreport ; then
- python_set_active_version 2
- python_pkg_setup
- fi
-}
-
-src_prepare() {
- if use htmlreport ; then
- pushd htmlreport
- python_convert_shebangs -r 2 .
- distutils_src_prepare
- popd
- fi
-}
-
-src_configure() {
- tc-export CXX
- if use qt4 ; then
- pushd gui
- qt4-r2_src_configure
- popd
- fi
-}
-
-src_compile() {
- emake || die
- if use qt4 ; then
- pushd gui
- qt4-r2_src_compile
- popd
- fi
- use htmlreport && distutils_src_compile
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die
- dodoc readme.txt || die
- if use qt4 ; then
- dobin gui/${PN}-gui || die
- dodoc readme_gui.txt gui/{projectfile.txt,gui.cppcheck} || die
- fi
- use htmlreport && distutils_src_install
-}
-
-pkg_postinst() {
- use htmlreport && distutils_pkg_postinst
-}
-
-pkg_postrm() {
- use htmlreport && distutils_pkg_postrm
-}