summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2011-04-27 21:19:02 +0000
committerMichael Weber <xmw@gentoo.org>2011-04-27 21:19:02 +0000
commit999f11dd96d918942a843a714573abf166199a09 (patch)
treed99bc780d01fbd5e48099913e815c346cb97fc0f /dev-util/cppcheck
parentRemove masks for gmpc-{q,osd} and -coveramazon (diff)
downloadgentoo-2-999f11dd96d918942a843a714573abf166199a09.tar.gz
gentoo-2-999f11dd96d918942a843a714573abf166199a09.tar.bz2
gentoo-2-999f11dd96d918942a843a714573abf166199a09.zip
Version bump
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/cppcheck')
-rw-r--r--dev-util/cppcheck/ChangeLog7
-rw-r--r--dev-util/cppcheck/cppcheck-1.48.ebuild77
2 files changed, 83 insertions, 1 deletions
diff --git a/dev-util/cppcheck/ChangeLog b/dev-util/cppcheck/ChangeLog
index 0541b67d57f9..ee9dde6597a9 100644
--- a/dev-util/cppcheck/ChangeLog
+++ b/dev-util/cppcheck/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/cppcheck
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/ChangeLog,v 1.23 2011/03/05 00:42:56 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/ChangeLog,v 1.24 2011/04/27 21:19:02 xmw Exp $
+
+*cppcheck-1.48 (27 Apr 2011)
+
+ 27 Apr 2011; Michael Weber <xmw@gentoo.org> +cppcheck-1.48.ebuild:
+ Version bump (thanks to Jaak Ristioja for the report, bug 365047)
*cppcheck-1.47 (05 Mar 2011)
diff --git a/dev-util/cppcheck/cppcheck-1.48.ebuild b/dev-util/cppcheck/cppcheck-1.48.ebuild
new file mode 100644
index 000000000000..c6c46bd821fe
--- /dev/null
+++ b/dev-util/cppcheck/cppcheck-1.48.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/cppcheck-1.48.ebuild,v 1.1 2011/04/27 21:19:02 xmw Exp $
+
+EAPI="3"
+PYTHON_DEPEND="htmlreport? 2"
+
+inherit distutils eutils qt4-r2 toolchain-funcs
+
+DESCRIPTION="static analyzer of C/C++ code"
+HOMEPAGE="http://apps.sourceforge.net/trac/cppcheck/"
+SRC_URI="mirror://sourceforge/cppcheck/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="htmlreport qt4"
+
+DEPEND="htmlreport? ( dev-python/pygments )
+ qt4? ( x11-libs/qt-gui:4
+ x11-libs/qt-assistant:4 )"
+RDEPEND="${DEPEND}"
+
+DISTUTILS_SETUP_FILES=("htmlreport|setup.py")
+
+pkg_setup() {
+ if use htmlreport ; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ if use htmlreport ; then
+ pushd htmlreport
+ python_convert_shebangs -r 2 .
+ distutils_src_prepare
+ popd
+ fi
+}
+
+src_configure() {
+ tc-export CXX
+ if use qt4 ; then
+ pushd gui
+ qt4-r2_src_configure
+ popd
+ fi
+}
+
+src_compile() {
+ emake || die
+ if use qt4 ; then
+ pushd gui
+ qt4-r2_src_compile
+ popd
+ fi
+ use htmlreport && distutils_src_compile
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc readme.txt || die
+ if use qt4 ; then
+ dobin gui/${PN}-gui || die
+ dodoc readme_gui.txt gui/{projectfile.txt,gui.cppcheck} || die
+ fi
+ use htmlreport && distutils_src_install
+}
+
+pkg_postinst() {
+ use htmlreport && distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ use htmlreport && distutils_pkg_postrm
+}