summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2012-04-20 10:02:48 +0000
committerMichael Weber <xmw@gentoo.org>2012-04-20 10:02:48 +0000
commitdcf4cd405c6eda8de41c9ab54bf5d10b58a163ee (patch)
tree50bf52f332ec766fccb833b6ca339a52b608a24c /dev-util/cppcheck
parentTry to fix radare (but keep it masked for now) (diff)
downloadgentoo-2-dcf4cd405c6eda8de41c9ab54bf5d10b58a163ee.tar.gz
gentoo-2-dcf4cd405c6eda8de41c9ab54bf5d10b58a163ee.tar.bz2
gentoo-2-dcf4cd405c6eda8de41c9ab54bf5d10b58a163ee.zip
Version bump (bug 412737, thanks David J Cozatt)
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/cppcheck')
-rw-r--r--dev-util/cppcheck/ChangeLog8
-rw-r--r--dev-util/cppcheck/cppcheck-1.51.ebuild77
-rw-r--r--dev-util/cppcheck/cppcheck-1.54.ebuild (renamed from dev-util/cppcheck/cppcheck-1.52.ebuild)2
3 files changed, 8 insertions, 79 deletions
diff --git a/dev-util/cppcheck/ChangeLog b/dev-util/cppcheck/ChangeLog
index d97e77a2dcb1..a13592135751 100644
--- a/dev-util/cppcheck/ChangeLog
+++ b/dev-util/cppcheck/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/cppcheck
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/ChangeLog,v 1.30 2012/03/13 13:47:23 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/ChangeLog,v 1.31 2012/04/20 10:02:48 xmw Exp $
+
+*cppcheck-1.54 (20 Apr 2012)
+
+ 20 Apr 2012; Michael Weber <xmw@gentoo.org> -cppcheck-1.51.ebuild,
+ -cppcheck-1.52.ebuild, +cppcheck-1.54.ebuild:
+ Version bump (bug 412737, thanks David J Cozatt)
*cppcheck-1.53 (13 Mar 2012)
diff --git a/dev-util/cppcheck/cppcheck-1.51.ebuild b/dev-util/cppcheck/cppcheck-1.51.ebuild
deleted file mode 100644
index ca7f9b94bb1f..000000000000
--- a/dev-util/cppcheck/cppcheck-1.51.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/cppcheck-1.51.ebuild,v 1.1 2011/10/15 08:50:39 xmw Exp $
-
-EAPI="3"
-PYTHON_DEPEND="htmlreport? 2"
-
-inherit distutils eutils qt4-r2 toolchain-funcs
-
-DESCRIPTION="static analyzer of C/C++ code"
-HOMEPAGE="http://apps.sourceforge.net/trac/cppcheck/"
-SRC_URI="mirror://sourceforge/cppcheck/${P}.tar.bz2"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="htmlreport qt4"
-
-DEPEND="htmlreport? ( dev-python/pygments )
- qt4? ( x11-libs/qt-gui:4
- x11-libs/qt-assistant:4 )"
-RDEPEND="${DEPEND}"
-
-DISTUTILS_SETUP_FILES=("htmlreport|setup.py")
-
-pkg_setup() {
- if use htmlreport ; then
- python_set_active_version 2
- python_pkg_setup
- fi
-}
-
-src_prepare() {
- if use htmlreport ; then
- pushd htmlreport
- python_convert_shebangs -r 2 .
- distutils_src_prepare
- popd
- fi
-}
-
-src_configure() {
- tc-export CXX
- if use qt4 ; then
- pushd gui
- qt4-r2_src_configure
- popd
- fi
-}
-
-src_compile() {
- emake || die
- if use qt4 ; then
- pushd gui
- qt4-r2_src_compile
- popd
- fi
- use htmlreport && distutils_src_compile
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die
- dodoc readme.txt || die
- if use qt4 ; then
- dobin gui/${PN}-gui || die
- dodoc readme_gui.txt gui/{projectfile.txt,gui.cppcheck} || die
- fi
- use htmlreport && distutils_src_install
-}
-
-pkg_postinst() {
- use htmlreport && distutils_pkg_postinst
-}
-
-pkg_postrm() {
- use htmlreport && distutils_pkg_postrm
-}
diff --git a/dev-util/cppcheck/cppcheck-1.52.ebuild b/dev-util/cppcheck/cppcheck-1.54.ebuild
index ef2a1bec21c5..3b1928712f1c 100644
--- a/dev-util/cppcheck/cppcheck-1.52.ebuild
+++ b/dev-util/cppcheck/cppcheck-1.54.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/cppcheck-1.52.ebuild,v 1.1 2012/02/07 03:28:20 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/cppcheck-1.54.ebuild,v 1.1 2012/04/20 10:02:48 xmw Exp $
EAPI="3"
PYTHON_DEPEND="htmlreport? 2"