summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMasatomo Nakano <nakano@gentoo.org>2005-05-16 03:05:13 +0000
committerMasatomo Nakano <nakano@gentoo.org>2005-05-16 03:05:13 +0000
commitb07c03e83ef832f04f0674762b7f6bd19d194a74 (patch)
tree3ae250271f2d9947a3ace1be975b561d1de05081 /dev-util/cvsspam/cvsspam-0.2.11-r1.ebuild
parentdont run iconv when cross-compiling #92695 (diff)
downloadgentoo-2-b07c03e83ef832f04f0674762b7f6bd19d194a74.tar.gz
gentoo-2-b07c03e83ef832f04f0674762b7f6bd19d194a74.tar.bz2
gentoo-2-b07c03e83ef832f04f0674762b7f6bd19d194a74.zip
added two patches to fix bug
(Portage version: 2.0.51.21-r1)
Diffstat (limited to 'dev-util/cvsspam/cvsspam-0.2.11-r1.ebuild')
-rw-r--r--dev-util/cvsspam/cvsspam-0.2.11-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-util/cvsspam/cvsspam-0.2.11-r1.ebuild b/dev-util/cvsspam/cvsspam-0.2.11-r1.ebuild
new file mode 100644
index 000000000000..ae24343ccbfb
--- /dev/null
+++ b/dev-util/cvsspam/cvsspam-0.2.11-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cvsspam/cvsspam-0.2.11-r1.ebuild,v 1.1 2005/05/16 03:05:13 nakano Exp $
+
+inherit eutils
+
+DESCRIPTION="Utility to send colored HTML CVS-mails"
+SRC_URI="http://www.badgers-in-foil.co.uk/projects/cvsspam/${P}.tar.gz"
+HOMEPAGE="http://www.badgers-in-foil.co.uk/projects/cvsspam/"
+LICENSE="GPL-2"
+DEPEND="virtual/libc"
+RDEPEND="dev-lang/ruby"
+KEYWORDS="~x86 ~ppc"
+SLOT="0"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gentoo.patch
+}
+
+src_install() {
+ dobin collect_diffs.rb || die
+ dobin cvsspam.rb || die
+ dobin record_lastdir.rb || die
+ insinto /etc/cvsspam || die
+ doins cvsspam.conf || die
+
+ dohtml cvsspam-doc.html
+ dodoc COPYING CREDITS TODO cvsspam-doc.pdf
+}