summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-02-07 01:04:39 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-02-07 01:04:39 +0000
commit06a762f64afc3f44b08e01ba7953aaf9a710acb5 (patch)
treee51134aa256f34f1202c983750957e39d7800f40 /dev-util/eric
parentChange giggle dependency to require >=autoconf-2.64. Since this would break ... (diff)
downloadgentoo-2-06a762f64afc3f44b08e01ba7953aaf9a710acb5.tar.gz
gentoo-2-06a762f64afc3f44b08e01ba7953aaf9a710acb5.tar.bz2
gentoo-2-06a762f64afc3f44b08e01ba7953aaf9a710acb5.zip
Use PYTHON_DEPEND instead of NEED_PYTHON. Simplify code in pkg_postinst().
(Portage version: 15325-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/eric')
-rw-r--r--dev-util/eric/eric-4.4.1.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/dev-util/eric/eric-4.4.1.ebuild b/dev-util/eric/eric-4.4.1.ebuild
index ec96f0b43104..03d054e17b91 100644
--- a/dev-util/eric/eric-4.4.1.ebuild
+++ b/dev-util/eric/eric-4.4.1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/eric-4.4.1.ebuild,v 1.1 2010/02/06 14:49:02 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/eric-4.4.1.ebuild,v 1.2 2010/02/07 01:04:39 arfrever Exp $
EAPI="2"
-NEED_PYTHON="2.6"
+PYTHON_DEPEND="2:2.6"
SUPPORT_PYTHON_ABIS="1"
inherit eutils python
@@ -36,6 +36,7 @@ for L in ${LANGS}; do
linguas_${L}? ( mirror://sourceforge/eric-ide/${MY_PN}-i18n-${L/zh_CN/zh_CN.GB2312}-${PV}.tar.gz )"
IUSE="${IUSE} linguas_${L}"
done
+unset L
S="${WORKDIR}/${MY_P}"
@@ -70,7 +71,7 @@ pkg_postinst() {
elog
elog "If you want to use eric4 with mod_python, have a look at"
- elog "\"${ROOT}usr/$(get_libdir)/python$(PYTHON -f --ABI)/site-packages/eric4/patch_modpython.py\"."
+ elog "\"${ROOT%/}$(python_get_sitedir -f)/eric4/patch_modpython.py\"."
elog
elog "The following packages will give eric extended functionality:"
elog " dev-python/pylint"