summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-01-04 03:21:26 +0000
committerMike Frysinger <vapier@gentoo.org>2005-01-04 03:21:26 +0000
commit5fcad41bf3622439eafb12b693f365b14619a0d3 (patch)
tree8b991404cb1f3cc200ea1383eba93f3e2da456e4 /dev-util/indent/indent-2.2.9-r2.ebuild
parentReally fix compilation without X, changed use flag from gtk to X (Manifest re... (diff)
downloadgentoo-2-5fcad41bf3622439eafb12b693f365b14619a0d3.tar.gz
gentoo-2-5fcad41bf3622439eafb12b693f365b14619a0d3.tar.bz2
gentoo-2-5fcad41bf3622439eafb12b693f365b14619a0d3.zip
Incorporate debian patches and fix usage segfault #71690.
Diffstat (limited to 'dev-util/indent/indent-2.2.9-r2.ebuild')
-rw-r--r--dev-util/indent/indent-2.2.9-r2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-util/indent/indent-2.2.9-r2.ebuild b/dev-util/indent/indent-2.2.9-r2.ebuild
new file mode 100644
index 000000000000..31eef4502514
--- /dev/null
+++ b/dev-util/indent/indent-2.2.9-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/indent/indent-2.2.9-r2.ebuild,v 1.1 2005/01/04 03:21:26 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="Indent program source files"
+HOMEPAGE="http://www.gnu.org/software/indent/indent.html"
+SRC_URI="mirror://gnu/indent/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sparc x86"
+IUSE="nls"
+
+DEPEND="virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PV}-deb-gentoo.patch
+}
+
+src_compile() {
+ econf $(use_enable nls) || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS NEWS README*
+ dohtml "${D}"/usr/doc/indent/*
+ rm -r "${D}"/usr/doc
+}