summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2004-09-19 01:04:41 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2004-09-19 01:04:41 +0000
commit0527fe1b0bc7f195a09d84a284cbe43e829af834 (patch)
tree03a22d419fc5adbb709a8292667779bcbf3f2bf7 /dev-util/its4/its4-1.1.1.ebuild
parentRemoved EMBOSS support in "app-sci/staden". (diff)
downloadgentoo-2-0527fe1b0bc7f195a09d84a284cbe43e829af834.tar.gz
gentoo-2-0527fe1b0bc7f195a09d84a284cbe43e829af834.tar.bz2
gentoo-2-0527fe1b0bc7f195a09d84a284cbe43e829af834.zip
Initial commit. Ebuild by Robin H. Johnson <robbat2@gentoo.org>.
Diffstat (limited to 'dev-util/its4/its4-1.1.1.ebuild')
-rw-r--r--dev-util/its4/its4-1.1.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-util/its4/its4-1.1.1.ebuild b/dev-util/its4/its4-1.1.1.ebuild
new file mode 100644
index 000000000000..8fbfa0cafbb0
--- /dev/null
+++ b/dev-util/its4/its4-1.1.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/its4/its4-1.1.1.ebuild,v 1.1 2004/09/19 01:04:41 robbat2 Exp $
+
+DESCRIPTION="ITS4: Software Security Tool"
+HOMEPAGE="http://www.cigital.com/its4/"
+SRC_URI="${P}.tgz"
+LICENSE="ITS4"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="sys-devel/gcc virtual/libc"
+RESTRICT="nomirror fetch"
+#RDEPEND=""
+S="${WORKDIR}/${PN}"
+
+pkg_nofetch() {
+ einfo "Please visit ${HOMEPAGE} to download the source, and place it in"
+ einfo "${DISTDIR}"
+}
+
+src_compile() {
+ # WARNING
+ # non-standard configure
+ # do NOT use econf
+ ./configure --prefix=/usr --mandir=/usr/share/man --datadir=/usr/share/its4 || die "configure failed"
+ emake OPTIMIZATION="${CXXFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ # WARNING
+ # non-standard, do NOT use einstall or 'make install DESTDIR=...'
+ make install INSTALL_BINDIR="${D}/usr/bin" INSTALL_MANDIR="${D}/usr/share/man" INSTALL_DATADIR="${D}/usr/share/its4" || die "install failed"
+}