summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <abcd@gentoo.org>2009-11-13 07:50:25 +0000
committerJonathan Callen <abcd@gentoo.org>2009-11-13 07:50:25 +0000
commit30acfb428a1d836280f0146dcdd7d69f65414f44 (patch)
treeb50b373e7d6a48b70281b57e23956ce1059c0c87 /dev-util/kdbg
parentDrop unused file (diff)
downloadgentoo-2-30acfb428a1d836280f0146dcdd7d69f65414f44.tar.gz
gentoo-2-30acfb428a1d836280f0146dcdd7d69f65414f44.tar.bz2
gentoo-2-30acfb428a1d836280f0146dcdd7d69f65414f44.zip
Drop unused file
(Portage version: -svn/cvs/Linux i686)
Diffstat (limited to 'dev-util/kdbg')
-rw-r--r--dev-util/kdbg/ChangeLog6
-rw-r--r--dev-util/kdbg/files/kdbg-2.1.1-glibc-2.10.patch55
2 files changed, 5 insertions, 56 deletions
diff --git a/dev-util/kdbg/ChangeLog b/dev-util/kdbg/ChangeLog
index 252c92f30975..d2ef4695e7e8 100644
--- a/dev-util/kdbg/ChangeLog
+++ b/dev-util/kdbg/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/kdbg
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/kdbg/ChangeLog,v 1.65 2009/10/05 02:41:45 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/kdbg/ChangeLog,v 1.66 2009/11/13 07:50:25 abcd Exp $
+
+ 13 Nov 2009; Jonathan Callen <abcd@gentoo.org>
+ -files/kdbg-2.1.1-glibc-2.10.patch:
+ Drop unused file
05 Oct 2009; Ryan Hill <dirtyepic@gentoo.org> kdbg-2.2.0.ebuild,
+files/kdbg-2.2.0-glibc-2.10.patch:
diff --git a/dev-util/kdbg/files/kdbg-2.1.1-glibc-2.10.patch b/dev-util/kdbg/files/kdbg-2.1.1-glibc-2.10.patch
deleted file mode 100644
index fb340d284ae8..000000000000
--- a/dev-util/kdbg/files/kdbg-2.1.1-glibc-2.10.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-diff -rupN kdbg-2.1.1.old/kdbg/gdbdriver.cpp kdbg-2.1.1.new/kdbg/gdbdriver.cpp
---- kdbg-2.1.1.old/kdbg/gdbdriver.cpp 2008-11-17 17:17:55.000000000 -0500
-+++ kdbg-2.1.1.new/kdbg/gdbdriver.cpp 2009-08-01 22:08:53.000000000 -0400
-@@ -133,7 +133,7 @@ GdbDriver::GdbDriver() :
-
- #ifndef NDEBUG
- // check command info array
-- char* perc;
-+ const char* perc;
- for (int i = 0; i < NUM_CMDS; i++) {
- // must be indexable by DbgCommand values, i.e. sorted by DbgCommand values
- assert(i == cmds[i].cmd);
-@@ -669,7 +669,7 @@ static bool parseErrorMessage(const char
- // skip warnings
- while (strncmp(output, "warning:", 8) == 0)
- {
-- char* end = strchr(output+8, '\n');
-+ const char* end = strchr(output+8, '\n');
- if (end == 0)
- output += strlen(output);
- else
-@@ -1880,8 +1880,10 @@ bool GdbDriver::parseThreadList(const ch
- p++;
- // there follows only whitespace
- }
-- char* end;
-- id = strtol(p, &end, 10);
-+ const char* end;
-+ char *end_p; /* we need a non-const version to pass to strtol */
-+ id = strtol(p, &end_p, 10);
-+ end = end_p;
- if (p == end) {
- // syntax error: no number found; bail out
- return true;
-diff -rupN kdbg-2.1.1.old/kdbg/xsldbgdriver.cpp kdbg-2.1.1.new/kdbg/xsldbgdriver.cpp
---- kdbg-2.1.1.old/kdbg/xsldbgdriver.cpp 2008-12-18 16:01:58.000000000 -0500
-+++ kdbg-2.1.1.new/kdbg/xsldbgdriver.cpp 2009-08-01 22:09:19.000000000 -0400
-@@ -114,7 +114,7 @@ DebuggerDriver(), m_gdbMajor(2), m_gdbMi
-
- #ifndef NDEBUG
- // check command info array
-- char *perc;
-+ const char *perc;
-
- for (int i = 0; i < NUM_CMDS; i++) {
- // must be indexable by DbgCommand values, i.e. sorted by DbgCommand values
-@@ -768,7 +768,7 @@ parseVar(const char *&s)
- } else if (strncmp(p, "= ", 2) == 0) {
- /* we're processing the result of a "print command" */
- /* find next line */
-- char *nextLine = strchr(p, '\n');
-+ const char *nextLine = strchr(p, '\n');
-
- TRACE("Found print expr");
- if (nextLine) {