summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2006-10-20 16:38:53 +0000
committerCarsten Lohrke <carlo@gentoo.org>2006-10-20 16:38:53 +0000
commite5019b5e2fbe82f8fc27db5f5fae72286c150475 (patch)
tree00d435be8507d8b4c89956f38e577a02946be916 /dev-util/kscope/kscope-1.4.2.ebuild
parentMark 2.14.4 stable on alpha (diff)
downloadgentoo-2-e5019b5e2fbe82f8fc27db5f5fae72286c150475.tar.gz
gentoo-2-e5019b5e2fbe82f8fc27db5f5fae72286c150475.tar.bz2
gentoo-2-e5019b5e2fbe82f8fc27db5f5fae72286c150475.zip
Version bump.
(Portage version: 2.1.2_pre3-r5)
Diffstat (limited to 'dev-util/kscope/kscope-1.4.2.ebuild')
-rw-r--r--dev-util/kscope/kscope-1.4.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-util/kscope/kscope-1.4.2.ebuild b/dev-util/kscope/kscope-1.4.2.ebuild
new file mode 100644
index 000000000000..e012ebeeda5d
--- /dev/null
+++ b/dev-util/kscope/kscope-1.4.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/kscope/kscope-1.4.2.ebuild,v 1.1 2006/10/20 16:38:53 carlo Exp $
+
+inherit kde
+
+DESCRIPTION="KScope is a KDE front-end to Cscope."
+HOMEPAGE="http://kscope.sourceforge.net/"
+SRC_URI="mirror://sourceforge/kscope/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="|| ( kde-base/kate kde-base/kdebase )"
+RDEPEND="${DEPEND}
+ media-gfx/graphviz
+ dev-util/ctags
+ >=dev-util/cscope-15.5-r4"
+
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ sys-devel/bison"
+
+need-kde 3.2
+
+src_install() {
+ kde_src_install
+
+ dodir /usr/share/applications/kde
+ mv ${D}/usr/share/applnk/Development/kscope.desktop \
+ ${D}/usr/share/applications/kde
+
+ insinto /usr/share/config
+ doins "${FILESDIR}/${PN}rc"
+}
+