summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDamien Krotkine <dams@gentoo.org>2005-08-27 18:51:20 +0000
committerDamien Krotkine <dams@gentoo.org>2005-08-27 18:51:20 +0000
commit119f2fc2c05c4e637f41ffb2fd3918ff029eaf50 (patch)
tree80118e9607997da4e9f6c05ba34ec0707c800dfb /dev-util/libconf/libconf-0.40.00.ebuild
parentstabilize for security bug #103661 (diff)
downloadgentoo-2-119f2fc2c05c4e637f41ffb2fd3918ff029eaf50.tar.gz
gentoo-2-119f2fc2c05c4e637f41ffb2fd3918ff029eaf50.tar.bz2
gentoo-2-119f2fc2c05c4e637f41ffb2fd3918ff029eaf50.zip
major version bump
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'dev-util/libconf/libconf-0.40.00.ebuild')
-rw-r--r--dev-util/libconf/libconf-0.40.00.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-util/libconf/libconf-0.40.00.ebuild b/dev-util/libconf/libconf-0.40.00.ebuild
new file mode 100644
index 000000000000..5e3945282c4c
--- /dev/null
+++ b/dev-util/libconf/libconf-0.40.00.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/libconf/libconf-0.40.00.ebuild,v 1.1 2005/08/27 18:51:20 dams Exp $
+
+IUSE=""
+
+MY_P=perl-${PN/l/L}-${PV}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Centralized abstraction layer for system configuration files"
+HOMEPAGE="http://libconf.net/"
+SRC_URI="http://libconf.net/download/${MY_P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ia64 ppc ~ppc64 ~sparc x86"
+
+DEPEND="dev-lang/perl
+dev-perl/DelimMatch
+xml? ( dev-perl/Data-DumpXML )"
+
+src_compile() {
+ emake || die "make failed"
+ make test || die "make test failed"
+}
+
+src_install() {
+ einstall PREFIX=${D}/usr
+ dodoc AUTHORS COPYING ChangeLog
+}