summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-02-11 22:40:50 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-02-11 22:40:50 +0000
commitb4960b3a1e904223a27cd1c94e53d819976e4fd3 (patch)
tree095c5c6181873f58027522a3464818d01a3b453a /dev-util/meld/meld-1.1.5.1-r1.ebuild
parent* fix python eclass use, bug #207667 (diff)
downloadgentoo-2-b4960b3a1e904223a27cd1c94e53d819976e4fd3.tar.gz
gentoo-2-b4960b3a1e904223a27cd1c94e53d819976e4fd3.tar.bz2
gentoo-2-b4960b3a1e904223a27cd1c94e53d819976e4fd3.zip
* fix python eclass use, bug #207667
(Portage version: 2.1.4.1)
Diffstat (limited to 'dev-util/meld/meld-1.1.5.1-r1.ebuild')
-rw-r--r--dev-util/meld/meld-1.1.5.1-r1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-util/meld/meld-1.1.5.1-r1.ebuild b/dev-util/meld/meld-1.1.5.1-r1.ebuild
new file mode 100644
index 000000000000..ff2deb26c313
--- /dev/null
+++ b/dev-util/meld/meld-1.1.5.1-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/meld/meld-1.1.5.1-r1.ebuild,v 1.1 2008/02/11 22:40:50 eva Exp $
+
+inherit python gnome2 eutils multilib
+
+DESCRIPTION="A graphical (GNOME 2) diff and merge tool"
+HOMEPAGE="http://meld.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc gnome"
+
+RDEPEND=">=dev-lang/python-2.3
+ >=gnome-base/libglade-2
+ >=gnome-base/libgnome-2
+ >=dev-python/gnome-python-2.6.0
+ >=dev-python/pygtk-2.6.0
+ >=dev-python/pyorbit-1.99.0
+ gnome? ( dev-python/gnome-python-desktop )"
+
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ app-text/scrollkeeper"
+
+DOCS="AUTHORS README.CVS changelog help/"
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # fix the prefix so its not in */local/*
+ sed -i -e 's:/usr/local:/usr:' INSTALL
+ sed -i -e "s:\$(prefix)/lib:\$(prefix)/$(get_libdir):" INSTALL
+
+ # let the python eclass handle python objects
+ sed -i -e '/$(PYTHON) .* .import compileall;/s/\t/&#/g' GNUmakefile
+
+ # don't run scrollkeeper (with the wrong path), leave that to gnome2.eclass #145833
+ sed -i -e '/scrollkeeper-update/s/\t/&#/' help/*/GNUmakefile
+}
+
+src_compile() {
+ emake || die "make failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/$(get_libdir)/meld
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/$(get_libdir)/meld
+}