summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2010-08-10 17:10:26 +0000
committerFabio Erculiani <lxnay@gentoo.org>2010-08-10 17:10:26 +0000
commit91c3e20c79852bef25f996d6386256834bc445b1 (patch)
tree0a6fc7721ef7128336705eec07d0962a7bb82f47 /dev-util/molecule
parentStable on amd64 wrt bug #331761 (diff)
downloadgentoo-2-91c3e20c79852bef25f996d6386256834bc445b1.tar.gz
gentoo-2-91c3e20c79852bef25f996d6386256834bc445b1.tar.bz2
gentoo-2-91c3e20c79852bef25f996d6386256834bc445b1.zip
version bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/molecule')
-rw-r--r--dev-util/molecule/ChangeLog7
-rw-r--r--dev-util/molecule/molecule-0.9.20.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/dev-util/molecule/ChangeLog b/dev-util/molecule/ChangeLog
index bf61a9c27321..c88948ed6990 100644
--- a/dev-util/molecule/ChangeLog
+++ b/dev-util/molecule/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/molecule
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/molecule/ChangeLog,v 1.13 2010/07/23 09:08:46 lxnay Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/molecule/ChangeLog,v 1.14 2010/08/10 17:10:26 lxnay Exp $
+
+*molecule-0.9.20 (10 Aug 2010)
+
+ 10 Aug 2010; Fabio Erculiani <lxnay@gentoo.org> +molecule-0.9.20.ebuild:
+ version bump
*molecule-0.9.12 (23 Jul 2010)
diff --git a/dev-util/molecule/molecule-0.9.20.ebuild b/dev-util/molecule/molecule-0.9.20.ebuild
new file mode 100644
index 000000000000..e58aaa991937
--- /dev/null
+++ b/dev-util/molecule/molecule-0.9.20.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/molecule/molecule-0.9.20.ebuild,v 1.1 2010/08/10 17:10:26 lxnay Exp $
+
+EAPI="2"
+PYTHON_DEPEND="*"
+
+inherit multilib python
+
+DESCRIPTION="Release metatool used for creating Sabayon (and Gentoo) releases"
+HOMEPAGE="http://www.sabayon.org"
+SRC_URI="http://distfiles.sabayon.org/dev-util/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-util/intltool
+ sys-devel/gettext"
+RDEPEND="net-misc/rsync
+ sys-fs/squashfs-tools
+ virtual/cdrtools"
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="/usr/$(get_libdir)" \
+ PREFIX="/usr" SYSCONFDIR="/etc" install \
+ || die "emake install failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize "/usr/$(get_libdir)/molecule"
+}
+
+pkg_postrm() {
+ python_mod_cleanup "/usr/$(get_libdir)/molecule"
+}