summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Johanson <latexer@gentoo.org>2005-10-15 22:58:04 +0000
committerPeter Johanson <latexer@gentoo.org>2005-10-15 22:58:04 +0000
commit7af2370847eb32f92ca96ac82b37d32ed8f121f3 (patch)
tree2c7d29d55efc54b117261f93812d76bf47645a53 /dev-util/mono-tools/mono-tools-1.1.9.ebuild
parentAdded ~sparc keyword. (diff)
downloadgentoo-2-7af2370847eb32f92ca96ac82b37d32ed8f121f3.tar.gz
gentoo-2-7af2370847eb32f92ca96ac82b37d32ed8f121f3.tar.bz2
gentoo-2-7af2370847eb32f92ca96ac82b37d32ed8f121f3.zip
First commit. Includes the GUI browser previously found in the monodoc package, plus a few other programs.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'dev-util/mono-tools/mono-tools-1.1.9.ebuild')
-rw-r--r--dev-util/mono-tools/mono-tools-1.1.9.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-util/mono-tools/mono-tools-1.1.9.ebuild b/dev-util/mono-tools/mono-tools-1.1.9.ebuild
new file mode 100644
index 000000000000..3e24a4a3756c
--- /dev/null
+++ b/dev-util/mono-tools/mono-tools-1.1.9.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/mono-tools/mono-tools-1.1.9.ebuild,v 1.1 2005/10/15 22:58:04 latexer Exp $
+
+inherit mono
+
+DESCRIPTION="Set of useful Mono related utilities"
+HOMEPAGE="http://www.mono-project.com/"
+SRC_URI="http://www.go-mono.com/sources/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="dev-lang/mono
+ >=dev-util/monodoc-${PV}
+ =dev-dotnet/gtk-sharp-1.0*
+ =dev-dotnet/gnome-sharp-1.0*
+ =dev-dotnet/glade-sharp-1.0*
+ =dev-dotnet/gtkhtml-sharp-1.0*
+ =dev-dotnet/gconf-sharp-1.0*
+ <dev-dotnet/gecko-sharp-0.10"
+
+src_compile() {
+ econf || die
+ emake -j1 || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc ChangeLog README
+}